locked
Video Resolution not staying set issue RRS feed

  • General discussion

  • Hi, I've got a MESH PC with an Nvidia 8400GS video card in - running Vista Home Premium SP1

    On boot the res changes to the lowest possible, before occasionally sorting itself out.

    Otherwise I have to manually set it to the correct res.

    Things I've already tried.

    Latest drivers

    Swapped the video card

    Cleaned up the registry

     

    I've seen a few threads around the net around this but with no real solution. Can anyone help please ?

     

    Tuesday, January 27, 2009 8:21 PM

All replies

  •  

     

    Hi,

     

    Based on my research, the issue can be caused by the incorrect system configuration and please check the settings with the following steps:

     

    1.    Click the Start Button type "msconfig" (without quotation marks) in the Search box, and then press Enter.

    Note: If prompted, please click Continue on the User Account Control (UAC) window.

    2.    Go to the "Boot" tab, and check if the "Base video" box on the “Boot options” has been checked or not.

     

    If the "Base video" box has been checked, please uncheck it and click OK. After restarting the computer, please see if it works.

     

    Thanks.

     


    Nicholas Li - MSFT
    Monday, February 2, 2009 8:37 AM
    Moderator
  • Yes, thanks I will give this a try and post back.
    Tuesday, February 3, 2009 7:00 AM
  • Confirmed,  Base video box is UN checked

    Any other ideas please ?
    Wednesday, February 4, 2009 7:09 AM
  •  

     

    Hi,

     

    Thank you for updating.

     

    Based on the current situation, we need perform further research on the issue, please help us collect the following information:

     

    1) Click Start, type: REGEGIT in the Start Search bar and then press Enter. Click Continue if it prompts.

    2) Navigate to the following registry keys

     

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Hardware Profiles\Current\System\CurrentControlSet\SERVICES\IALM\DEVICE0]

     

    3) Right click the Class entry, choose "Export", select Desktop in the Save in box and type Class in File Name. Click Save.

     

    4) Please also save the following keys with step 2) and 3):

     

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Hardware Profiles\Current\System\CurrentControlSet\SERVICES\IALM\DEVICE0\Mon80861100]

     

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Hardware Profiles\0001\System\CurrentControlSet\SERVICES\IALM\DEVICE0]

     

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Hardware Profiles\0001\System\CurrentControlSet\SERVICES\IALM\DEVICE0\Mon80861100]

     

    [HKEY_CURRENT_CONFIG\System\CurrentControlSet\SERVICES\IALM\DEVICE0]

     

    [HKEY_CURRENT_CONFIG\System\CurrentControlSet\SERVICES\IALM\DEVICE0\Mon80861100]

     

    5) Exit the Registry Editor.

    6) Please zip the files to one package and use Windows Live SkyDrive (http://www.skydrive.live.com/) to upload to file to the Internet, then share its URL with me.

     

    Thank you for your efforts and cooperation.

     


    Nicholas Li - MSFT
    Friday, February 6, 2009 2:26 AM
    Moderator
  • Hi, after following your instructions it appears the key is not there.

    I've uploaded a screen shot of the registry entries close to where you wanted the export done from.

    Uploaded Registry Screenshot

    Thanks




    Sunday, February 15, 2009 10:30 AM
  •  

    Hi,

     

    Thank you for updating.

     

    I suspect the registry was corrupted as the related key didn’t exist. Let’s try to create the keys to see if it works.

     

    1.    Navigate to the following registry key

     

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Hardware Profiles\Current\System\CurrentControlSet\SERVICES\IALM\DEVICE0]

     

    2.    On the Edit menu, point to New, and then click DWORD Value.

    3.    In the New Value #1 box, type DefaultSettings.XResolution, and then press ENTER.

    4.    Right-click DefaultSettings.XResolution, and then click Modify.

    5.    In the Value data box, type the value 5a0, and then click OK.

    6.    Create a DWORD Value named “DefaultSettings.YResolution” and set its value to 384 according the steps 2-5.

    7.    Please also create the keys to the following directories:

     

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Hardware Profiles\Current\System\CurrentControlSet\SERVICES\IALM\DEVICE0\Mon80861100]

     

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Hardware Profiles\0001\System\CurrentControlSet\SERVICES\IALM\DEVICE0]

     

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Hardware Profiles\0001\System\CurrentControlSet\SERVICES\IALM\DEVICE0\Mon80861100]

     

    [HKEY_CURRENT_CONFIG\System\CurrentControlSet\SERVICES\IALM\DEVICE0]

     

    [HKEY_CURRENT_CONFIG\System\CurrentControlSet\SERVICES\IALM\DEVICE0\Mon80861100]

     

    8.    After creating all the keys successfully, reboot the computer and check the results.

     

    Hope this helps. Thanks.

     


    Nicholas Li - MSFT
    Friday, February 20, 2009 8:50 AM
    Moderator
  • Hi,

    I can't see what you mean in the last section - create keys to the following directories - could you advise please ?

    Thanks
    Saturday, March 7, 2009 1:01 PM
  •  

    Hi,

     

    Thank you for your response.

     

    Let's try another way:

     

    Please open a notepad, copy and paste the following (between the two lines) to the notepad and save it as a ".reg" file (such as video.reg):

    =======================

     

    Windows Registry Editor Version 5.00

     

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Hardware Profiles\Current\System\CurrentControlSet\SERVICES\IALM\DEVICE0]

    "DefaultSettings.XResolution"=dword:000005a0

    "DefaultSettings.YResolution"=dword:00000384

     

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Hardware Profiles\Current\System\CurrentControlSet\SERVICES\IALM\DEVICE0\Mon80861100]

    "DefaultSettings.XResolution"=dword:000005a0

    "DefaultSettings.YResolution"=dword:00000384

     

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Hardware Profiles\0001\System\CurrentControlSet\SERVICES\IALM\DEVICE0]

    "DefaultSettings.XResolution"=dword:000005a0

    "DefaultSettings.YResolution"=dword:00000384

     

     [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Hardware Profiles\0001\System\CurrentControlSet\SERVICES\IALM\DEVICE0\Mon80861100]

    "DefaultSettings.XResolution"=dword:000005a0

    "DefaultSettings.YResolution"=dword:00000384

     

    [HKEY_CURRENT_CONFIG\System\CurrentControlSet\SERVICES\IALM\DEVICE0]

    "DefaultSettings.XResolution"=dword:000005a0

    "DefaultSettings.YResolution"=dword:00000384

     

     [HKEY_CURRENT_CONFIG\System\CurrentControlSet\SERVICES\IALM\DEVICE0\Mon80861100]

    "DefaultSettings.XResolution"=dword:000005a0

    "DefaultSettings.YResolution"=dword:00000384

     

    ==========================

    Then double click the .reg file to apply the settings. When a message indicating the operation is successful appears, please reboot the computer to see if it works.

     

    Thanks.


    Nicholas Li - MSFT
    Monday, March 9, 2009 11:09 AM
    Moderator
  • Urgh I'm having this same exact problem as this guy.  The registry keys get so confusing in this area.

    I'm noticing that it looks like there is registry keys set up for different resolutions.

    I have my computer set up for 1766x996  with 32 bit color and 59Hz refresh rate.  This is because I have my computer set up to my 1080p HDTV and I'm using a DVI to HDMI cable to connect it.

    When I start my computer the DOS screen is in a very small resolution like in a little box.  Obviously because the drivers haven't loaded yet.  Then when the Welcome screen pops up the resolution changes to either 800x600 or 1024x768 then flickers to a black screen then changes back to the way I had it....then switches back AGAIN then finally goes back to my normal settings.

    I have a feeling that these registry keys are making the computer think that there's multiple resolutions and it's going nuts during startup.  I NEVER had this problem using Windows XP.  But ever since I upgraded to Vista x64 SP2 I've had this problem like crazy.

    I noticed the guy didn't follow up on this....can you please help me instead and change that dword coding to work with my resolution??  1766x996
    Tuesday, July 7, 2009 11:45 AM