WMI Access denied RRS feed

  • Question

  • Symptoms:
      When I right-click on WMI Control and go to properties I get an "unable to connect to <local computer>" and "access is denied."
      Windows Installer service is unable to start and I am unable to install applications.
      In the System event log:
        Event ID 1015, source: MsiInstaller, description "Failed to connect to server. Error: 0x80070005"
        Event ID 1802, source: SecurityCenter, description "The Windows Security Center Service was unable to establish event queries with WMI to monitor third party AntiVirus and Firewall."

    Things I have tried:
        Installed Windows XP SP3 from a sysprep image
        Installed Windows XP SP3 from orignal OEM CD
        Uninstalling SMNP and WMI monitoring tools
        Running sfc /scannow  (no errors)
        Not installing or uninstalling Symantec EndPoint protection

    The workstation is normally joined to the domain and in the same context as all other workstations.  I haven't ever had this issue on any workstation on any network anywhere.

    I can still get access denied when the workstation is not joined to the domain.

    Thanks in advance for your time and attention.

    Monday, June 15, 2009 9:14 PM


All replies

  • Hi Precise,

    Try to diagnose WMI with the WMIDiag tool.
    It is a free download on the microsoft download site.

    If the following wmidiag doesn't work for you try to repair your WMI.

    Does this resolve your problem?

    Kind Regards
    IM me
    • Proposed as answer by daft Monday, June 15, 2009 9:39 PM
    • Edited by daft Monday, June 15, 2009 9:40 PM spelling mistakes :p
    Monday, June 15, 2009 9:39 PM
  • You may receive an “0x80070005: Access is denied" error message when you create a scheduled task on a Windows XP-based computer after you install security update 841873. Check it Microsoft tool and fixed: http://support.microsoft.com/hotfix/KBHotfix.aspx?kbnum=904423&kbln=en-us
    Thursday, July 15, 2010 9:28 PM
  • I spent many hours trying to solve this problem i.e. Error 0x80070005 "Access is denied". I ran the WMIDiag diagnostics tool and it reported everything was OK. I finally discovered that if "Use Simple File Sharing (Recommended)" is checked in the Folder Options -> View menu then WMI simply does not work. I would have thought that this would have been reported by the diagnostics tool but sadly not. 

    Hope that saves some people a several hours of frustration :-)

    Best wishes,


    Monday, February 25, 2013 2:29 PM
  • Thank you very much man :)

    you're awesome!!

    I had same problem & and for my sorry and my bad luck I also spent many hours sadly :(((

    after unchecking simple file sharing everying went right :)

    thanks again..

    Tuesday, September 17, 2013 11:17 PM