locked
Fail to download file with explorer 10 while explorer 9 and other browsers succeed to download the same file RRS feed

  • Question

  • I try to download file from management website of switch device. The file size is 11.66K.

    The webserver is GoAhead, OS is windows7 and explorer version is 10 (it also happens with explorer 11). The server is using Transfer-Encoding: chunked.

    After I download the file, I get pop-up message from the browser “Do you want to open or save running-config.txt from 1.1.1.11?”

    If I press the save/open button I get message “running-config .txt couldn’t be downloaded”. If I press the retry button the file is downloaded successfully.

    When I used meddler to debug the problem, it didn’t occur and the file was downloaded successfully.

    I took capture of successful download (with meddler debugger) and  another capture of download that raised “couldn’t be downloaded” message, but I didn’t see any difference between the requests and the responses. I also made sure the last chunk “0” was not missing in the response and it wasn’t.

    Please note, I also tried many suggestions given to other users that reported similar problem – restart explorer, remove add-ons, etc – nothing worked!

    Please help.

    Sunday, April 13, 2014 7:39 AM

Answers

  • Hi,

    Did  this issue occur on when you download file from other website?

    This problem occurs if the Do not save encrypted pages to disk option in Internet Explorer is selected.

    To fix this issue, try these methods:

    Methods 1

    On the Tools menu in Internet Explorer, click Internet Options, click the Advanced tab, click to clear the check mark from the Do not save encrypted pages to disk check box in the Security area, and then click OK. (This is the default Internet Explorer setting.)

    Methods 2

    1.Start Registry Editor.
    2.For a per-user setting, locate the following registry key:

    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings

    For a per-computer setting, locate the following registry key:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings

    3.On the Edit menu, click Add Value, and then add the following value:

    "BypassSSLNoCacheCheck"=Dword:00000001

    4.Exit Registry Editor


    Karen Hu
    TechNet Community Support

    • Marked as answer by 暁北 Wednesday, April 23, 2014 2:03 AM
    Tuesday, April 15, 2014 8:39 AM

All replies

  • Hi,

    Did  this issue occur on when you download file from other website?

    This problem occurs if the Do not save encrypted pages to disk option in Internet Explorer is selected.

    To fix this issue, try these methods:

    Methods 1

    On the Tools menu in Internet Explorer, click Internet Options, click the Advanced tab, click to clear the check mark from the Do not save encrypted pages to disk check box in the Security area, and then click OK. (This is the default Internet Explorer setting.)

    Methods 2

    1.Start Registry Editor.
    2.For a per-user setting, locate the following registry key:

    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings

    For a per-computer setting, locate the following registry key:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings

    3.On the Edit menu, click Add Value, and then add the following value:

    "BypassSSLNoCacheCheck"=Dword:00000001

    4.Exit Registry Editor


    Karen Hu
    TechNet Community Support

    • Marked as answer by 暁北 Wednesday, April 23, 2014 2:03 AM
    Tuesday, April 15, 2014 8:39 AM
  • Thank you, Karen, for your reply.

    Unfortunately, it seems your suggestion relate to failure downloading file through HTTPS, but I try to download the files through HTTP. Moreover, I checked the "Do not save encrypted pages to disk " checkbox and it was not marked.

    Do you have any other suggestions?

    Thursday, April 24, 2014 1:24 PM