locked
NAP DHCP not working RRS feed

  • Question

  • Hi

    I am running a NAP DHCP test in a lab environment but cannot seem to get a client computer to respond to the settings properly. My setup is as follows:

    1 x Server 2012 R2 Domain controller with ADDS, DNS, DHCP and NPS roles installed

    1 x Windows 8.1 Client

    The client is joined to the domain.

    I have configured NAP in NPS for DHCP with the remediation server as the DC. The health setting is set to firewall only for Windows 8 machines. I have enabled NAP for the DHCP scope (there is only one scope) and created a GPO to enable NAP DCHP on all domain computers. 

    I have done a gpupdate /force on the client, restarted it, released and renewed the ip but for some reason when I turn the firewall off, NAP doesn't seem to kick in. If I restart the client with the firewall off I will get restricted access but then even if I turn the firewall back on it will not register and give me network access. I have seen a training video with this same kind of setup and it worked fine, and NAP worked instantly (as soon as the firewall was turned off/on) but I cannot work out why this particular configuration will not work as it should. Any help is much appreciated. Alex


    • Edited by Zipster1 Tuesday, February 18, 2014 7:31 PM
    Tuesday, February 18, 2014 7:30 PM

Answers

  • OK, solved my own problem. For some reason the NAP service does not start automatically on Windows 8.1. Sorted it by adding additional parameters in the NAP GPO that forced automatic start of the NAP service on client machines.
    • Marked as answer by Zipster1 Tuesday, February 18, 2014 9:42 PM
    Tuesday, February 18, 2014 9:39 PM

All replies

  • OK, solved my own problem. For some reason the NAP service does not start automatically on Windows 8.1. Sorted it by adding additional parameters in the NAP GPO that forced automatic start of the NAP service on client machines.
    • Marked as answer by Zipster1 Tuesday, February 18, 2014 9:42 PM
    Tuesday, February 18, 2014 9:39 PM
  • Hi,

    Good to hear that the issue has been solved.

    Thanks for sharing and it would be greatly helpful to anyone who encouters the similar issue.

    Have a good day!

    Best regards,

    Susie

    Wednesday, February 19, 2014 2:37 AM