locked
Unable to access sharepoint sites after applying MOSS 2007 SP2 RRS feed

  • Question

  • I was able install WSS SP 2, but had issues.  I was able to work around it and perform the upgrade.

     

    I then installed MOSS 2007 SP2.  The upgrade seemed to go ok but there were some errors thrown during the install.

     

    Now when I try to load the main site:  http://mossiste, it gives me a page that says error and refers me to the Web Parts Maintenance Page.

     

    I try to remove these webparts but am unsuccessful.  Could the web.config file be referings webparts that aren't there and throw this error?

     

    I have the PSCdiagnostics file if that helps.

     

     

    Thanks,

    Wednesday, June 1, 2011 5:54 PM

Answers

  • Hi,
     
    According to your description, I was having the same problem: An unexpected error has occurred, Web Part Maintenance Page. In my opinion, Troubleshoot issues with Windows SharePoint Services. This error is that the Web part does not support Publishing feature. The solution for it is: create the page using SharePoint Designer and store it as normal ASP page, not Published page. Please have a try.
     
    Best Regards
    David Hu
    • Marked as answer by Emir Liu Thursday, June 9, 2011 8:55 AM
    Monday, June 6, 2011 10:17 AM

All replies

  • In order to see the real error messages as well as the stack trace of where the error happened within SharePoint, you have to do two simple things – in fact, also please post the error so that we can have a look and suggest a resolution
     
     
     In the web.config file of your SharePoint web application, edit these two entries:
      
     
    1. Switch custom errors off
     
    <system.web>

     
    <customErrors mode="On" />
     

     
    </system.web>
     
    Set the value "On" to "Off" in a development or staging environment, or to "RemoteOnly" if you have to troubleshoot an issue in a productive environment (of course, the error has to be reproduced locally in this case).
     
     
     
    2. Enable CallStack
     
    <SharePoint>

    <SafeMode MaxControls="50" CallStack="false" />
     

     
    </SharePoint>
     
      
    To make the CallStack visible, set the value to "true".
    Thursday, June 2, 2011 10:53 AM
  • Hi,
     
    According to your description, I was having the same problem: An unexpected error has occurred, Web Part Maintenance Page. In my opinion, Troubleshoot issues with Windows SharePoint Services. This error is that the Web part does not support Publishing feature. The solution for it is: create the page using SharePoint Designer and store it as normal ASP page, not Published page. Please have a try.
     
    Best Regards
    David Hu
    • Marked as answer by Emir Liu Thursday, June 9, 2011 8:55 AM
    Monday, June 6, 2011 10:17 AM