Win 7 Explorer always opens a new window, sometimes 2 RRS feed

  • Question

  • Whenever I select a drive using Windows 7 Explorer (64 bit), it always opens a new window, and sometimes opens two new windows.  I'm trying to get it to not do this, and a search of these forums and google/bing hasn't turned up anything else either.  I have "open each folder in the same window" checked, "double-lick to open an item" checked, and I do not have "launch folder windows in a separate process" checked.  I've tried playing around with these options, restarting my computer, and a handful of other things (see below).  Right clicking and selecting open (in bold) produces the same behavior.

    This link here ( http://social.technet.microsoft.com/Forums/en/w7itprogeneral/thread/e5ef58b5-a330-4eed-9c10-638c3b2c8f98 ) suggests it's something to do with McAfee, which I have never installed.  Furthormer, this has been an issue since day 1 - so unless the software came pre-installed with windows (I installed the OS myself), this seems unlikely.

    Resetting to default ( suggested here: http://www.sevenforums.com/general-discussion/24532-explorer-problem-opens-new-window.html ) along with rebooting had no effect.

    Another link suggested having the navigation panel displayed ( http://social.technet.microsoft.com/Forums/en-US/itprovistadesktopui/thread/1ee8dfe9-b258-4fed-9fc6-1d7195f5f60a ).  This had no effect.

    Messing around with the registry ( http://www.vistax64.com/vista-general/159063-windows-explorer-always-opens-new-window.html ) didn't work either.

    Finally, one link suggested re-installing Windows 7.  I'm not really interested in re-installing my entire OS to fix a menu option that should work in the first place.

    Assistance appreciated in advance.

    Tuesday, May 18, 2010 11:22 PM

All replies

  • This happens when completely uninstalling the Internet Explorer 8 wit DISM. Have you done this?

    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    Tuesday, May 18, 2010 11:33 PM
  • I have not uninstalled IE 8 (it is still currently installed) , and I'm not sure what DISM is. 
    Wednesday, May 19, 2010 3:19 AM
  • Hi Ricter,


    Did you try other suggestions in the threads you posted? If not, you can try the suggestions in this thread: Bug with opening folders in windows explorer on Windows 7 RTM - not opening in same window!


    If the issue persists, go to Start, type the following command in the Start Search box:


    regsvr32 "%programfiles%\Internet Explorer\ieproxy.dll"


    Right click on the item found and then click "Run as administrator".


    Hope this helps.





    • Proposed as answer by Andre.Ziegler Wednesday, May 19, 2010 12:58 PM
    • Unproposed as answer by Ricter Friday, May 21, 2010 5:18 PM
    Wednesday, May 19, 2010 8:48 AM
  • Yeah Linda, this is the answer. This happens when uninstalling IE8. Registering this dll fixes it.

    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    Wednesday, May 19, 2010 12:59 PM
  • I tried that before as well, and when I right click and select "Run as administrator" I get an error stating "To register a module, you must provide a binary name."  It then gives some usage information.

    If I just run the code in the Start Search box, it says operation succeeded, but this does not fix the erroneous behavior.

    And again, I did NOT uninstall IE8.  This behavior existed from first boot.

    Thursday, May 20, 2010 3:27 PM
  • Did you try the suggestions in this thread which posted previously? If the issue still exists, use the System File Checker tool to see if there is any missing or corrupted system files.


    If the issue still exists, perform an In-place Upgrade of Windows 7 to check the result.


    Regarding In-place Upgrade, it is a tool to repair the system. Through the special upgrade process, we will be able to repair the system. The In-place Upgrade will not affect settings like photos, movies, documents, etc. that are saved on the computer.  However, it is recommended to first backup your important information and files to other partitions or other disks. We can have a try to see if the issue works.


    Turn off Windows features before performing an In-place Upgrade


    1. Click Start, and click Control Panel.

    2. Click Classic View on the left pane, and double click Program and Features.

    3. Click "Turn Windows features on or off on the left" pane.

    4. In the Windows Features dialog box, uncheck all of the check boxes, and then click OK. 

    If you are prompted for an administrator password or confirmation, type the password or provide confirmation.


    Now, let's perform the following steps to repair the corrupted files:


    In-place Upgrade


    Though this operation will not remove or modify the installed programs and files, I still suggest that we backup the important files before doing this. In addition, we may have to reinstall the device drivers after this operation. Thank you for your understanding.


    If the Windows 7 DVD is not available, please just run setup.exe file in the Windows 7 installation package to perform the following steps.


    1. Insert the Windows 7 DVD in the computer's DVD drive.

    2. Click Start and choose Computer.

    3. Please find the "setup.exe" file in the DVD-ROM and double click it.

    4. Click Install now.

    5. When we are prompted to input the product key, please click Next without inputting any key. The setup wizard will prompt and ask if you agree to install Windows 7 without the key. Please choose to confirm.

    6. When you reach the "Which type of installation do you want" screen, click Upgrade to upgrade the system files of Windows 7.


    Note: While performing the In-place Upgrade, the system will restart automatically (several times) to merge the files and programs. Please leave the computer alone and do not configure it until In-place Upgrade is completed. The system will start Windows 7 once it is upgraded.


    When the In-place Upgrade finishes please check the original issue again.



    Friday, May 21, 2010 3:09 AM
  • Following the options in that thread did not fix the issue, even after a reboot.

    Something I think that is perhaps important is the fact that my explorer sometimes opens two additional windows, a symptom that none of the other threads (at least so far) have had.

    Technocrate's solution failed to work, either.

    I'll be trying the System File Checker tool here later today.

    Friday, May 21, 2010 5:20 PM
  • System File Checker got through 54% before throwing the error "Windows Resource Protection could not perform the requested operation."  Informative.

    I then executed:

    findstr /C:"[SR] Cannot repair member file" %windir%\logs\cbs\cbs.log >sfcdetails.txt

    With no response, so I assume it executed successfully.


    edit sfcdetails.txt

    Failed, saying that edit is not a recognized internal or external command, operable program or batch file.


    Finally, I attempted to follow the steps Linda Yan elaborated in her last post with regards to the Windows Features.  This caused me to Bluescreen.  Curiously, when I rebooted, the Windows screen said it was changing some settings, but when I logged into the computer, all checkboxes had been restored to their previous values.

    My win 7 dvd is an iso, so I'm not sure that I can run just setup from that.  I tried finding it in my installed windows directory, but while I found multiple files called "setup.exe" each of them was located in different areas (presumably different files, rather than copies of the same) and each threw an error when attempting to run, saying they could not determine the language to run.

    Saturday, May 22, 2010 4:06 PM
  • I still would appreciate assistance with this issue.
    Friday, May 28, 2010 5:32 PM
  • I would appreciate additional assistance.  Are there any other suggestions?
    Tuesday, June 8, 2010 1:51 PM
  • Try this one

    1. Go to Start > All Programs > Accessories, Then right click on  Windows Explorer, select Properties
    2. On properties Windows, click on Shortcut Tab, put this %windir%\explorer.exe  into
    Target box

    Friday, July 2, 2010 7:11 PM
  • Hey Ricter, I had the same problem as you, tried the same solutions... However, ironically, the solution was staring me in the face - it was just incorrectly stated (in my case, at least) by Linda Yan:

    "If the issue persists, go to Start, type the following command in the Start Search box:

    regsvr32 "%programfiles%\Internet Explorer\ieproxy.dll"

    Right click on the item found and then click "Run as administrator".

    Open search, type that in the start search box, but just left click it. Do not right click to start as an administrator. Just run it. It was fixed immediately. It gave me exactly the same error as it did you, when I attempted to run it as an administrator. Just do a regular open.

    Likewise, Andre.Ziegler: This is not tied to uninstalling IE8. I have not un-installed IE8 either (as I sometimes need it for work). If it is truly tied to something involving IE (which is obviously likely as it's a file in the IE folder), it may be because I uninstalled Bing Bar... Or, there are other potential possibility that I can think of, like the IE Tab addon I have in Chrome. It could likewise be related to Windows Update involving some IE modification, or some setting on IE8. It could, possibly, also happen because of uninstalling IE8, but that is simply not the only cause.
    Thursday, August 5, 2010 8:46 PM
  • I am having the exact same issue with Windows Explorer opening TWO windows when I left click on its icon. These suggestions did not fix the problem for me.

    After searching  more online I found a reference to this possibly being due to a corrupt User Profile. So I switched users on my PC to see if the problem went away, and it did. Apparently it is caused by a corrupt user profile as suggested on the other forum. So to fix it one needs to create a new user profile.

    Since I didn't really want to create a new profile from scratch (I have several customizations) I decided to try creating a new profile and then copying my existing profile to it (hoping whatever part is corrupt would be lost in the transition). I found a post telling how to do that under "fix a corrupt user profile" on this forum. However, when I get to the last step, where I am supposed to paste the copied files from my original administrator user account into the new administrator user account, I get an error message saying I need "permission" from the original user account to paste the files into the new account. I am not a fan of all this "permissions" BS, for sure. I have no idea HOW to tell the new administrator profile it has my "permission"!!

    So, if anyone can tell me how to do that I would surely be grateful!



    • Proposed as answer by Zoandar Monday, November 1, 2010 4:20 AM
    • Edited by Zoandar Monday, November 1, 2010 9:02 PM Solution "doesn't have permission".
    Monday, November 1, 2010 4:04 AM
  • I had this same problem.  I was just getting ready to copy the registry hack that KevinInNZ posted here:

    when a window popped up on my desktop from Microsoft - literally floating over the registry hack I was about to copy.  Felt like a good fairy was watching over me, which is not what I usually experience with software of any kind.

    It suggested that I download and run a folders fixit program.  It provided the download link right in the floating window.  So I downloaded and ran it and to my amazement, it fixed the problem.  My folders are back to working the way I have designated in my folder options (open in same window).  It then asked if I want to save it for possible later use (or something like that) and put a shortcut to it on my desktop.

    This is how it stored it:

    C:\Windows\System32\rundll32.exe "C:\Windows\system32\url.dll",FileProtocolHandler "http://support.microsoft.com/fixit"

    They even included the download url at the end of this file name.  It felt like my problem fix was fully automated and I just had to watch (not quite, but it felt like it)

    Thanks Microsoft fairy, for coming to my rescue in my time of need!

    Thursday, December 23, 2010 11:43 AM