locked
New-AppvSequencerPackage bug in Windows 10 ADK sequencer? RRS feed

  • Question

  • Hi folks.

    I'm using the New-AppvSequencerPackage cmdlet in Windows 10 - part of the Windows ADK and the version is 10.0.17763.1.  And the capturing process seems to be different to previous versions that I used on Windows 7?  I.e, it doesn't seem to work as well?

    As a basic example:

    I have created 2 CMD files:

    mkdir.cmd - simply creates a text file (C:\Program Files\test\sample.txt)

    @echo off
    
    SET folderpath=%ProgramFiles%\test
    SET filepath=%folderpath%\sample.txt
    
    mkdir "%folderpath%"
    echo Sample Text>"%filepath%"

    and

    pause.cmd (simply pauses until i press a key)

    pause


    If i run this command:

    New-AppvSequencerPackage -name "mkdir" -Installer "C:\temp\mkdir.cmd" -path "c:\temp\mkdir"


    The generated App-V package correctly captures the text file.

    However...

    If i run the following command line:

    New-AppvSequencerPackage -name "pause" -Installer "C:\temp\pause.cmd" -path "c:\temp\pause"

    During the sequencing process it will pop up the command prompt with a pause as it should.  Whilst this is in a paused state (and is during the capture phase) I then manually run mkdir.cmd to create the text file, and go back to the original command prompt and press a key (to essentially exit the installation process).  But the resultant generated App-V package DOES NOT capture the text file?

    It's a though the capture phase only captures the processes/sub processes launched directly via the sequencer, and not other processes?  Can anyone reproduce this?

    Wednesday, April 10, 2019 9:53 AM

All replies

  • Actually I have never used the auto sequencer like this... always with a sillent install command, batchfile or powershell script.
    I just reproduced your issue with the latest ADK 1903. The question is, is this by design or not ;)

    Roy Essers

    Wednesday, April 24, 2019 12:48 PM
  • Hi Roy.

    I'm glad you could reproduce the issue and I'm not barking mad!:-)

    I wrote a tool a while ago that essentially spins up a VM (in a clean snapshotted state), starts a Problem Step Recorder (PSR) session, opens a command prompt that pauses and prompts the user to install their app (and whatever else).  Once they're finished they close the command prompt and they end up with a sequenced package and some 'discovery' step by step screenshots.  Of course my tool also caters for non-PSR, automated conversions.

    It worked well in earlier versions, but in this version it doesn't capture anything!  If it's by design it seems like a poor design!  If it's a bug I'm not sure how to report it to be honest....?  I thought this forum might be the way to go.

    Wednesday, April 24, 2019 4:36 PM