locked
Can't delete a Site Collection after a botched restore RRS feed

  • Question

  • Hi all,

    I'm running MOSS 2007 (SP2). 

    Whilst restoring a site collection, the restore failed which I understand was due to the db transaction log drive filling up.

    Since the failed restore I'm unable to delete the site collection.

    In Central Admin, Delete Site Collection, the site collection is listed but with no details (URL, Title etc. aren't present). If I click OK to proceed to delete, the Delete button is greyed out.

    I've tried using enumallwebs as below, but the site isn't listed.

    "stsadm -o enumallwebs -databasename [databasename] -databaseserver [servername]"

    I've checked in SharePoint Manager 2007. The site is listed under the web app, but lots of fields display either "The system cannot find the path specified" or "There is no web names /sites/sitename". 

    I have got the ID through SharePoint Manager, so I also tried the following:

    "stsadm -o deletesite -force -siteid c23ee336-a2e0-4b2c-a0bc-5a966d9043f6 -databasename [databasename] -databaseserver [servername]"

    This results in the message: "There is no site collection with Id = c23ee336-a2e0-4b2c-a0bc-5a966d9043f6 in content database [databasename] on database server [servername]."

    I guess this isn't the end of the world, I've since restored the site collection to a new URL /sites/sitename2, but I've since found out that the search crawl isn't working because of this. The crawl fails with an error"sts3://intranettest.xxx.com.au/contentdbid={...
    Exception from HRESULT: 0x81070504 (There is no Web named "/sites/sitename".)" and it won't crawl any other content which exists in other web apps / site collections.

    I'd appreciate any advice on things to try to delete this non-existent site!

    Thanks.

    Wednesday, July 17, 2013 1:09 AM

Answers