locked
ADFS 4.0 Authentication not working with Special characters in Password RRS feed

  • Question

  • Hi all,

    We published Exchange Services like owa,ecp Claims Aware on ADFS / WAP 4.0 (Server 2016). Other Services like ActiveSync,rpc we published Non-Claims Aware and with Basic PreAuth on the WAP Server.

    Authentication on OWA (Claims Aware) Services worked fine with Special characters. But Special characters (like §) in the password cause an issue with Preauth with ADFS / WAP 4.0 Scenario on Non Claims Aware Trust with Basic PreAuth.  In fact e.g. ActiveSync

    Is this a known bug? Is there a list of special characters that do not worked as Password for PreAuth WAP/ADFS Scenarios?

    Kind Regards

    Steve

    Wednesday, March 28, 2018 1:31 PM

All replies

  • Hum... Interesting :) How do you pin point if it is ADFS not understanding it or if it is the client not sending and encoding it properly?

    Do you have a fiddler trace that show that  § is actually what is sent?


    Note: Posts are provided “AS IS” without warranty of any kind, either expressed or implied, including but not limited to the implied warranties of merchantability and/or fitness for a particular purpose.

    Wednesday, March 28, 2018 5:39 PM
  • Hi,

    We were able to test this very simply. We had several mobile devices (iOS,Android). Then we tested with a test account. Once with a password with special characters, then once with a password without special characters. We could also test it via the Exchange WebService test page (https://testconnectivity.microsoft.com/).

    We found that the Special characters are not works (§ and °).

    Kind Regards

    Steve

    Thursday, March 29, 2018 6:54 AM