none
MDT - No task sequences appearing

    Question

  • Im trying to image a few computers with the latest intel processor that requires UEFI boot.  I have a 2016 WDS server with MDT.  This server was setup with files copied over from my old WDS server.  I can successfully PXE boot and image older legacy BIOS PC's using my x32 Lite touch image.  If i try to UEFI PXE boot without my x64 litetouch image enabled, the process errors out with a hardware error message.  With my x64 litetouch image enabled I am able to UEFI PXE boot, choose my x64 litetouch image, and get redirected to MDT.  Once at MDT the process seemingly ends after the "Initializing" splash screen.  I do not see any of my task sequences.  One of the sequences is win7 x64 and the rest are all win10 images so its not something to do with architecture. They are all enabled and not hidden.  My deployment share has security rights set for the service account.  The custom settings ini, deployment share, and bootstrap ini, all have the correct pointers to the server, deployment share, and service account.  I have injected the drivers specific to the PC's being imaged as well as the WIN10PE drivers from dell. I can legacy pxe boot and see my task sequences just fine however this is not viable as the latest processor seems to require UEFI. So, my problem now is i am unable to see my task sequences when pxe botting from my x64 litetouch image via UEFI PXE boot.  Any help would be appreciated.
    Thursday, October 11, 2018 12:35 PM

All replies

  • Some screenshots might help so we can see what you see and maybe step by step processed until this point. Such as did get by processing customsettings.ini, bootstrap.ini, etc. As for initializing does it get to the point where it says "initialization complete". Does it make it to the screen where you would see the list of task sequences but nothing i listed?

    You might check your deployment share properties and make sure x64 is checked under platforms. If not, check it. You may need to update your deploymentshare and boot image after.

    Thursday, October 11, 2018 2:18 PM
  • It makes it to the screen where I would expect to see the task sequences listed but the wizard just disappears and i am left with a blank Windows Deployment Toolkit screen.  I have checked that x64 is enabled and have updated my deployment share with the option to completely regenerate the lite touch images followed by importing them into WDS.  I just tested an older computer with legacy bios and had no issues when choosing my x32 lite touch image.  
    Thursday, October 11, 2018 3:06 PM
  • If you are making use of Selection Profiles make sure you allow these task sequences to show up in WINPE. For example I have a selection profile just for deployment task sequence and I use customsettings.ini to allow them only to show up in WINPE.

    [WinPE]
    WizardSelectionProfile=DeployTaskSequences

    You can also try this.

    https://social.technet.microsoft.com/Forums/en-US/df1ae15f-2af7-4e06-ab7c-f606badc0668/missing-task-sequences-in-deployment-wizard?forum=mdt

    Wednesday, October 17, 2018 5:20 PM
  • Is sounds like the task sequences aren't set to "this can run on any platform". Be sure they have that set

    Daniel Vega

    Wednesday, October 17, 2018 7:19 PM
  • Hi,

    I ran into this too on a new server build. When the task sequences wouldn't appear I went through the setup and config files with a fine tooth comb -> no joy. Turns out the problem was with the folder permissions on the deployment share versus the credentials being used in the WinPE MDT wizard (a domain account). I think when the deployment share is updated, the folder share permissions are reset to Local Administrators=Full Control, and nothing else. The user account I was using wasn't a local administrator so didn't see the MDT share and therefore the task sequences.

    Edit the MDT share's folder permissions or change the account being used in the WinPE MDT wizard.

    Hope this helps somebody.

    Cheers

    Friday, November 30, 2018 1:08 AM
  • you might also want to try to just create a new deploymentshare, copy the customsettings and rules from your other deploymentshare, create a test task sequence, update the boot image and see if it works there.
    Friday, November 30, 2018 11:54 AM
  • Have you tried pressing F8 and doing an IP config to validate you've received a valid IP address from DHCP?  If not it could still be an issue with the network driver, I've had that happen.
    Friday, November 30, 2018 4:00 PM