locked
Moving files RRS feed

  • Question

  • Whenever i try to move large folders with files to another location like an usb hard drive vista keeps folders in the original location with files, simply incompletes the move.

    If I try again vista will move more folders and files, but never all with just one command like in XP. In XP I just had to cut and paste 1 time, in vista it simply doesn’t work like it should..

    Using a new laptop computer pre installed with vista x64 sp1. I have seen this behavior with other computers as well...

    Tuesday, January 6, 2009 9:33 PM

All replies

  •   

    Hi,

     

    Is there any error message when the issue occurs?

     

    This behavior can be caused by several reasons, I suggest that you boot in Clean Boot Mode first.

     

    Clean boot

    =================

    Let’s disable all startup items and third party services when booting. This method will help us determine if this issue is caused by a loading program or service. Please perform the following steps:

     

    1. Click the Start Button type "msconfig" (without quotation marks) in the Start Search box, and then press Enter.

     

    Note: If prompted, please click Continue on the User Account Control (UAC) window.

     

    2. Click the "Services" tab, check the "Hide All Microsoft Services" box and click "Disable All" (if it is not gray).

    3. Click the "Startup" tab, click "Disable All" and click "OK".

     

    Then, restart the computer. When the "System Configuration Utility" window appears, please check the "Don't show this message or launch the System Configuration Utility when Windows starts" box and click OK.

     

    Please test this issue in the Clean Boot environment, if the issue disappears in the Clean Boot environment, we can use a 50/50 approach to quickly narrow down which entry is causing the issue.

     

    For more information about this step, please refer to the following KB article:

     

    How to troubleshoot a problem by performing a clean boot in Windows Vista

    http://support.microsoft.com//kb/929135

     

    However, if the issue persists in Clean Boot Mode, please let us know if the issue occurs when you move files between partitions of the fixed hard drive, but not between the fixed hard drive and the external hard drive.

     

    Also please let us know if the issue occurred when the computer is received. From some forums I find that application such as incompatible version Quicktime causes this kind of issues. Please try to find if the issue started to occur after a specified program was installed.


    Arthur Xie - MSFT
    • Marked as answer by Arthur XieModerator Monday, January 12, 2009 9:22 AM
    • Unmarked as answer by wolf-it Friday, January 23, 2009 3:15 AM
    • Marked as answer by wolf-it Friday, January 23, 2009 3:15 AM
    • Unmarked as answer by wolf-it Friday, January 23, 2009 3:16 AM
    Wednesday, January 7, 2009 8:40 AM
    Moderator
  • Hi,
    Are these empty folders which vista leaves or folders with data inside? or these are folders with data and when you move the data are moved and the empty folder is left bahind?

    Akfash Latibu
    http://akfash.wordpress.com
    http://techdbt.blogspot.com
    http://techdisti.blogspot.com
    Thursday, January 8, 2009 1:55 PM
  • Hi, 

    I've tested it with 3 pcs.

    1 quad xeon graphical workstation with 16GB ram and using vista x64 business sp1 with all updates installed. Vista in this case was oem copy.

    1 asus business notebook with an intel T7250 cpu 2GB ram and using vista x64 business sp1 clean installed, without any software or drivers other than those installed during OS installation. Vista in this case was MSDN copy. Tried this machine without any updates and with full updates. Tried this machine with windows 7 beta build 7000.

    1 hp elitebook 8530w 4GB ram preinstalled with vista x64 sp1. Tried with full system updates and during a normal windows session and like you have suggested in clean boot mode.

     

    The test was a simple cut and paste operation to a folder where there was a similar folder(ie same name). Folders in question have many files and folders and i wanted to merge them.

    The size of the folders I've tried to merge vary from ~4GB ~1800files ~120folders to ~400GB ~100.000files ~10.000folders.

    I've tried to merge them from 1HDD to another, from 1 partition to another and between folders in the same partition. Tried also using internal HDDs only and between internal to external(usb) HDDs.

    I've also kept an eye to memory usage and kernel memory usage and both stabilized well before any problems.

    I was able to reproduce the problem with all of this systems,. Sometimes it takes longer, sometimes it is right away. Sometimes i got left empty folders in the original location, sometimes windows would start to merge and then just stopped leaving many(really lot's of files and GBytes) folders and files behind. Sometimes it wouldn't start at all, I mean you get to the first question "This folder allready contains.. do you still want to merge... i respond yes and it started preparing the move and just stopped. Sometimes i get to the second similar question about folders contained in the moved folder, to wich i respond yes and do this to all current (FOUND items) and then i get the question about the files to which i respond move and replace and do this for the next XXXX conflicts and click in the move and replace option.

    The problem was the same with all vista installations i tested. With win7 i didn't tested it enough to be certain that it would do the same, however it also left empty folders in the original location and gave me an error message saying something like this "The folder you are trying to move doesn't exist anymore" Windows had already moved it, this was not the root folder it was always some folder contained somewhere inside the root folder and windows7 was the only system to give me this error messages and gave me plenty of them on the same cut and paste operation and offered to skip the folder, try again and there was a check box to "do the same to..."

     

     I think that there's a link between how many file operations like this windows has done in 1 session because sometimes it takes a lot of time to reproduce the issue after a system boot, and sometimes it would happen in the first attempt on machines with +4h uptimes.

    This problem is annoying because i can't leave windows merging folders overnight and wake up to see the operation done, i get up and see that windows forgot lots of files...

     I hope MS is aware of the issue and will solve it before win7 get released.

    If you have suggestions on how to make MS aware of this issue they'll be welcomed.

    I've also found this: http://social.msdn.microsoft.com/Forums/en-US/windowsgeneraldevelopmentissues/thread/9793a6d5-3291-43b1-be5a-acd9a24b82d9/

     

     

     

    Friday, January 23, 2009 4:07 AM
  • Hi Wolf,

     

    This behavior occurs if your external hard drive has been formatted to FAT32 file system. If it is the case, you have to reformat the hard drive to NTFS.

     

    NTFS makes a number of improvements over FAT-based file systems. It uses advanced data structures, has a B+ tree directory structure, has improved reliability and use of disk space, allows for extensions such as security control, and has both a hard disk and file size of 16 EiB (EiB = exbibyte; a contraction of exa binary byte, and equaling 1,152,921,504,606,846,976 bytes).

     

    Therefore, when you need to copy files larger than 4GB, the copy destination needs to be formatted with NTFS.

     

    Another possible reason of this issue is the power supply of the hard drive. Long-time copy may make the power supply works incorrectly. If your hard drive is already NTFS, I suggest that you test this issue with another USB hard drive if it is convenience. If the issue does not occur with other drives, you may need to contact the hard drive manufacturer.


    Arthur Xie - MSFT
    • Marked as answer by Tim QuanModerator Friday, January 30, 2009 8:29 AM
    • Unmarked as answer by wolf-it Saturday, January 31, 2009 12:30 PM
    Wednesday, January 28, 2009 2:34 AM
    Moderator
  • Hi Arthur,

    I’ve done my testing with two 500GB external LaCie usb drives, one 640GB external WD usb drive, one 80GB external 2.5” HDD, and with internal sata HDDs. All HDDs are formatted to NTFS.

    I’ll run more tests as soon as have the time.


    Wednesday, January 28, 2009 3:22 PM
  • I've been experiencing the same issue with Vista's Explorer for a long time now and have yet to find a resolution to it other than writing code myself to do the operation as expected.  (Only NTFS partitions are being used.)

    Issue:
    1.  If "cutting" a folder object in explorer and pasting it into another folder that already has a subfolder in it named as the folder that is attempting to be pasted a "Confirm Folder Replace" dialog displays asking "Do you still want to merge this folder...with this one?" along with a checkbox for checking if this should be done for all current items.  I generally check the checkbox then select "Yes".  
    2. Then the "Move File" dialog appears prompting  "Move and Replace", "Don't move" and "Move, but keep both files" options along with a checkbox for allowing that operation to be performed for the next x conflicts.  I check the checkbox then select "Move and Replace". 

    Now what I expect from this "Move and Replace" operation is that the source folder's folder that I cut together with its subfolders would be merged into the destination folder as well as DELETED from the source folder when or as the operation progresses or completes.  This would indicate that the cut folders contents are supposedly combined with the folder that it was pasted into.  But no ... Vista's explorer does not perform that operation successfully for some reason.  I get no exception screens or prompts telling me why.   If the progress indicator even shows it gets to 100% green and disappears as if it did something but the orginal folder stays along with the folder structure and files....most of the time.    Sometimes some of the files get copied, sometimes they get moved but the actual folder itself (as well as possible subfolders) will not move entirely a high percentage of the time.   I typically would have to drill into the subfolders and move its file object contents one at a time which is not how the operation should occur.  I've only experienced when a "Replace" operation is requested.  If the folder does not exist, the move operation performs as expected.

    My laptop:
    Gateway C141XL
    Intel(R) Core(TM)2 Duo CPU T8300 @ 2.4GHz
    3.00 GB RAM
    32-bit OS
    Vista Ultimate with SP1 installed

    My desktop:
    Dell Dimension 5150
    Intel(R) Pentium(R) D CPU 3.00 GHz
    3.00 GB RAM as well
    32-bit OS
    Vista Ultimate with SP1 too



    • Edited by nawlins Wednesday, March 4, 2009 6:40 PM (added system specs)
    Wednesday, March 4, 2009 6:13 PM
  • I have this same problem moving files/folders in vista workstation. Very Annoying managing folders. Only occurs when destination folder already exists and am overwriting/adding to destination.
    Move operation is performed on Nas and San storage units as we move data from one place to another (all units are NTFS).
    I used xp workstation to do that exact same thing as above and what do you know, it works as expected, files/folders moved and originals deleted! This would seem to eliminate the source and targets as the problem.
    Also tested on 3 other vista pc's and same exact problem of not deleting source files/folders.
    So for now, I have to use an xp pc to do maintenance. Thanks ms for making me keep xp around a bit longer.
    Wednesday, March 11, 2009 8:36 AM
  • BEWARE, I also have this problem, and *some files disappear entirely* sometimes.  The only solution I've found is to move the files with vice versa--even teracopy and robocopy had problems on my system... :-(
    Sunday, March 15, 2009 3:24 PM
  • Hello Arthur Xie,

    I made a clean boot and the tpoblem persisted. I was moving files from one physical HD to another. Both mounted internally.

    Ali
    Tuesday, April 7, 2009 4:34 AM
  • I support this complaint.  How can Vista be unable to move a folder from an NTFS partition to a FAT32 partition on the same internal hard drive without failing? 

    Arthur Xie: I note your advice to "reformat the hard drive to NTFS".  Are you kidding?  My data partition is FAT32, and it's going to stay that way.  If I can use any other OS to move files from one partition to another, then why can't I use Vista?

    Wednesday, April 15, 2009 12:33 PM
  • I've ended up here after finally deciding to go looking for a solution to this problem I've had on every Vista PC I've used.

    On the exact issue that caused me to end up here, I'm moving files around on the same partition of the same NTFS formatted hard drive and try as I might, multiple moves won't move all the files nor all the folders. The folders are full of jpgs if that makes nay difference.

    This spanks of an easily repeatable Vista bug that is being ignored by MS. Much like the Status Bar bug that has been around since beta which I'm betting any 1st year c++ student could fix and is still unfixed today.
    Sunday, April 19, 2009 4:24 PM
  • I've had this folder "left behind" issue since beta as well, I've noticed it on numerous machines in my office but of course most often on my personal laptop; it started out as a vista business x64, but was upgraded to ultimate. It doesn't matter if the source or destination drives are local or network or a combination of the two. I've just "dealt" with it. However, today while I'm copying thousands of files - and as usual, a few random folders remain intact; empty - was finally frustrated enough to look for an official "that's how it is" or "we're going to fix it" answer - found neither...


    DG
    Sunday, May 31, 2009 7:40 PM
  • Hey Everybody,

    Got an answer for this possibly on another forum thread. Figured I'd repost here in case it helps anyone. Cheers to Dale for find a possible solution...


    Dale Qiao Users MedalsUsers MedalsUsers MedalsUsers MedalsUsers Medals
     Answer
    Vote As Helpful
    0

    Hi,

     

    Thanks for posting in Microsoft TechNet Forum.

     

    The cause for copying large files is due to the file system, differt file systems can handle different sizes of file. As I know, FAT32 can only handle files up to 4GB in size. NTFS can handle files more than 4GB. If you need to copy files larger than 4GB, you may need to make sure that the file system on the hard disk you are copying to is NTFS and not FAT32. However, many portable USB hard disk dirves come formatted as FAT32 in order to interface with the maximum number of operating systems.

     

    Based on my research, the problem for moving and copying large files in Windows Vista is because of the new auto-tuning network. Once Windows Vista is auto-tuning network is turned off, then the issue of moving files goes away. Here is the steps.

     

    To Turn off Auto-Tuning

    ==============

     

    1.    press Ctrl+Shift+Enter to open the Command Prompt. Choose run as administrator.

     

    Type in: netsh int tcp set global autotuninglevel=disabled

     

    2.    Reboot

     

    If you have any problems, then to turn auto-tuning back on type the following in Command Prompt:

     

    Type in: netsh int tcp set global autotuninglevel=normal

     

    Hope this helps. Thanks.

    Wednesday, July 8, 2009 10:38 AM
  • Yeah, this didn't work for me either ... problem still exists ... moving files and folders leaves files and folders behind ...
    Monday, February 8, 2010 12:45 AM
  • For me too. Windows Vista Home Premium all updates, the same issue. Now, I do have another problem, when I moving files from the Internal HDD, where the OS is installed, I can't move files to a netowork folder, however, if I'm using an external driver or flash driver, it will work.
    Saturday, June 12, 2010 2:42 PM
  • I've been experiencing this problem, too.  I've scoured the net but still can't find any answer.  Let me confirm that:

    1. This is not an external HD issue: it occurs with internal HD, too, even with moves on the same drive/partition.

    2. This is not a file system issue: it occurs on all NTFS systems, and as stated, even with moves on the same drive.

    It's incredible that something this fundamental to an OS, and a problem widely-reported, remains unfixed 4 years and 2 SPs after the first release.

    Wednesday, July 7, 2010 9:28 PM
  • I'm using WIndows 7 Ultimate and exactlyt he same problem. Moving folders on an NTFS partition within one disk. Notably I do this a lot:

    Folder1 contains two folders named "Fixed" and "Folder2". Folder2 contains a tree of folders (usually only one level deep sometimes two). I do some work with the data in Folder2 then when done I move it to Fixed. The result is that Folder2 is now in Fixed, but in Folder1 I still have teh tree structure of FOlder2 (i.e. all the folders are there, just the files are gone).

    This happens with TerraCopy (Move) as well.

    It seems MS have a bug here that is deeply embarassing! Dreadful! How can sucha  trivial and common file system operation be so broken? I also have found nothing but complaints and no solutions while researching on-line.


    Project Manager, Manager of Support, Quality Assurance and Documentation
    Monday, November 15, 2010 11:37 AM
  • i move folders from one drive to another all the time with Vista.

    I've found that if it stops and asks me anything (ie. if to move hidden files or file exists overwrite?)

    it will move everything but leaves the empty folders behind. that i have to delete manualy

    Thursday, March 17, 2011 8:24 PM
  • Unfortunately, this issue exists in Windows 8 too. Moving files (I notice it happens more with folders which have UAC protection) leaves behind empty folders. I think file copying/moving is important enough to get it right for the shell team, but then they have been doing a horrid job on Explorer in Vista and later.

    Tuesday, May 8, 2012 4:07 AM
  • I use Windows 7 Pro and Enterprise and Server 2008R2 and experience it too. When moving folders around on the server (NTFS share hosted on 2008R2) immediately after the move everything seems fine. A few minutes later some the original folders come back and a few of the files un-move (strange but true) in each folder and are back where they were not in the new place.
    • Edited by KarlHenselin Monday, September 17, 2012 8:18 PM typos
    Monday, September 17, 2012 8:12 PM
  • Even though I am working in a Wni 7 environment, the part of this answer that helped me is where it talks about the power supply inside an external USB Hard Drive. I was moving files from my internal drive to the external drive when, after a couple of files, the operation just stopped. The error I got was a pop up window saying: Could not find this item in *\: . After disconnecting the drive from the USB port and reconnecting again, I was able to move the files (this time one by one) to the external drive.

    Thank you.

    Tuesday, November 27, 2012 2:02 PM