locked
Unable to Install/Configure TSP on 64-bit O/S. RRS feed

  • Question

  • The short version of the question is, is a 32-bit TSP supported on a 64-bit O/S, and if so how do you get the Control Panel->Phone and Modem Options to look in the C:\Windows\SYSWOW64 directory for my TSP. If I launch the C:\Windows\SysWOW64\telephone.cpl it sees my TSP but launching it from Start->Control Panel->Phone and Modem Options does not (because it looks in C:\Windows\System32) which is how our customers would normally configure our TSP.

    Running C:\Windows\SYSWOW64\telphon.cpl the Phone and Modem Options panel sees the TSP and lets me add it (or tries), but it never gets entered into registry.

    The long version is, the initial developer of the TSP left and I am now responsible for it. The TSP now needs to support a 64-bit O/S and so the first thing I did was search to see if a TSP was supported running in WOW64 mode. After searching the only thing I could find on TAPI in 64-bit was people indicating that the 64-bit Tapi version needed to be installed for a particular Service provider (Cisco I believe is what I found). So I assumed that you had to have a 64-bit TSP on a 64-bit O/S since there was no talk of a TSP running in WOW64 mode. After getting everything compiled for 64-bit I started looking at getting it installed so I could test, so I ran our 32-bit installer just to get the files in place and noticed that the installer launched the Phone and Modem Options control panel and looking at SysInternals ProcessMonitor see that its looking in C:\Windows\SysWOW64 for the Tsp's and also noticed that the remotetsp.tsp and unimdm.tsp files are in there (as well as System32, not sure if the SysWOW64 ones are 32-bit or what) like 32-bit TSPs are supported on a 64-bit O/S. So I took a step backwards to see if I could get our 32-bit TSP to run, but I can't get the Phone and Modem Options panel to bring up our configuration dll. It fails to even get registered into HKLM\SOFTWARE\Wow6432Node\Microsoft\CurrentVersion\Telephony\Providers. From looking at ProcessMonitor it doesn't seem like the TSP is getting executed at all. I tried to figure out what the Phone and Modem Options panel does to launch our TSP Configuration DLL on a working 32-bit system and compare it to the 64-bit system, but it accesses so many registry entries/files stuff I have no idea where it is stopping/failing on the 64-bit O/S.

    I am running Windows Server 2008 Standard, Service Pack 2. It does the same thing on Windows Server 2008 Standard R2.

    So is a 32-bit TSP supported on a 64-bit O/S, and if so how, and if not why are the unimdm.tsp and remotetsp.tsp files in C:\Windows\SysWOW64 directory (making it look like 32-bit TSPs are supported).

    -Don

    Tuesday, April 6, 2010 7:27 PM

All replies

  • Hello -

     

    Have you made any progress with this? I'm having a very similar issue, and I would love to know if you found a solution.

     

    Thanks.

     

    -Nick

    Tuesday, April 13, 2010 4:00 PM
  • Nick,

      Well, I have made progress, but probably will be of no help to you. I re-compiled all our stuff in 64-bit and now have it running. But as far as getting the 32-bit driver to run in the C:\Windows\SysWow64 directory in 32-bit mode, I have had no luck. I can run the telepon.cpl file out of the C:\Windows\SYSWow64 diretory and then do an Add Provider and see my TSP driver, but it will not execute the TSP UI dll.

     

    -Don

     

    Wednesday, April 14, 2010 9:41 PM