locked
DVD bad sound in WMP 12 RRS feed

  • Question

  • When I play a DVD in WMP 12 it makes a horrible clicking noise and does not play the audio for the DVD.  I have read some other forums and as a result tried to play the DVD in Media Center and it worked fine.  Why is this and when can I expect to be able to play DVDs in WMP 12?  I am running Windows 7 RC 32 bit on my Gateway MX6450, I have Conexant AC Link Audio.  It took awhile for me just to get sound at all and everything else I play works fine.
    Sunday, May 17, 2009 8:46 PM

Answers

  • This website fixed my issues even though I did not have the same sound card.

    http://timheuer.com/blog/archive/2009/10/01/windows-7-conexant-ac97-dvd-audio-fix.aspx

    Right click on audio icon by clock and select playback devices.
    Select the audio device you are using and go to properties.
    Go to the advanced Tab.
    Uncheck 'Allow application to take exclusive control of this device'
    Select OK

    Hopefully it works for you
    • Proposed as answer by nosaj64 Friday, October 23, 2009 9:17 PM
    • Marked as answer by blackbeltpicasso Saturday, March 13, 2010 5:52 PM
    Friday, October 23, 2009 9:16 PM

All replies

  • Hi,

     

    This issue can be caused by incompatible Codec. I suggest that you remove all the installed third party Codec packs, players or video record programs.

     

    Another possible reason is your audio driver. If the issue persists, I suggest that you download the latest audio driver from the manufacturer's website and install it.  

     


    Arthur Xie - MSFT
    • Marked as answer by Arthur Xie Monday, May 25, 2009 4:04 AM
    • Unmarked as answer by blackbeltpicasso Wednesday, May 27, 2009 12:27 AM
    Tuesday, May 19, 2009 8:18 AM
  • The issue with the audio for DVD playback in WMP happens with nothing but windows installed.  I had to manually install my audio driver but I am using the correct one for this machine.  I installed ffdshow and Haali Media Splitter after having the problem.  They did not fix it but they are not the problem.  The DVD plays fine in media center I have also since installed nero and it plays the DVD just fine.  All other file play in Media Player but DVDs play clicking insted of audio. the video part is fine.
    Wednesday, May 27, 2009 12:32 AM
  • The issue with the audio for DVD playback in WMP happens with nothing but windows installed.  I had to manually install my audio driver but I am using the correct one for this machine.  I installed ffdshow and Haali Media Splitter after having the problem.  They did not fix it but they are not the problem.  The DVD plays fine in media center I have also since installed nero and it plays the DVD just fine.  All other file play in Media Player but DVDs play clicking insted of audio. the video part is fine.

    I have the exact same issue since 7.100. It works fine in VLC. But I would rather use WMP12
    Thursday, May 28, 2009 5:16 PM
  • Does the issue occurs when you play a DVD, or all of the DVD?

    On our test computers DVD could be played in WMP 12 without any issues. Since the issue occurs before you installed any other programs, if the issue occurs on all of the DVD, I suspect that the audio driver which is for Windows Vista that is not compatible with Windows 7 RC or WMP 12.


    Arthur Xie - MSFT
    Friday, May 29, 2009 6:40 AM
  • I have the exact same problem.  I am using a Gateway MX6440 notebook and running a dual boot system with XP and W7 Bld-7100.  So far I have updated the audio driver from Gateway's site so that is current.  Here is the list of codecs currently on my machine:

    Audio Codecs

    Type Name Format Binary Version
    ACM Microsoft IMA ADPCM CODEC 0011
    ACM Microsoft CCITT G.711 A-Law and u-Law CODEC 0007
    ACM Microsoft GSM 6.10 Audio CODEC 0031
    ACM Microsoft ADPCM CODEC 0002
    ACM Fraunhofer IIS MPEG Layer-3 Codec (decode only) 0055
    ACM Microsoft PCM Converter 0001
    DMO WMAudio Decoder DMO 0160, 0161, 0162, 0163 WMADMOD.DLL 6.1.7100.0
    DMO WMAPro over S/PDIF DMO 0162 WMADMOD.DLL 6.1.7100.0
    DMO WMSpeech Decoder DMO 000A, 000B WMSPDMOD.DLL 6.1.7100.0
    DMO MP3 Decoder DMO 0055 mp3dmod.dll 6.1.7100.0


    DVDs will not play on the W7 system in any other player either.  I have loaded several other players to try it out and in W7 all I get is the click/buzz for the audio.  I have to reboot into XP in order to watch the DVDs.
    Monday, June 1, 2009 1:44 PM
  • I'm going to upload a file to rapidshare so you guys can listen and tell me what it is...

    http://rapidshare.com/files/240826593/MyRecording.caf.html
    Thursday, June 4, 2009 6:23 PM
  • Does the issue occurs when you play a DVD, or all of the DVD?

    On our test computers DVD could be played in WMP 12 without any issues. Since the issue occurs before you installed any other programs, if the issue occurs on all of the DVD, I suspect that the audio driver which is for Windows Vista that is not compatible with Windows 7 RC or WMP 12.


    Arthur Xie - MSFT

    All of the DVD, video plays perfect, its the horrible sound. And as someone has stated before I think the MP3's also skip, so it might be a 7 issue or drivers issue, but I don't get how it changed from the first BETA to RC...
    Thursday, June 4, 2009 6:30 PM
  • Alright, I found out the issue. WMP 12 is the problem.. Windows Media Center plays the DVD just fine.. Microsoft needs to fix this ASAP.

    How can I contact MS on this issue?
    Thursday, June 4, 2009 8:09 PM
  • The issue with the audio for DVD playback in WMP happens with nothing but windows installed.  I had to manually install my audio driver but I am using the correct one for this machine.  I installed ffdshow and Haali Media Splitter after having the problem.  They did not fix it but they are not the problem.  The DVD plays fine in media center I have also since installed nero and it plays the DVD just fine.  All other file play in Media Player but DVDs play clicking insted of audio. the video part is fine.
    I was messing around with this again and I noticed that when I start the DVD in Media Player my speakers are making a horrible noise so I tried to mute it in Media Player and nothing changed so I hit the mute for the speakers and it turned off so it is not necessarily just media player.  I had to manually install my Conexant AC link Audio driver from the file already on my computer when I first installed 7.  The driver was signed as Microsoft Compatible.  This is the most up to date driver and again I want to stress the strangeness that this audio glitch is the only problem everything else plays fine all other file types and movie play fine in Media Center and Nero.
    Saturday, June 6, 2009 5:39 PM
  • I'm also having the same problem: DVD playback in WMP always makes a horrible crackling noise, but all other audio playback (including playing DVDs in Media Center and playing other stuff in WMP) works OK.  I'm using a Compaq R4000 with Windows 7 RC 64-bit (the same thing happened with the Beta).

    This system also has Conexant AC-Link Audio (PCI\VEN_1002&DEV_4370&SUBSYS_3085103C&REV_01).  I'm using the driver from HP's "SP35558", which needs to be installed manually but seems to work fine apart from this issue.
    Saturday, June 6, 2009 5:51 PM
  •  

     

    I've had a similar problem, using a Dell computer. In this case, whole tracks appeared to have been omitted from the playback. Initially I was using the HD audio device that's part of Windows 7. This appeared to be fine for most CDs. One in particular had quite serious problems. I seem to have lost John Lennon off Sgt Pepper's Lonely Heart's Club Band - this problem appears to be with Windows 7, rather than solely with Media Player, as the problem still existed with iTunes, when played from file or the original CD. The CD was fine played on another CD player.

     

    Following your advice I uploaded the updated Realtek driver  R155944 manually. This enhanced the sound quality and the cockerels now crow at the beginning of "Good Morning". However, problems still exist as some tracks are little more than instrumentals, whilst other CDs and music files are unaffected.

    Any suggestions of how to solve this completely would be appreciated. Thanks.

    Saturday, June 6, 2009 8:09 PM
  • Well, here I am with the same problem and I thought it was only me. I have an HP L2000 laptop and experience the same problem. There isn't anyway to report bugs anymore so I am stuck. If I try to play a DVD movie I get the same horrible chattering sound everyone else has commented on. I changed the DVD player and put in a LiteScribe DVD hoping it might make a difference. It didn't. I put in 2 Gigs of RAM hoping that might make the difference. It didn't. The weird thing is that CD sound plays perfectly. I was hoping one of the auto updates would fix it, but no such luck yet. I would think the problem would have been taken care of by now.

    Thanks to all.

    RKelly5327

    Tuesday, June 9, 2009 8:11 PM
  • Well I have an answer of sorts.  Apparently the problem is with Windows 7 and Media Player 12.  I don't know what the problem is and it appears that Microsoft doesn't care either.  I tried several different media players and found one that works just fine in Windows 7--VLC Media Player.  It's open source and it's free.  You can download it here--http://www.videolan.org/vlc/

    I can play a commercial DVD just fine with this player loaded in Windows 7.  If I switch to Media Player 12 I get the same chatter/buzz noise for the audio.  I updated all my drivers on the notebook so that isn't the problem.  You can look above at my previous post to see what the audio drivers are on my notebook.

    It might be that Microsoft has something that is clashing with the copy protection on commercial DVDs.  I got the same chatter/buzz audio from two different media players though so I don't know what's going on.  At any rate, download the VLC Media player and give it a run.  Hopefully it will work for you too.
    Thursday, June 11, 2009 1:51 AM
  • If audio playback does not work properly in a system that does not have any Codec installed, I suspect that the audio adapter driver cannot work properly with WMP 12. In most Windows 7 RC system, including the systems on our test machines, DVD playback works properly.

    You may try to upgrade the audio driver from the computer manufacturer's website.


    Arthur Xie - MSFT
    Friday, June 12, 2009 4:00 AM
  • Tried that already.  Twice.  Although it was a new updated driver that I installed, it made no difference whatsoever on the sound problem.  Still the same chatter/buzz for audio.

    The VLC Media Player works just fine though.  The audio comes in clear as a bell.
    Sunday, June 14, 2009 2:21 AM
  • I have the same problem with DVD playback on my Compaq Presario V2000 (V2312US) with a freshly loaded copy of Win 7 RC1. When it first happened I thought the DVD was misaligned in the drive, it was that bad. I'm working around the issue in the same way as 'Tikus66', by using VLC Media Player.
    Monday, July 27, 2009 1:37 PM
  • Same problem with my hp pavilion laptop with 32 bit Windows 7 RC.  Neither Media Player nor Media Center worked.  Video fine, audio "rat tat tat" sound only.  I also downloaded VLC Media Player and it plays back fine.  I hope this is fixed soon by Microsoft and is included in an update so I don't have to load up with peripheral software just to get things to work. 
    • Edited by tangopoppa Friday, July 31, 2009 12:01 AM
    Thursday, July 30, 2009 11:58 PM
  • Arthur - Several of your replies point to either an incompatible Codec or Audio Adapter Driver.  I have the same problem as originally stated - DVD playback works in Media Center, but in Media Player video is fine, audio is not.  Can you explain why the Codecs included with the Windows 7 Release Candidate and the most current audio driver would work for any DVD played back in Media Center, but NOT in Media Player?  Does Media Center use different Codecs than Media Player?  If not the problem is with Media Player 12 and Microsoft needs to fix it be for the final release.  This problem has been reported many times, but Microsoft does not seem interested in providing a real fix for it.

    Thursday, August 13, 2009 6:26 AM
  • I'm in the same exact boat.  I loaded the Winodws 7 RC (Build 7100) on my L2000 laptop and get the same * awful * noise if I try to play a DVD.

    On my Compaq V5000, I get NO SOUND.

    Definitly a problem with this release!
    Thursday, September 3, 2009 3:43 AM
  • This website fixed my issues even though I did not have the same sound card.

    http://timheuer.com/blog/archive/2009/10/01/windows-7-conexant-ac97-dvd-audio-fix.aspx

    Right click on audio icon by clock and select playback devices.
    Select the audio device you are using and go to properties.
    Go to the advanced Tab.
    Uncheck 'Allow application to take exclusive control of this device'
    Select OK

    Hopefully it works for you
    • Proposed as answer by nosaj64 Friday, October 23, 2009 9:17 PM
    • Marked as answer by blackbeltpicasso Saturday, March 13, 2010 5:52 PM
    Friday, October 23, 2009 9:16 PM
  • This worked for me! Thanks.
    Saturday, October 24, 2009 1:21 AM
  • This was an awesome piece of advise.

    To the owner of the other HP L2000 in this thread: this works! I'm running Windows 7 Pro 64bit + SP35558 on an L2000. With the little Sound Properties tweak I've been able to overcome the final hurdle, and DVD playback is once again working.

    Thanks again, Nosaj64!

    - Richard.
    • Proposed as answer by FredHoward Wednesday, November 11, 2009 8:43 AM
    Monday, October 26, 2009 6:36 AM
  • I have had this problem for ages and this seemed like the solution, but it didn't work for me. However, whilst playing with all of the various tabs mentioned here, I noticed that when I "right click" on the errant mpg, and choose, "Open with", I have TWO Windows media Player options. If I click on the first one, I get the terrible noise described , but puzzled by the duplication, I clicked on the second WMP entry and the mpg played back normally !   I have no idea why and I am also unable to remove the first entry from the "Open with" menu. I'll keep at it and if anyone knows how to do that, I'd appreciate it.
                                                                                                                              Fred

    Wednesday, November 11, 2009 8:53 AM
  • Worked for me!
    HP 510 with Windows 7 Pro 32-bit
    Wednesday, December 16, 2009 5:09 PM
  • I started this thread and after a while just gave up and used media center to play dvds but unchecking the 'Allow applications to take exclusive control....' worked thank you i am now using media player to play dvds.
    Saturday, March 13, 2010 5:52 PM
  • I've been suffering with this since I upgraded my laptop from XP to Windows 7.  Your instructions resolved my problem.  Thanks much.  

     

    Right click on audio icon by clock and select playback devices.
    Select the audio device you are using and go to properties.
    Go to the advanced Tab.
    Uncheck 'Allow application to take exclusive control of this device'
    Select OK

    Friday, May 7, 2010 6:14 PM
  • THANK YOU SO MUCH!

    I had the same problem with WMP12 and Win7! Fixed perfectly! You rock!

    Tuesday, July 13, 2010 10:13 PM
  • Thanks so much, just upgraded laptop to Win7. DVD player sounded BAD, your info fixed it for me. Laptop still with me and not in garbage.  Thanks again!!
    Thursday, October 28, 2010 7:24 AM