locked
MDT v8443 - Can't set en-AU Userlocale, Language and Speech via TS RRS feed

  • Question

  • Can anybody point me to a currently working step by step process to get a task sequence (TS) to install en-AU language and region settings into a deployed image?

    Language handling documentation for MDT seems to be hard to find and what I have found so far seems to be not quite right or doesn't work (in v8443). 

    Tried adding the en-gb language pack (current volume license version) to the Install.wim image of Win10 Enterprise (1603).  I have tried both the Jul2016 and Nov2016 versions of Win10 Enterprise 

    When adding via Powershell DISM commandlets, it throws an error after about 6 seconds of processing. 

    PS E:\temp> Add-WindowsPackage -PackagePath lp.cab -Path offline

    WARNING: Failed to add package lp.cab
    WARNING: Add-WindowsPackage failed. Error code = 0x800f081e
    Add-WindowsPackage : Add-WindowsPackage failed. Error code = 0x800f081e
    At line:1 char:1
    + Add-WindowsPackage -PackagePath lp.cab -Path offline
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : NotSpecified: (:) [Add-WindowsPackage], COMException
        + FullyQualifiedErrorId : Microsoft.Dism.Commands.AddWindowsPackageCommand

    Tuesday, February 28, 2017 1:29 AM

All replies

  • Error code = 0x800f081e usually means that the package is not applicable to the image.  Could be a number of reasons: wrong version, older files, prerequisites missing, etc.

    Check the dism.log and CBS.log for possible hints as to why it is failing.

    Wednesday, March 1, 2017 9:53 PM
  • Have you tried v8450?

    I'm having another attempt at my little project I started last year before I started running in to driver issues for my rig, so I haven't looked at the en-AU stuff for a while (mid - last year) since I was working on a personal Australian system image for ASUS Notebooks .. (doing this from vague memory) but :

    There's also something crafty that happened for the Speech and TTS for en-AU that happened for 1703/1709.

    Something didn't seem quite right when I looked at the OnDemand language packs.

    a) They downloaded with a file name very different to the rest of the language packs (Global). File names were a hash instead of "WinPE-Speech-TTS_en-AU.cab" format.

    b) The packages were no longer backward compatible when building in DISM.

    c) The DVD ISO for language packs and features for en-GB and en-US were not being recognized by MDT(8450).

    I've just downloaded and tried again same error I encountered last year from the 'X21-50425' disc

    Skipping invalid CAB file F:\Windows Preinstallation Environment\x64\WinPE_OCs\en-gb\WinPE-LegacySetup_en-gb.cab (probably not an update package)

    and also checked the LPs again...

    https://i.imgur.com/wG2pk1C.jpg

    The 10240 LP was able to be added to everything up until 14393 (trying to jog memory - 1703/1709 needed the new LP)

    and the Australia Specific packages...

    https://i.imgur.com/cFzDhvf.jpg


    Make sure your path points to the image too, not offline...

    PS E:\temp> Add-WindowsPackage -PackagePath lp.cab -Path offline

    Sunday, April 29, 2018 6:10 PM