none
Disk Protection Issue RRS feed

  • General discussion

  •  Just installed SteadyState and it installed without any issues. Setup a high restricted Public user account and tested it. Did a defrag as administrator and enabled Disk Protection. Once it rebooted it will not boot up now. It stays at the Windows XP startup screen with the bar going across. I let it go overnight thinking that perhaps Disk Protection was still doing something. After 12 hours, turned it off and it continues to do the same thing. I tried booting to SafeMode but get a BSOD with a 0x000000A.

     

    Not sure what happened? But am I better off formatting the disk and starting over again?

     

    Rick

    Thursday, June 28, 2007 2:11 AM

All replies


  • Hi Rick,


    Currently we do not know what may cause this. However, it is important to note that, as described in SteadyState handbook, if the computer has already been used and reconfigured by multiple users, as shared computers often are, we should consider reinstalling Windows XP before installing Windows SteadyState.

    Quote from handbook

    ~~~~~~~~~~

    Reasons to reinstall Windows XP:

    § 
    Reformatting and reinstalling is the best way to help create a more secure environment, to help enhance user privacy, and to improve performance and stability.
    § 
    Reinstalling Windows XP automatically removes the separate partition you may have created when you initially installed Shared Computer Toolkit.
    §  Reinstalling gives you an opportunity to create a new disk partition. A separate disk partition can be useful when using Windows Disk Protection because you   can  use it to store permanent files and user profiles that you want to retain when the Windows Disk Protection cache is cleared. For more information on saving data and files permanently, see the “Creating Permanent User Profiles on a Separate Partition” section in this handbook. 

     

    Friday, June 29, 2007 8:06 AM
  • I have experienced the same issue, with a completely new and fully updated installation of XP Pro on a Dell GX260 tower.

     

    I had everything installed and configured, with a the hard drive divided into a protected C: partition and a F: partition for saved user data.   I set a System Restore point "A".  The 65 GB C: drive is compressed, and was fully defragged and compacted using PerfectDisk, and had about 30% free space.

     

    As a final step I turned on WDP; after about a minute of installing the cache file, the computer rebooted, and I got a BSOD with indicating a problem with FILE_SYSTEM, and with technical information:

     

    Stop:  0x000000022 (0x00564346, 0x00000000, 0x00000000, 0x00000000)

     

    Additional attempts to reboot normally result in same BSOD.

     

    I then reboot using "Last known good configuration", and it rebooted, but now showing WDP to be off, although the System Restore log shows "Installed Windows XP Wdf01005."

     

    I use System Restore to return to Point "A", with identical result as before.  Several times, actually.

     

    I have previously installed MS SCT v1.1 on about 20 PCs with similar configuration without incident.

     

    Any suggestions?

    Tuesday, July 17, 2007 2:44 PM
  • If the STOP 0x0000000A bugcheck generated a dump file, there's a good chance it will identify the driver that caused the error. 


    The WDP driver bugchecks the system with this FILE_SYSTEM code when it detects a serious problem with the physical layout of the cache file on the disk. In this case, the list of file fragments that make up the cache file is stored in the registry. For some reason, that list seems to be in disagreement with NTFS's internal accounting of the file's fragments.

    I'm not sure what would cause that, but it could potentially be any kind of background defragmenting that is happening while the cache file is being created. It's conceivable that restoring a restore point while WDP is operating could cause problems. One other potential issue could be that the partition's structure is corrupt. You could check that by using chkdsk /f on the system partition (this will require a reboot and perform the check during startup). Once you get WDP uninstalled, I'd suggest validating the disk with chkdsk first. If it does find errors, keep running it until you get a clean bill of health before trying to reenable WDP.


    -Rob
    Wednesday, July 18, 2007 4:27 AM
  • OK, I tried the following:

     

    1.  Restored system to Restore Point "A"

    2.  Uninstalled SteadyState, ensuring all restrictions removed in advance.

    3.  Ran Chkdsk on both partitions (C: & FSmile with "Automatically fix files system errors" and "Scan for and attempt recovery of bad sectors" checked.  Windows found & replaced bad clusters in two files - a data file and "c:\cache.wdp".  (Question - if SteadyState has been uninstalled, why isn't "cache.wdp" already deleted?)

    4.  Manually deleted "c:\cache.wdp".

    5.  Ran Chkdsk on C: a second time, still found bad clusters on data file, but then reported volume as clean.

    6.  Downloaded & reinstalled SteadyState, put restrictions back on, but did not yet turn on WDP.

    7.  Set Restore Point "B".

    8.  Ran Disk Cleanup for C:

    9.  Ran Defrag on C:

    10. Turned on WDP

     

    Result:  Exact same BSOD as before :-(

     

    Any (further) suggestions?

     

    Thursday, July 19, 2007 4:09 PM
  • In my situation which is definitely different then what you are experiencing, is I wiped the system out and reinstalled XP and Office. Re-setup everything again and turned on WDP, worked without a hitch. Guess my issue was trying to put SteadyState on a computer that had been used for several years by several different end-users. Wiping it clean did the trick for me.

     

    RDFTS

    Friday, July 20, 2007 2:03 AM
  •  

    Hi B_radford1,

     

    First of all, please double check whether bad clusters still exist with the Chkdsk command.

     

    As the problem can also relate to other services or programs, we can perform a Clean Boot:
    ----------------------------
    1. Click Start and then Run, type msconfig and click OK.
    2. On the General tab, click "Selective Startup", and then clear all of the subsequent check boxes. You will not be able to clear the Use Original BOOT.INI check box.
    3. Click OK, and then click Restart to restart your computer.
    4. After Windows starts, enable WDP to check BSOD occurs or not.
     

    Regards,

    Friday, July 20, 2007 11:07 AM
  • The cache file should be removed when WDP is uninstalled.  If you had to resort to using a restore point to disable WDP, though, then our uninstall code did not run and thus didn't have a chance to remove the cache file. 

     

    The chkdsk errors are definitely cause for concern.  Until you can run chkdsk w/o any errors, I would not recommend installing WDP.

     

    Friday, July 20, 2007 2:23 PM
  •  

    I was able to reproduce the FILE_SYSTEM error by enabling WDP on a system that had disk compression enabled. 

     

    Start > My Computer

    Right-click on the hard drive that Windows is installed on (typically CSmile

    Select Properties

    Look at the checkbox on the bottom of the General tab labeled "Compress drive to save disk space"

     

    If that's checked, uncheck it and try enabling WDP again.

     

     

    Wednesday, July 25, 2007 6:34 PM
  • The problem now appears to be fixed with the Windows SteadyState 2.5 Beta.  Thanks!

    Monday, February 4, 2008 3:39 AM
  • I too have a similar problem with Steady State on an old Dell Dimension 2400.  Windows wouldn't boot with WDP enabled until I restarted with the last know good configuration (and that brought WDP back with protection turned off).  Which do you recommend, running chkdsk over and over or just install the bata version.  I also have WDP installed on a few HP's without any problems.  Is the problem possibly the FAT 32 partition on my Dell?

     

    Thanks ahead of time.  DLH

    Tuesday, February 12, 2008 8:42 PM
  •  

    Hi,

     

    Based on the Handbook, NTFS is required to install SteadyState. You may need to convert FAT32 to NTFS first.

     

    To do so, please refer to the following article:

     

    How to convert a FAT16 volume or a FAT32 volume to an NTFS file system in Windows XP

    http://support.microsoft.com/kb/307881/en-us

     

    Best Regards,

    Wednesday, February 13, 2008 3:11 AM