locked
Windows 10 Mobile + Exchange 2013 issue RRS feed

  • Question

  • Hello

    Hope this is the correct forum for this...

    Having an issue connecting a Lumia 950 (fully updated) to Exchange 2013 (Exchange Server, not hosted Exchange).

    My previous phone (WP8 - Lumia 1020) connected no problem, as does iPad, iPhone and everything else I have tried.

    The account appeared to set up correctly with a "All done! Your account was set up correctly." message. When I initially then tried to sync I got a message saying "Untrusted certificate... etc... Do you want to connect anyway?" Tap on Continue to confirm and I get this error:


    "Something went wrong
    Your device doesn't support this server version. Contact your support person or service provider.
    Error code: 0x85002028"

    I deleted the account and recreated, with the same result.

    I'm guessing that this may be because I have a self-signed certificate in Exchange. But as a one person business I can seriously do without the added cost of getting a 'proper' certificate so that I can connect my own phone to my own Exchange server within my own LAN!

    Any pointers very gratefully received.

    Thanks,
    Simon


    • Edited by simonrl Monday, December 21, 2015 10:41 PM
    Monday, December 21, 2015 10:39 PM

All replies

  • I'm running an Exchange 2013 server, with a self-signed (domain) cert.

    Are you running a Windows domain, with a CA and self-signed domain cert, and you generate your Exchange/SSL cert from that? That's what I did, and I had to export the domain cert as a .cer, then import into the phone. That tells the phone that your SSL cert is trusted, and the mail app will work.

    You may be able to achieve the same goal with a non-CA cert, but the end result is you need to export the cert, with private key, to a .p7b or .cer, put the somewhere that the phone can access it. I have a home page on my internal web server, and I just have a link to the file there. I open that link in Edge, which downloads it, then go into Downloads and "open" the cert. That'll import it for you.

    I have this vague recollection that, even though the UI says you can ignore the untrusted cert, you actually can't. Importing/trusting is the only way to go.

    Brad.

    Monday, December 28, 2015 6:17 PM
  • Many thanks Brad, that worked perfectly. I have a non-CA cert, it exported, downloaded and imported fine. I also found a useful app in the store - Certificates - that lets you view you certificates on your phone. 

    I seem to recall I had to do this with a previous version of Windows Mobile, but cannot remember which one. Will try to remember next time around...

    Thanks again, and happy new year.

    Thursday, December 31, 2015 3:27 PM
  • Glad it worked out. And thanks for the pointer to the app, that can come in handy.

    Brad.

    Thursday, December 31, 2015 3:34 PM