none
Windows 10, Roaming Profiles and Default Apps (Calculator, Weather, Cortana Search, Camera, etc) wont start for domain users RRS feed

  • Question

  • I am trying to get the default apps (particularly Calculator, Weather, Cortana Search, Camera, and the others Windows Apps too) to run with our domain joined computers.  

    When a Domain User clicks on any of the Windows App in the All Apps list, the loading bar appears on the App, but it never loads, and grays out. Nothing happens, it just stays that way until you logout. 


    I have discovered that if I take out Roaming Profile path out of the user's AD properties, then they will grab the Local Default Profile from the system and these Apps all work.


    Mandatory Roaming Profiles don't seem to work correctly, The Apps are suppose to be load on login, and this doesn't seem to be happening. This look to be a permission issue or something that isn't being created after the mandatory roaming profile is loaded.


    Loading the profile from the Local Default Profile these "Windows Apps" work correctly. i.e. calculator, voice recorder, Cortana search, etc.

    I've tried many different permissions in the V5 profile, but haven't had much luck yet. There is something that happen differently from when the Local Default Profile vs the Mandatory Roaming Profile is loaded. Not sure how to troubleshoot this.

    Windows 8.1 also has the same issues with domain users running off of roaming profiles.  This didn't bother me as much seeing that Microsoft
     still had a version of the software that weren't Windows App.


    However, our domain needs roaming profiles. I
     have found a few threads with people experiencing the same issue, but none of them have a resolution.  So...anyone have any ideas or can point me in the right direction?


    Thanks,

    Tim

    Monday, October 19, 2015 6:50 PM

Answers

  • The solution is:

    Applications will not run on roaming profiles or mandatory profile until the following group policy has been applied first:

    Computer Configuration -->Administrative Templates --> Windows Components --> App Package Deployment --> Allow deployment operations in special profiles: Enabled

    • Marked as answer by Zenithtwc Friday, January 15, 2016 6:29 PM
    Friday, January 15, 2016 6:29 PM

All replies

  • I've been having the same issue for monthes and im really close fo figure it out my last shot is to try to implement a AD test in server 2016 i heard roaming profiles of windows 10 are very compatible, for your start menu the only solution you can do is export from the local profile and implement the XML file through GPO.

    Regards,

    Elie.

    Wednesday, October 21, 2015 12:20 PM
  • The solution is:

    Applications will not run on roaming profiles or mandatory profile until the following group policy has been applied first:

    Computer Configuration -->Administrative Templates --> Windows Components --> App Package Deployment --> Allow deployment operations in special profiles: Enabled

    • Marked as answer by Zenithtwc Friday, January 15, 2016 6:29 PM
    Friday, January 15, 2016 6:29 PM
  • Marked as answer by Kate Li

    Dont mark my answer for me, this was not even close to the correct answer!




    • Edited by Zenithtwc Friday, January 15, 2016 6:31 PM
    Friday, January 15, 2016 6:30 PM
  • So Microsoft doesn't even enable Store apps by default in roaming profiles?  WTF, Microsoft.
    Saturday, January 16, 2016 1:35 AM
  • This is exactly what was wrong with my domain windows 10 computers, I'm glad I found this because everything thing else was telling me to rebuild user profiles and all sorts of things and none of those fixes would have changed this group policy setting :)
    Thursday, April 13, 2017 6:29 PM
  • I have 9 pc with windows 10pro running in sever 2016 domain with roaming profile enable but every time I log on to a pc I have to download all my apps all over again 
    Wednesday, April 19, 2017 4:25 AM