locked
Nano Server Best Practices Analyzer - Cannot get BPA results RRS feed

  • Question

  • Added a nano server to Server Manager, but it produces an error under Manageability 'Cannot get BPA results'. Looking into it set script execution to unrestricted and it shows error "The specified module 'BestPractices' was not loaded because no valid module file was found in any module directory"

    Anyway to supress this? Any plans to add BPA for nano server? Its making my dashboard look untidy.

    Wednesday, November 25, 2015 10:28 PM

Answers

  • Hello Mr. Happy,

    Thank you bringing this our attention. I have engaged the Product Group and confirmed that BPA isn't and won't be supported on Nano Server due to a variety of dependencies. A bug has been opened to 'suppress' the error when the system is detected as a Nano Server.

    Regards,

    Steven Graves

    Enterprise Cloud Group - Beta Team

    Monday, December 7, 2015 4:44 PM

All replies

  • Hi Mr Happy,

    I'm afraid I could not find any official document about the BPA for nano server.

    Considering Server TP is only a preview version, some applications and services may not work properly until an update released.

    I suppose we could ignore the error temporarily and wait for official document.

    Best Regards,

    Leo


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Thursday, November 26, 2015 7:23 AM
  • Hello Leo,

    Thank you for the reply. Yes appreciate a preview and I run it in a complete test environment so no problem at all with the odd issue. My makes my dashboard look untidy was attempt at humour that may not have been apparent.

    Just want to clarify this issue. This happens just adding the nano server to Server Manager, i.e. you do not need attempt to run a BPA (although I did to get the other errors). I have got the same issue on Server Manager on Server TP4 and on Windows 10.

    Nano server looks good to me and it seemed obvious to want to add it to Server Manager so thought I would post this. Perhaps all nano server needs is a BPA module to politely say 'no BPA' and perhaps just log a warning to that affect if a scan is run.

    Regards

    -Mr Happy-

    Thursday, November 26, 2015 7:42 PM
  • Hello Mr. Happy,

    Thank you bringing this our attention. I have engaged the Product Group and confirmed that BPA isn't and won't be supported on Nano Server due to a variety of dependencies. A bug has been opened to 'suppress' the error when the system is detected as a Nano Server.

    Regards,

    Steven Graves

    Enterprise Cloud Group - Beta Team

    Monday, December 7, 2015 4:44 PM