locked
Word 2016 Hyperlinks not working RRS feed

  • Question

  • I'm deploying Office 2016 as part of a Windows 10 SOE update, and I've run into a problem I'm having trouble solving.

    Hyperlinks created using the Insert Hyperlink tool are not opening at all.  This is only an issue in Word - hyperlinks created the same way in Excel work normally.

    I can type a URL directly into the document, it's converted to a hyperlink, and works perfectly.

    When I mouse over broken hyperlinks, I'm not even getting the 'Ctrl+Click to follow link' tip appearing.  I can Ctrl+Click on the link, and nothing at all happens - no errors, IE doesn't attempt to open the page.  Changing default browser to Chrome makes no difference.  

    I press Alt+F9, and can see that the link contains the correct hyperlink code - ie {HYPERLINK-"http://www.google.com.au"}

    I've had a look at our Group Policy, and I can't find any settings in there that look like they'd affect this behaviour, and I'm tending to think it's not going to be a system policy given Excel can do this without issue.

    Driving me up the wall!  Does anyone have any ideas at all, or suggestions where I could look for further troubleshooting?

    Thanks,

    Stuart

    Thursday, February 1, 2018 3:48 AM

Answers

  • So I've found the answer - it doesn't make a lot of sense though.

    The policy setting causing the issues was User Configuration\Policies\Administrative Templates\Microsoft Office 2016\Security Settings\Check OLE Objects.  This was Enabled, with 'Strict Allow List' selected.

    Does Word keep a separate OLE allow list to other office applications?  This is a global office setting, yet hyperlinks worked without problem in Excel and Outlook when created exactly the same way.  Bug in Word?

    Whatever the reason, I can stop pulling my hair out now!

    • Marked as answer by thatsnotme Wednesday, February 7, 2018 12:37 AM
    Wednesday, February 7, 2018 12:37 AM

All replies

  • I'm deploying Office 2016 as part of a Windows 10 SOE update, and I've run into a problem I'm having trouble solving.

    Hyperlinks created using the Insert Hyperlink tool are not opening at all.  This is only an issue in Word - hyperlinks created the same way in Excel work normally.

    Hi Stuart,

    Does this issue affect all machines in your environment?
    What's the detailed build number of your Word 2016?
    By "Hyperlinks created using the Insert Hyperlink tool", do you mean the dialogue box below?

    I tested in my Word 2016 (16.0.9001.2080) but cannot reproduce the issue.

    Please try to start Word in safe mode (Press Win + R, type "winword /safe", press Enter.) and see if the issue persists.

    Any updates, please don't hesitate to post back.

    Best regards,
    Yuki Sun


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Friday, February 2, 2018 6:40 AM
  • Hi Yuki, 

    This build is still in development, and this issue was identified in UAT, so it's hard to say exactly how widespread it is, however I've replicated the issue on at least 4 different devices, so it's probably fair to say it will affect every build.

    Our Word version is 16.0.4639.1000.  The problem still occurs in Safe Mode.

    And yes, the dialog you show above is the one I'm talking about.

    Thanks for having a look at it...it's definitely a confusing issue!

    Sunday, February 4, 2018 10:35 PM
  • Hi Stuart,

    >> however I've replicated the issue on at least 4 different devices, so it's probably fair to say it will affect every build.

    Are the other 4 different devices running different version or build of Word?

    By the way, have you checked in Outlook to see if hyperlinks can be inserted properly?

    Best regards,
    Yuki Sun


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    • Marked as answer by thatsnotme Monday, February 5, 2018 2:45 AM
    • Unmarked as answer by thatsnotme Monday, February 5, 2018 2:45 AM
    Monday, February 5, 2018 2:33 AM
  • Hi Yuki, 

    The other devices are all running the same build of Word.  

    I hadn't checked Outlook actually...I went and testing, and Hyperlinks work properly in Outlook 2016.  So for some reason it only appears to be affecting Word 2016.

    Following on from this, I've modified the GPO delegations so Office 2016 user policy won't apply to me, and retested.  After doing this, the hyperlink is working again, so it's a policy setting issue...I just have no idea which one!  I believe it must be a Word 2016 specific setting causing the problems given other Office applications can create hyperlinks without issue.  I hate policies sometimes...!

    Monday, February 5, 2018 4:37 AM
  • So I've found the answer - it doesn't make a lot of sense though.

    The policy setting causing the issues was User Configuration\Policies\Administrative Templates\Microsoft Office 2016\Security Settings\Check OLE Objects.  This was Enabled, with 'Strict Allow List' selected.

    Does Word keep a separate OLE allow list to other office applications?  This is a global office setting, yet hyperlinks worked without problem in Excel and Outlook when created exactly the same way.  Bug in Word?

    Whatever the reason, I can stop pulling my hair out now!

    • Marked as answer by thatsnotme Wednesday, February 7, 2018 12:37 AM
    Wednesday, February 7, 2018 12:37 AM
  • Please download the application <g class="gr_ gr_118 gr-alert gr_spell gr_inline_cards gr_disable_anim_appear ContextualSpelling ins-del" data-gr-id="118" id="118">from</g> below link and Run, it will resolve your hyperlink related issues.

    https://support.microsoft.com/en-us/help/218153/error-message-when-clicking-hyperlink-in-office-cannot-locate-the-inte


    Friday, November 30, 2018 5:24 PM
  • Where are you finding this? In the registry or in the GP Editor. It's not very clear, and the path you mention doesn't seem to exist.

    Thank you.

    Tuesday, May 14, 2019 2:03 PM
  • This is a setting in Group Policy.  What do you mean the path doesn't exist - do you mean in the Registry (no it doesn't exist there) or in GPO - if you can't see it in GPO have you got the correct templates installed?
    Tuesday, May 14, 2019 11:43 PM
  • I don't have a listing for Microsoft Office 2016 under Administrative Templates.  Any suggestions?

    I just gave up and swapped over to Office XP and the hyperlink works fine now.  

    Wednesday, January 1, 2020 1:43 AM