none
Have Windows 7 automatically switch to LAN when cable is plugged in and switch to wireless when it's removed

    Question

  • I have Windows 7 Professional on my PC. In the first load I had, the PC should automatically detect if the LAN cable was plugged in, turn off the wireless radio, and change the network icon in the right bottom corner to reflect the cable was now in use. Unfortunately, I had to reload my PC, and since then I can't get it to do it again.

    So, what I'd like to achieve is this: Have Windows automatically detect when the cable is plugged in, turn of the wireless radio, and change the network icon in the right bottom corner to reflect the cable is in use - and, obviously, vice versa.

    Can someone tell me what I need to do, please?

    Tuesday, February 28, 2012 11:02 PM

Answers

  • Hi,

    There are two methods can help you.

    1. Go to <Network and Sharing><Change Adapter Settings> and right click your wired and wireless adapters one at a time to change the properties. Select IPv4, click <Properties> then click <Advanced>. For each one, clear the "Automatic metric" check box and assign the metric value manually. Setting your wired adapter’s metric value lower than wireless adapter one, such as “1” for wired adapter and “2” for wired adapter.

    2. Go to <Network and Sharing><Change Adapter Settings>, hold down 'alt' to bring up the "File" menu, select "Advanced", select
    "Advanced Settings" from the dropdown menu, adjust the priority of your wired adapter higher than your wireless adapter in the "Advanced Settings" window under the "Adapters and Bindings" tab.

    Hope this helps.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Wednesday, February 29, 2012 8:55 AM
    Moderator

All replies

  • Hi,

    There are two methods can help you.

    1. Go to <Network and Sharing><Change Adapter Settings> and right click your wired and wireless adapters one at a time to change the properties. Select IPv4, click <Properties> then click <Advanced>. For each one, clear the "Automatic metric" check box and assign the metric value manually. Setting your wired adapter’s metric value lower than wireless adapter one, such as “1” for wired adapter and “2” for wired adapter.

    2. Go to <Network and Sharing><Change Adapter Settings>, hold down 'alt' to bring up the "File" menu, select "Advanced", select
    "Advanced Settings" from the dropdown menu, adjust the priority of your wired adapter higher than your wireless adapter in the "Advanced Settings" window under the "Adapters and Bindings" tab.

    Hope this helps.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Wednesday, February 29, 2012 8:55 AM
    Moderator
  • I have this same issue and those settings do not work. In some cases the network never switches over from wireless to wired.
    Wednesday, March 27, 2013 7:55 PM
  • Hi Jaap,

    it's resolved my issue. thanks.

    • Proposed as answer by match_lnq Tuesday, April 26, 2016 3:40 AM
    Tuesday, April 26, 2016 3:40 AM
  • Bumping an older thread here, but how do you keep a Windows 7 laptop from connecting to both wired and wireless connections at the same time?


    Regards

    Saturday, November 12, 2016 5:09 AM
  • I also would like to bump this and ask how to keep the laptop from connecting to both NICs. We want to make sure that when the laptops are docked, they only use the Ethernet (LAN) connection. Currently, the only way to get them to use the LAN is to disable the wireless NIC. We have tried the suggestions Jeremy_Wu posted as well as ensuring that the LAN/WLAN Autoswitch configuration is set within the BIOS. Any other helpful suggestions?
    Tuesday, August 8, 2017 12:08 PM
  • I want to add, that just setting the metric to 1 and 2 will not always work. 

    Because a formula is used to determine which network should be used and the metric just shifts the weight. 
    Therefore there needs to be enough difference bettween the two metrics in order for them to have an effect so that that ethernet becomes heavier on priority.

    I managed to tell windows to use ethernet over wireless, by setting metrics for ethernet to 1, and for wireless to 20.


    Thursday, April 12, 2018 2:18 PM