locked
Unable to Hibernate after Fall Creators Update RRS feed

  • Question

  • Yesterday I had the displeasure of being updated to the Fall Creators version of Windows 10.  Ever since then, I have not been able to hibernate my PC.  I've updated everything I could from both Windows Updates and from the manufacture (HP).

    I am trying to diagnose which driver is causing the issue.

    When running

    xbootmgr -trace hibernate -traceFlags BASE+CSWITCH+DRIVERS+POWER -resultPath C:\TEMP


    it fails with

    [2018/02/01-10:53:57.078] Changing power state...
    [2018/02/01-10:54:08.737] SetSystemPowerState failed with 0x000005aa.


    And per MSDN that is:

    ERROR_NO_SYSTEM_RESOURCES1450 (0x5AA)
    Insufficient system resources exist to complete the requested service.


    I assume this is a driver issue, but I need help identifying which driver is causing the issue.

    *Edit* and powercfg output:

    powercfg /requests
    DISPLAY:
    None.
    
    SYSTEM:
    None.
    
    AWAYMODE:
    None.
    
    EXECUTION:
    None.
    
    PERFBOOST:
    None.
    
    ACTIVELOCKSCREEN:
    None.

    powercfg /a
    The following sleep states are available on this system:
        Standby (S3)
        Hibernate
        Hybrid Sleep
        Fast Startup
    
    The following sleep states are not available on this system:
        Standby (S1)
            The system firmware does not support this standby state.
    
        Standby (S2)
            The system firmware does not support this standby state.
    
        Standby (S0 Low Power Idle)
            The system firmware does not support this standby state.

    • Edited by J Hoover Thursday, February 1, 2018 9:45 PM Added powercfg outputs.
    Thursday, February 1, 2018 9:14 PM

All replies

  • Might occur because hiberfil.sys is corrupt. You can fix this by deleting and restoring it:

    powercfg /h off

    reboot

    powercfg /h on

    reboot

    Not sure if the reboots are essential but they make sure you really have deleted a corrupt hiberfil.sys

    Thursday, February 1, 2018 10:10 PM
  • Thanks.  I've already tried this with no luck.  I've also tried a clean boot with all non-MS services disabled, and it still has the same behavior.
    Thursday, February 1, 2018 10:14 PM
  • When you click hibernate, what does the machine behavior?

    After you run the command, there will be an etl file created, could you please upload it to a network drive and share the link here. In addition, go to Event log>windows logs>system to see if there is any logs there, you can also save the logs and upload to the network drive.

    What is more, go to Device Manager to see if there is any errors with device driver. If so, uninstall the driver and reboot your machine. 


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.



    Friday, February 2, 2018 6:28 AM
  • The session is locked, the screen goes black, but the disk fails to spin down. Once the screen goes black if you bump the mouse or keyboard your back at the login screen.

    https://www.dropbox.com/s/738eg9ca7t13kar/hibernate_BASE%2BCSWITCH%2BDRIVERS%2BPOWER_1.zip?dl=0

    There are no System events that matter as far as I can tell.  I would need to filter a log to give just the events around the attempted hibernation, but I am not seeing anything for Kernel-Power.

    Device manager is normal, with no unknown devices.


    • Edited by J Hoover Friday, February 2, 2018 7:19 PM Updated link
    Friday, February 2, 2018 5:46 PM
  • Also worth mentioning sfc /scannow reports no issues.
    Monday, February 5, 2018 6:09 PM
  • Hi,

    I noticed that there is some device, which is require for power during hibernate:

    1.Intel wireless Bluetooth

    2.synaptics fp sensors (wbf) (pid=003f)

    3.active management technology sol

    4.Intel HD Graphics 530

    5.USB composite device

    6.Generic pnp monitor

    Please go to Device Manager, find the drivers for this device, right click them>properties>power tab>check the option "Allow the computer to turn off the device to save power". 

    Then it is suggested you can turn off/unplug the wireless Bluetooth device , wireless or wired touch pad, usb device, go to hibernate again to see if the problem exists.

    Then run command powercfg /energy as administrator to generate a report of the power statue, then upload it to the network drive.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, February 6, 2018 1:15 AM
  • 1) Already was checked

    2) Already was checked

    3) No power management tab

    4) No power management tab

    5) No power management tab

    6) No power management tab

    As nothing was changed, no sense in retesting.

    https://www.dropbox.com/s/cqzyi7uy83jpdwx/energy-report.html?dl=0

    Tuesday, February 6, 2018 3:47 AM
  • From the report, I have noticed two errors:

    1.Devices with missing or misconfigured drivers:

    Cisco AnyConnect Secure Mobility Client Virtual Miniport Adapter for Windows x64

    2.Platform Power Management Capabilities: PCI Express Active-State Power Management (ASPM) Disabled

    Here are some steps that you can try:

    1,Update your firmware

    2.Unplug the USB device and turn off the wireless Bluetooth device.

    Someone fixed the problem by unplugging the usb adapter:https://superuser.com/questions/823548/what-is-the-known-hardware-incompatibility-that-disables-pcie-active-state-pow

     3.Enable PCI Express Active-State Power Management
    
    Open the Control Panel in the Start menu.
    b)    Open Power Options in the Control Panel
    Note: If Power Options is not available, change View by to Large icons at the top right of the Control Panel.
    c)    Select Change plan settings next to the power plan you want to set.
    d)    Select Change advanced power settings.
    e)    Select “PCI EXPRESS”.
    f)    Under PCI EXPRESS select “Link State Power Management” and then click OK to save the changes.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, February 6, 2018 10:23 AM
  • BIOS is the latest version, which I updated after the Fall Creators update when this problem initially started.

    There were 0 external devices connected when running that report.

    For PCI Express, they were both set to maximum power savings, changed to moderate power savings (as opposed to off).


    Still no changes.
    • Edited by J Hoover Tuesday, February 6, 2018 5:38 PM
    Tuesday, February 6, 2018 5:37 PM
  • Hi, 

    I see this: 

    Devices with missing or misconfigured drivers can increase power consumption.
    Device Name	Cisco AnyConnect Secure Mobility Client Virtual Miniport Adapter for Windows x64

    Previously, I have encountered the issue that Anyconnect prevent Windows from sleeping when I am using Windows 8.1. I am not sure it can work well on Windows 10 without any compatibility issue. 

    At this time, I suggest we uninstall Anyconnect first including to clear the driver installation in Device manager, and see if your computer can sleep well after restarting the computer. 



    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Wednesday, February 7, 2018 2:23 AM
  • We have a partial success.  I've also been working with the HP business support and they had responded with:

    ...and noticed a BIOS setting that I would recommend changing:
    under the advanced page > secureboot configuration > I suggest changing from "legacy support enable and secure boot disable" to "legacy support disable and secueboot enable (or secureboot can remain disabled) the current setting is for Windows 7 and can cause some problems for Windows 10.
    

    Once I changed this setting, the laptop again appears to hibernate.

    Wednesday, February 7, 2018 2:28 AM
  • FYI, I am using a ZBook 17 G3 with BIOS version:

    Vendor: HP
    Version: N81 Ver. 01.22
    Release Date: 01/22/2018

    Wednesday, February 7, 2018 2:30 AM
  • We have a partial success.  I've also been working with the HP business support and they had responded with:

    ...and noticed a BIOS setting that I would recommend changing:
    under the advanced page > secureboot configuration > I suggest changing from "legacy support enable and secure boot disable" to "legacy support disable and secueboot enable (or secureboot can remain disabled) the current setting is for Windows 7 and can cause some problems for Windows 10.
    

    Once I changed this setting, the laptop again appears to hibernate.

    Still the issue could be caused by your firmware which may not support Windows 10 well. 



    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, February 7, 2018 2:46 AM
  • J Hoover....how is your "partial success" going? I have a ZBook Studio 15 G3 with the BIOS at v01.25 01/30/2018, and I have Cisco AnyConnect installed as well for VPN, and I was seeing the exact same problem.

    When I changed the SecureBoot configuration as you listed, my laptop is now once again able to hibernate/sleep, without the "Insufficient system resources exist..." error. Sounds like a viable permanent solution to this problem, I hope.

    Thursday, March 29, 2018 12:34 AM