none
fatal error: RevoScaleR cannot be used in this R session anymore, if possible restart R session RRS feed

  • Question

  • HI, anyone familiar with this error:

    Error in doTryCatch(return(expr), name, parentenv, handler) : 
      fatal error: RevoScaleR cannot be used in this R session anymore, if possible restart R session
    error code -1073741819, detailed error message might be found in: (standard output unavailable) and (standard error output unavailable)

    after executing this: 

    rxGetInfo(nyc_lab1_xdf, getVarInfo = TRUE, numRows = 10)


    any help appreciated

    Sunday, April 1, 2018 5:46 PM

All replies

  • I have not seen this particular error before, but the error seems to indicate that you may have corrupted your current R session. I would try running the rxGetInfo command from a new R session - does that work?

    Monday, April 2, 2018 3:49 PM
  • Nope, restarting the sessions didn't help.

    The error appears in VSTS and Rstudio. In RStudio is switched a couple of times between the R versions of Microsoft and the open R source. Perhaps I screwed something up there...

    I also tried to install RevoScaleR in the R open version, but that didn't succeed either.


    • Edited by Hennie7863 Tuesday, April 3, 2018 7:07 AM
    Tuesday, April 3, 2018 7:07 AM
  • Hey,

    I am getting the same error. Did you manage to resolve this error. Appreciate any inputs in this direction.

    Wednesday, October 17, 2018 4:34 PM
  • The error message seems to indicate a problem with the BxlServer connection that is part of RevoScaleR, however I am not certain what caused the crash in your instance.

    It may be that you have a corrupt XDF file or a corrupt installation.

    I would first try rxGetInfo() on one of the built-in XDF files that come with Microsoft R Server:

    Does the following work?

    rxGetInfo("C:/Program Files/Microsoft/ML Server/R_SERVER/library/RevoScaleR/SampleData/AirlineDemoSmall.xdf", getVarInfo = TRUE, numRows = 10)

    If no, you have probably corrupted your install and should try reinstalling Microsoft R Server.

    If it works, your XDF file may be corrupt.

    Wednesday, October 17, 2018 8:22 PM
  • hi, have you sloved this problem? i met the same issue, and tried to reinstall Microsoft R server. however, it didn't work. :( Do you have any advice?


    Wednesday, March 4, 2020 3:24 PM