Lync Mobility shows redirect to internal url from external discovery url RRS feed

  • Question

  • I have connected somehow one Lync mobile client (Windows Phone 7).  I try to connect other phone and they seem to be pushing back the internal URL when going to the external discovery URL.  Also I have tried to connect an iPhone internally and still getting issues.  Seems weird that my phone was the only one able to connect.

    I have no TMG but pushing 443 to 4443 on my router for my external web services.

    I have installed the domain ca cert on the phones to except the domain signed cert.

    I have ran Get-CsMCXconfiguration |fl and its showing the .local URL of the frontend server.

    I have tested my phone (the one that is working) both internally and externally.

    Any help would be great.

    Johnathan Penberthy

    Friday, December 14, 2012 5:12 PM

All replies

  • Hi,Johnathan,

    Are the other phones Windows Phone?If not please make sure you have input the correct format of user information when connect.

    Did you connect the Lync mobile using automatic connection or manual connection?

    When you use automatic discovery, mobile devices use DNS to locate resources. During the DNS lookup, a connection is first attempted to the fully qualified domain name (FQDN) that is associated with the internal DNS record (lyncdiscoverinternal.<internal domain name>). If a connection cannot be made by using the internal DNS record, a connection is attempted by using the external DNS record (lyncdiscover.<sipdomain>). However, both the internal Mobility Service URL and the external Mobility Service URL are associated with the external Web Services FQDN. So the Lync mobile will connect to the external web service regardless it connect internally or externally which is just on the oppsite of your scenario.

    I doubt there should be something wrong with your DNS record or the publishing rule ,would you pleae double check them?

    Besides,please enable diagnose log on your phone and the other phone then send the log file to your email and compare them to find out the difference for troubleshooting.



    Sharon Shen
    TechNet Community Support


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question.

    Monday, December 17, 2012 8:49 AM
  • One phone is a Windows Phone 7 and the other is an iPhone 4.  I've tried auto and manual connection.  This is the log from the Windows Phone.!702&authkey=!AHtYcJqS1ouCVIw

    Internal URL: lyncdiscoverinternal.penfam.local --> web1.penfam.local
    External URL: ( also works) -->

    Also the DNS is right, and like I said I'm not using TMG so there is no publishing rule.  I am forwarding 80 to 8080 and 443 to 4443.  Based on this article:

    Johnathan Penberthy

    Monday, December 17, 2012 4:50 PM
  • Hi..Jonathan,

    If it's working for your phone then we can assum that the Lync side configuration and Firewall forwarding is correct.

    I have a simmiler issue, it that case some phones are working and some not, for me what works is reinstalling the RootCA cert on the phones.

    Anyway can you check the bellow site to test if everthing is in oder.



    Wednesday, December 19, 2012 7:44 AM
  • Lync connected just fine on that site with multiple users.  I have installed the RootCA a couple times.

    Johnathan Penberthy

    Wednesday, December 19, 2012 8:31 AM
  • {"AccessLocation":"Internal","Root":{"Links":[{"href":"https:\/\/web1.penfam.local\/Autodiscover\/AutodiscoverService.svc\/root\/domain","token":"Domain"},{"href":"https:\/\/web1.penfam.local\/Autodiscover\/AutodiscoverService.svc\/root\/user","token":"User"}]}}

    It give the wrong URL when connecting from outside. also it connect to the internal Site so as expected it return the internal URL. Can you check bellow.

    1. You have not setup MX for internal only.

    2. EXternal Set-CsWebServer -Identity XXXXX -McxSipExternalListeningPort 5087

    2. Also check under "External site" URL Rewrite - lyncdiscover rule is there.

    Let know.




    Wednesday, December 19, 2012 9:29 AM
  • Also..!

    Are you useing a two IP one the FE, one for internal site and one for external.

    Wednesday, December 19, 2012 9:38 AM
  • I am still getting Internal URL instead of External.

    1. Get-CSMxcConfiguration | fl

     Exposed WebURL: External

    Does this mean I am only setup MX internally?

    2. Setup-CsWebServer -Identity fepool.domain -McxSipExternalListeningPort 5087

    3. "External site" URL Rewrite - has over 10 rules which include Autodiscover rule and client access policy rule

    Not sure how to fix to redirect to External...


    Thursday, February 12, 2015 5:46 PM
  • Hi,

    We have the same problem. Have you solved the issues?

    Monday, April 29, 2019 1:04 PM