locked
LIS 3.3 on CentOS 5.5 RRS feed

  • Question

  • I'm trying to get the LIS installed on a CentOS 5.5 Hyper-V VM running on Server 2012.  When I run ./install.sh I get a whole bunch of messages saying that dependencies are needed (too many to list) and then the installed exits with "Kmod RPM Installation failed, exiting"

    Is there anyway to get the integration services installed on this version of CentOS or am I out of luck?

    Saturday, September 1, 2012 8:08 AM

Answers

  • The fine manual in with the download of LIS 3.3 says:

    Other supported operating systems (including SUSE Linux Enterprise Server 10 and Red HatEnterprise Linux 5) 
    should use the version of Linux Integration Services available at

    http://www.microsoft.com/downloads/en/details.aspx?FamilyID=eee39325-898b-4522-9b4c-f4b5b9b64551.

    Which means: You might be lucky to make stuff work on EL5 under Server 2012, but LIS 2.1 is the (dead) end in terms of Hyper-V integration.
    Newer deatures like > 4vCPU just won't be supported with 2.1, that's mostly because EL5 is based on 2.6.18 while EL6 uses 2.6.32 as base.

    For a fresh deployment you should anyway consider updating to EL6 base which will gibe you the additional stuff. :-)
    Last time I used RHEL 5 with LIS 2.1 on 2008 R2 everything worked with these drivers, no worry.

    • Marked as answer by Obraik Monday, September 10, 2012 6:50 AM
    Monday, September 3, 2012 4:39 PM

All replies

  • The fine manual in with the download of LIS 3.3 says:

    Other supported operating systems (including SUSE Linux Enterprise Server 10 and Red HatEnterprise Linux 5) 
    should use the version of Linux Integration Services available at

    http://www.microsoft.com/downloads/en/details.aspx?FamilyID=eee39325-898b-4522-9b4c-f4b5b9b64551.

    Which means: You might be lucky to make stuff work on EL5 under Server 2012, but LIS 2.1 is the (dead) end in terms of Hyper-V integration.
    Newer deatures like > 4vCPU just won't be supported with 2.1, that's mostly because EL5 is based on 2.6.18 while EL6 uses 2.6.32 as base.

    For a fresh deployment you should anyway consider updating to EL6 base which will gibe you the additional stuff. :-)
    Last time I used RHEL 5 with LIS 2.1 on 2008 R2 everything worked with these drivers, no worry.

    • Marked as answer by Obraik Monday, September 10, 2012 6:50 AM
    Monday, September 3, 2012 4:39 PM
  • Sorry for the late reply.  Essentially yeah, I gave up on sticking with CentOS 5.5 and moved to CentOS 6.3, just as the LIS 3.4 pack came out which installed perfectly.

    As a bit of history, I'm virtualising a PBX system.  Originally I was going with Trixbox but it seems it's pretty much been abandoned so bit the bullet and installed CentOS6 from scratch and manually installed Asterisk and FreePBX.

     
    Monday, September 10, 2012 6:50 AM
  • The move should be worthy :-)

    Nonetheless I have to update my statement a little. While LIS 3-3.3 never appeared for EL5, MS just released LIS 3.4 and added official support for Centos 5 and bump overall EL5 drivers from the quite outdated 2.1 to a Server 2012-compatible version.

    Tuesday, September 11, 2012 12:27 PM