none
Installation via Software Center / Application Catalog auf Terminalservern blocken

    Question

  • Hallo an die Runde,

    ich habe gerade ein etwas schwer zu lösendes Thema. Ich hoffe jemand weiß Rat :)

    Also SCCM 2012 R2 Umgebung mit mehren DP an mehreren Standorten. Software Distribution läuft über Software Center und Application Catalog für alle Clients. Außerdem ist noch eine Citrix Infrastruktur für die Terminaldienste dabei. Auf den TS läuft auch ein Internet Explorer. Rufen die User nun über diesen den Application Catalog auf können die User auf dem TS die Software installieren. Wie kann man das abstellen? Kann man Geräte ausschließen von der Installtion? Die Software an sich stelle ich ja über Usersammlungen bereit somit kann ich das dort schon mal nicht steuern.

    Auf dem TS könnte man ja einfach den SCCM Client deinstallieren, geht aber auch nicht da Endpoint Protection darüber läuft.

    Hat jemand eine Idee?

    Tuesday, June 16, 2015 9:27 AM

Answers

  • Ich habe das gerade mal verifiziert. Es ist wohl am einfachsten, wenn Du "Install permission" auf "No users" stellst. Dann kann auf den betroffenen Clients keiner mehr etwas aus dem Application Catalog laden. Zudem den ConfigMgr-Client ohne Softwarecenter installieren und Du hast eine saubere Lösung.


    http://www.clientmgmt.de

    • Proposed as answer by Robert Haneberg Thursday, June 18, 2015 11:13 AM
    • Marked as answer by MarcelMik Friday, June 26, 2015 5:04 AM
    Wednesday, June 17, 2015 2:01 PM

All replies

  • Custom Client Agent Settings für alle Terminal-Server und dann SoftwareDistributionAgent deaktivieren.

    Torsten Meringer | http://www.mssccmfaq.de

    Tuesday, June 16, 2015 11:23 AM
    Answerer
  • Ok das macht Sinn.

    Ich habe jetzt Client Settings für Terminalserver gebaut und dort alles raus gelassen bis auf Endpoint und Hardware und Softwareinventur. Dann sollte das ja passen und im Laufe der nächsten Stunden angepasst sein oder?

    Kann ich das noch forcieren?

    Tuesday, June 16, 2015 12:05 PM
  • Passiert alles beim nächsten Policy Refresh automatisch. Default alle 60min.

    Torsten Meringer | http://www.mssccmfaq.de

    Tuesday, June 16, 2015 4:35 PM
    Answerer
  • Clientsettings erstellt, diese auch der Sammlung TS zugewiesen, keine Änderung. Softwarecenter nach wie vor auf den TS vorhanden. Habe auch nochmal den Client auf den TS neuinstalliert. Keine Änderung. Installation nach wie vor möglich
    Wednesday, June 17, 2015 4:55 AM
  • Hi Marcel,

    das Softwarecenter bleibt bei deaktiviertem SoftwareDistributionAgent natürlich installiert. Der Client wird aber keine Software darüber mehr erhalten. Wenn Du das Softwarecenter nicht installiert haben willst, dann kannst Du seit Configuration Manager 2012 R2 das Softwarecenter bei der Installation des Clients nicht mitinstallieren.

    CCMSetup.exe /ExcludeFeatures:ClientUI

    Grüße

    André

    Edit: Das macht bei Terminal Servern ggf. auch Sinn, da das Softwarecenter einen vergleichsweise hohen Speicherbedarf pro User hat.

    Edit 2: Ob der SoftwareDistributionAgent deaktiviert ist, siehst Du unter Components im ConfigMgr-Client.

    http://www.clientmgmt.de




    Wednesday, June 17, 2015 9:02 AM
  • Hallo,

    ja das habe ich natürlich geprüft. Die Komponente ist aktiviert und ich kann auch noch ganz normal darüber installieren. Ich habe jetzt auf allen TS den Client deinstalliert und werde jetzt mal mit dem o.g . Parameter das Softwarecenter ausblenden. Mal schauen ob das was bringt.

    Wednesday, June 17, 2015 1:17 PM
  • Ich habe das gerade mal verifiziert. Es ist wohl am einfachsten, wenn Du "Install permission" auf "No users" stellst. Dann kann auf den betroffenen Clients keiner mehr etwas aus dem Application Catalog laden. Zudem den ConfigMgr-Client ohne Softwarecenter installieren und Du hast eine saubere Lösung.


    http://www.clientmgmt.de

    • Proposed as answer by Robert Haneberg Thursday, June 18, 2015 11:13 AM
    • Marked as answer by MarcelMik Friday, June 26, 2015 5:04 AM
    Wednesday, June 17, 2015 2:01 PM