none
FAST Search - From the Site Collection Administration, FAST Search links lead to unexpected errors... RRS feed

  • Question

  • While search is working, 

    Site Collection Administration -> FAST Search keywords
    Site Collection Administration -> FAST Search site promotion and demotion
    Site Collection Administration -> FAST Search user context

    both from http://server:888 and http://fqdn:888.  Is this working for the rest of you guys?


    Thursday, December 10, 2009 10:01 AM

Answers

All replies


  • For that 3 links to work, you need to make sure "SharePoint Server Standard Site Collection features" is activated for your site collection: go to site settings, under "site collection administration", click "site collection features".

    Thanks

    Ying
    Thursday, December 10, 2009 10:30 PM
  • I have a created a site using the FAST Search Center template but when I go into Site Actions>Site Settings I don't see any of the above links. What template have you used to create your search site.?

    Cheers,

    Colin

    Friday, December 11, 2009 1:58 PM
  • Hi, Colin,
    Most likely you are at the site settings page for a site (of type spweb). To get those links, you need to go to the site settings page for the site collection (of type spsite). Click on the link "go to top level site settings" under the section "site collection administration" will get you there.
    HTH
    Ying

    Friday, December 11, 2009 6:22 PM
  • Hi Ying,

    I am looking at the top-level site settings, I can see the section Site Collection Administration but under that heading I don't see any links that start FAST.

    I have just created a new site collection using the FAST Search Center template and again I don't see any links beginning with FAST.

    Cheers,

    Colin
    Monday, December 14, 2009 1:21 PM
  • You are right, the FAST search center don't use FAST in the name of the links (I think there is only 3 links there), because by default everything is supposed to target against FAST. Only enterprise search center makes that distinction and has 6 links total, one set each. 

    Ying

    Monday, December 14, 2009 10:16 PM
  • Hi Ying,

    Thanks for the clarification. So what template should we use for getting the best out of FAST Searches? Do you have any guidance you can give us?

    Cheers,

    Colin
    Tuesday, December 15, 2009 12:33 PM
    • Fast search center is for fast search
    • Enterprise search center is for Sharepoint search
    • Basic search center is legacy template that should be avoided.

      Ying
    Tuesday, December 15, 2009 10:05 PM
  • Hi

    You do need to use the FAST specific admin pages to manage FAST keywords, promotions and user contexts:

    Site Collection Administration -> FAST Search keywords
    Site Collection Administration -> FAST Search site promotion and demotion
    Site Collection Administration -> FAST Search user context

    If you want to create a FAST Search Center as a sub-site in an existing Site Collection, make sure that you have activated the SharePoint Server Publishing Infrastructure feature.

    Regards,
    Jan Helge

    Wednesday, December 16, 2009 10:30 AM
  • Two things are required for the FAST Site Admin Links to be visible on site settings page.

    1. The Sharepoint SKU must be Enterprise SKU

    2.  Ensure that "SharePoint Server Enterprise Site Collection features" have been activated. You can do this by navigating to Site Settings -> Site   Collection Administration -> Site Collection Features and choosing " SharePoint Server Enterprise Site Collection features" and clicking activate button next to it.

     

    Also please note that these links are available only at site collection level. They are not available at sub site level.

     

    Wednesday, December 16, 2009 5:55 PM
  • <!-- /* Font Definitions */ @font-face {font-family:"Cambria Math"; panose-1:2 4 5 3 5 4 6 3 2 4; mso-font-alt:"Calisto MT"; mso-font-charset:0; mso-generic-font-family:roman; mso-font-pitch:variable; mso-font-signature:-1610611985 1107304683 0 0 415 0;} @font-face {font-family:Calibri; panose-1:2 15 5 2 2 2 4 3 2 4; mso-font-alt:"Century Gothic"; mso-font-charset:0; mso-generic-font-family:swiss; mso-font-pitch:variable; mso-font-signature:-520092929 1073786111 9 0 415 0;} /* Style Definitions */ p.MsoNormal, li.MsoNormal, div.MsoNormal {mso-style-unhide:no; mso-style-qformat:yes; mso-style-parent:""; margin:0in; margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-fareast-font-family:Calibri; mso-fareast-theme-font:minor-latin; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman"; mso-bidi-theme-font:minor-bidi;} span.EmailStyle15 {mso-style-type:personal; mso-style-noshow:yes; mso-style-unhide:no; mso-ansi-font-size:11.0pt; mso-bidi-font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-fareast-font-family:Calibri; mso-fareast-theme-font:minor-latin; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman"; mso-bidi-theme-font:minor-bidi; color:windowtext;} .MsoChpDefault {mso-style-type:export-only; mso-default-props:yes; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-fareast-font-family:Calibri; mso-fareast-theme-font:minor-latin; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman"; mso-bidi-theme-font:minor-bidi;} @page Section1 {size:8.5in 11.0in; margin:1.0in 1.0in 1.0in 1.0in; mso-header-margin:.5in; mso-footer-margin:.5in; mso-paper-source:0;} div.Section1 {page:Section1;} -->

    So what is the difference between “Search keywords” and “FAST search keywords”

    Friday, April 30, 2010 5:06 PM
  • What if only one link doesn't work...

     

    When I click FAST Search user context it gives me

     

    "Error

    An unexpected error has occured.....

    "

     

    The other two work great.

    Tuesday, June 15, 2010 5:20 PM
  • No Timothy, it's the same for me. FAST Search setup is up and running. It crawls all content sources fine. FAST Search Center works great, but these three links get unexpected errors. I have Standard and Enterprise feature and SharePoint Server Publishing Infrastructure  activated and all web applications linked to FAST Query SSA.

    Alberto

    Monday, August 2, 2010 1:17 PM
  • I was able to fix this by creating a local machine group called FASTSearchKeywordAdministrators and adding the users from the FASTSearchAdministrators group into it.
    Thursday, August 12, 2010 12:52 PM
  • Same here, the other two work fine, but this one just bombs.

    Any ideas?


    Garth H MCTS: SQL 2008 BI http://bitinkering.spaces.live.com/
    Friday, August 27, 2010 2:10 AM
  • Hello Alberto / GarthH_BI,

    I agree with cmcauliffe that Create a local group called FASTSEARCHKEYWORDADMINISTRATORS on all your Fast Servers & all users whom you want to have capability to add keywords from Site Collection Administration page.

    Hope this helps...

    Hiran


    Reagrds,

    Hiran
    Microsoft Online Community Support
    Saturday, August 28, 2010 6:24 PM
    Moderator
  • YES ! That group did the trick. I suggest to update the technet documentation with this.

    Thank you very much, cmcauliffe I give you my vote.

    Monday, September 6, 2010 10:29 AM
  • Hi Alberto,

    Thanks for your feedback on TechNet Documentation. I will pass your feedback to appropriate team.

    Thanks,

    Hiran


    Reagrds,

    Hiran
    Microsoft Online Community Support
    Tuesday, September 7, 2010 9:13 PM
    Moderator
  • I had this happen and had done everything others had done, but the links were missing from Site Collection Administration. 

    To fix the problem I had to activate (via powershell) a SearchExtensions feature which is not visible via the UI.

    Instructions available on my blog: http://www.neilrichards.net/blog/?p=149

    • Proposed as answer by erkindunya2010 Thursday, April 14, 2011 2:19 PM
    Saturday, March 12, 2011 11:40 AM
  • Hi, Do not waste your time with creating a local group called FASTSearchKeywordAdministrators, it wont work 

    Speacial Thanks to Neil Richards

    Just do follwing

    PS C:\Users\Administrator> Get-SPFeature | ? { $_.id -eq "5EAC763D-FBF5-4d6f-A76B-EDED7DD7B0A5"}

     

    Result:

    DisplayName                    Id                                       Scope
    -----------                    --                                       -----
    SearchExtensions               5eac763d-fbf5-4d6f-a76b-eded7dd7b0a5     Site


    PS C:\Users\Administrator> $siteWithNoFastFeatures = get-SPSite http://your SP SITE NAME FOR FAST COLLECTION (ADD UR OWN url)
    PS C:\Users\Administrator> $siteWithNoFastFeatures.Features.Add("5EAC763D-FBF5-4d6f-A76B-EDED7DD7B0A5")

    Result:
    DefinitionId           : 5eac763d-fbf5-4d6f-a76b-eded7dd7b0a5
    Parent                 : SPSite Url=http:// SP FAST NAME (ur OWN url)
    Properties             : {}
    Definition             : SPFeatureDefinition Name=FeatureDefinition/5eac763d-fbf5-4d6f-a76b-eded7dd7b0a5
    Version                : 14.0.0.0
    FeatureDefinitionScope : Farm

     

    Hope it helps,

    • Proposed as answer by erkindunya2010 Thursday, April 14, 2011 2:19 PM
    Wednesday, April 13, 2011 10:50 PM