locked
Windows 7 DHCP issue RRS feed

  • Question

  • Greetings.

      We are having a strange issue with our Windows 7 clients unable to apply DHCP address. Here's whats happening:

    Windows 7 Client connects to network

    Server 2003 DHCP server assigns IP address (i can see the lease in the Address Leases windows for the client with correct expiration date)

    Windows 7 Computer does not apply address to network adaptor, only displays APIPA address.

    Tried Ipconfig /release and renew - no go

    Assigning static address allow access to network but this is not a sufficent solution

    Adding NetworkService and LocalService to Administrators group on Windows 7 machine allows IP address to be applied to network adaptor. This too is not a sufficent solution.

    Windows XP clients do not have issue with DHCP.

    Is there a particular Local Security Policy in Windows 7 that would prevent a IP address from being applied to a network adaptor?

    Thanks for any insight into this issue.

     

     

    Saturday, February 5, 2011 7:48 PM

Answers

  • Hi Jeff

    do you have 802.1x configured for your network?? if not make sure its unticked on the setting for the adapter...


    tech-nique
    Tuesday, February 8, 2011 10:27 PM
  • Hi Jeff,

     

    Thanks for update.

     

    In addition ,here are some concerns you may check it :

     

    1.    Is these windows 7 DHCP client on the same subnet as the DHCP server? If not are there Windows 7 DHCP clients on the same subnet as the DHCP server that can obtain an IP address?

    2.    If the Windows DHCP client is more than one hop away from the Windows DHCP server are the customer’s routers or VLAN switches configured with a DHCP Server relay agent?

    3.    Have you set any IPSec policies enabled on DHCP server or Windows 7 client hosts?

    4.    Does the issue occur when booted to Safe Mode with Networking? If not, isolate the issue by clean booting with msconfig.

     

    Troubleshooting DHCP clients

    http://technet.microsoft.com/en-us/library/cc757164(WS.10).aspx

     

    Thanks.

     
    Tiger Li

     

    TechNet Subscriber Support in forum
    If you have any feedback on our support, please contact tngfb@microsoft.com


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, February 18, 2011 2:45 AM

All replies

  • Hi JTaylor

    Why don't you try disabling APIPA and see what happens beacuse maybe the win 7 client is waiting too short a time for the DHCP server to respond and ends up giving itself an APIPA address.. this is all just theoretical but test it on one win 7 client see how it goes.

    Disabling APIPA

    http://msdn.microsoft.com/en-us/library/aa505918.aspx

    hope this helps :)


    tech-nique
    Sunday, February 6, 2011 7:52 PM
  • Hi,

     

    Thanks for posting here.

     

    This issue only occurred on one particular windows 7 clients or all.

     

    Meanwhile, I’d also suggest try resetting TCP/IP setting to default with following method:

     

    How to reset Internet Protocol (TCP/IP)

    http://support.microsoft.com/kb/299357

     

    Thanks.

     

    Tiger Li


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, February 7, 2011 8:53 AM
  • Thanks for the responses!

    Tiger, This issue is happening on all our Windows 7 clients, 32 and 64bit.

    I will give these two methods a try and report back asap.

    Thanks!

    Jeff

     

     

    Monday, February 7, 2011 10:02 PM
  • I have tried Tiger and Tech-nique's suggestions but neither worked.

    On more note to add that I left off in my original post, when I perform a ipconfig /renew I recieve "Access Denied"

    Thanks!!

    Jeff

     

     

    Tuesday, February 8, 2011 7:31 PM
  • Hi Jeff

    do you have 802.1x configured for your network?? if not make sure its unticked on the setting for the adapter...


    tech-nique
    Tuesday, February 8, 2011 10:27 PM
  • Good point tech-nique, I will give that a shot tomorrow.

    I discovered another finding today, I was looing at the registry and noticed that the following key contained the IP address assigned by the DHCP server:

    HKLM>System>CurrentControlSet>Services>Tcpip>Parameters>Interfaces>"Long Adaptor String">

    But when I run ipconfig it still showed the APIPA address.

    ODD!

    Thanks!!

    Jeff

    Tuesday, February 8, 2011 11:54 PM
  • Hi Jeff,

    If there is any update on this issue, please feel free to let us know.

    We are looking forward to your reply.

    Tiger Li

    TechNet Subscriber Support in forum
    If you have any feedback on our support, please contact tngfb@microsoft.com


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, February 10, 2011 9:21 AM
  • Sorry for no replies yet, I hope have more information in a couple of days.

     

    THANKS!!
    Jeff

    Monday, February 14, 2011 9:18 PM
  • Hi Jeff,

    Have you tried the suggestion that tech-nique posted to disable 802.1x authentication on Windows 7 hosts and how is going ?

    Thanks.

    Tiger Li

    TechNet Subscriber Support in forum
    If you have any feedback on our support, please contact tngfb@microsoft.com


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, February 15, 2011 6:56 AM
  • I did try tech-nique's solution, there were not any options in the network adaptor setting for 802.1x

    We are looking into possilble local security policy issues at this time.

    THANKS!!

    Jeff

     

    Thursday, February 17, 2011 4:40 PM
  • Hi Jeff

    When i asked you disable APIPA on your machines, what ip address did you get?? where there any error messages, anything logged? Please try checking for logs while trying to get a DHCP address.. (Check logs on DHCP server and Client machine and post them up so we see what we are dealing with)


    tech-nique
    Thursday, February 17, 2011 5:47 PM
  • Hi Jeff,

     

    Thanks for update.

     

    In addition ,here are some concerns you may check it :

     

    1.    Is these windows 7 DHCP client on the same subnet as the DHCP server? If not are there Windows 7 DHCP clients on the same subnet as the DHCP server that can obtain an IP address?

    2.    If the Windows DHCP client is more than one hop away from the Windows DHCP server are the customer’s routers or VLAN switches configured with a DHCP Server relay agent?

    3.    Have you set any IPSec policies enabled on DHCP server or Windows 7 client hosts?

    4.    Does the issue occur when booted to Safe Mode with Networking? If not, isolate the issue by clean booting with msconfig.

     

    Troubleshooting DHCP clients

    http://technet.microsoft.com/en-us/library/cc757164(WS.10).aspx

     

    Thanks.

     
    Tiger Li

     

    TechNet Subscriber Support in forum
    If you have any feedback on our support, please contact tngfb@microsoft.com


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, February 18, 2011 2:45 AM
  • Hi Jeff,

    If there is any update on this issue, please feel free to let us know.

    We are looking forward to your reply.

    Tiger Li

    TechNet Subscriber Support in forum
    If you have any feedback on our support, please contact tngfb@microsoft.com


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, February 23, 2011 11:08 AM
  • Hi all,

      Sorry for the extremely late update on this issue. We finally discovered the issue was with group policy. One of our admins had applied a security policy that changed all our corporate settings and really screwed up other things after further investigation.

    Anywho after several hours of "repairing" the local security policy everything is back to normal. Just a FYI the security policy applied several hundred registry settings after we removed those settings "new" Windows 7 computers could obtain a IP address without issue.

    What a head ache!!!

    Thanks to everyone who provided help!

     

    Jeff

    Friday, March 25, 2011 12:21 AM
  • Jeff,

    I have run into this issue after applying the Win 7 EC baseline policy published by MS SCM. Do you know which specific policy broke DHCP acknowledgements on the Win 7 machine?  Any help would be greatly appreciated.

    Tuesday, April 19, 2011 4:31 PM
  • I applied that EC Desktop policy as well and ran into this problem.  If anyone found out which setting it might be, please let me know.
    My symptoms were quite confusing.  I had a working system, plugged into my domain getting DHCP.  I then needed to test VPN, so I plugged the computer into a Comcast ISP router and it would not pull an IP. (I have tested this router and done this with my laptop many times and it was working at the same time, same line etc)  the fact that it worked on my laptop and not my desktop led me to beleive it was a GPO setting.
    After removing the EC Desktop Policy, and running gpupdate /force /boot I could then obtain IP's from both.... That is where I am at.

    Any help or direction would be appreciated.

    CJA


    Chris
    Tuesday, July 26, 2011 8:27 PM