none
FIM Search Scope Issue RRS feed

  • Question

  • I recently added a new resource to my FIM environment and am having difficulties getting the information displayed that I want. I have created a nav bar resource for the search scope ran an IIS reset and everything looks good, I click on the new nav link and it takes me to the resource I want to see. However it has "DisplayName", "Description", "Created Time", and "Resource Type" in the displayed columns. I would like it to just show "DisplayName" and "templateID"(another attribute bound to the resource). I verified that in the search scope results I specified to return only those two attributes.

    The URL the nav bar takes me to. http://devcars.nationwidechildrens.dev/IdentityManagement/aspx/customized/customizedobjects.aspx?type=[newResourceName]&searchType=[SearchScopeGUID]

    I know I must be missing something I just can't seem to find it.

    Wednesday, June 18, 2014 11:49 AM

All replies

  • Open created/used search scope and enter "Results" tab.

    Here you have "Attribute" field - you should specify those if you want to have them displayed, so it would be:

    DisplayName;templateID

    Also, you can specify Redirecting URL here.

    For example for WorkflowDefinition, I have added "Description" to be displayed (Invoke IISRESET after change):


    If you found my post helpful, please give it a Helpful vote. If it answered your question, remember to mark it as an Answer.

    Wednesday, June 18, 2014 12:21 PM
  • This is what I currently have, DisplayName and epicTemplate are the system names of the attribute I want displayed.

    Here is what I get when I click the nav link.

    Wednesday, June 18, 2014 1:11 PM
  • Hello,

    Try to add the keyword "EpicSubTemplates" and "customized"

    and of course, run IISRESET


    Regards,


    Sylvain



    • Edited by Sylvain.c Wednesday, June 18, 2014 2:21 PM
    Wednesday, June 18, 2014 1:54 PM
  • I get the same result as above.
    Wednesday, June 18, 2014 2:35 PM
  • Yes, after testing this myself, i get the same result...
    It's seems like a bug


    Sylvain

    Thursday, June 19, 2014 12:27 PM
  • For your search scope, do you have "BasicUI", and "Global" in addition to your resource name "EpicSubTemplates" as usage keywords? "BasicUI" grants the rights to users to use your search scope and a usage keyword that matches the resource name is how the portal knows which search scopes to associate with the resource (and which search scopes show up in the "search within" dropdown. The "Global" keyword puts it on the top menu page (if I remember correctly).

    You probably also want to add a related search scope for the resource type AttributeTypePicker with a keyword of AttributePicker - this makes creating MPRs and filters easier. Look at one of the existing AttributeTypePicker scopes for the XPath query you need.

    Here is an example of my search scopes for a custom resource called "Location":

    Thursday, June 19, 2014 5:22 PM
  • And what if you enter Administration -> All Resources -> "Your type" ?

    Do you see correct column displayed then?


    If you found my post helpful, please give it a Helpful vote. If it answered your question, remember to mark it as an Answer.

    Monday, June 23, 2014 12:16 PM