locked
datetime field takes time as 00:00 RRS feed

  • Question

  • I am facing an issue with a calendar view of a list.

    When i enter dates in dataview, it takes the date and defaults time to 00:00. 

    When that even is displayed in the calendar view, it does not display the even for that day and if we make it 00:01 while entering 

    then it displays.

    Is there a way to configure it to take 00:01 automatically.

    Friday, August 14, 2015 11:19 AM

Answers

  • SharePoint actually stores date/time in GMT zone. That is why it shows one day previous time. i.e. 00 means 12 AM of previous day.

    If you have checked your regional settings and pointing them to your local time zone, and still it is not working.

    Then i will suggest to create a calculated column and add hours (difference of GMT - your timezone). Concat your date with this updated hour text and show this column in calendar view.


    • Edited by Sachin_Jadhav Thursday, September 3, 2015 11:58 AM
    • Proposed as answer by Sara Fan Tuesday, September 8, 2015 12:52 AM
    • Marked as answer by Sara Fan Wednesday, September 9, 2015 12:52 AM
    Thursday, September 3, 2015 11:57 AM