none
SMS_SITE_SQL_BACKUP component failed to reinstall RRS feed

  • Question

  • Hi,

    I have a problem with SMS_SITE_SQL_BACKUP component on my SCCM SQL server. The SQL server is running on Windows Server 2003 x64 SP2 and site is in Native mode running SCCM SP1 R2 on Windows Server 2003 SP2 (separate servers)
    I've enabled a Backup ConfigMgr Site Server maintance task 2 weeks ago and since then site backup was running fine.
    Few days ago I've noticed that SMS_SITE_SQL_BACKUP component start to log following errors:

    "SMS Site Component Manager failed to reinstall this component on this site system.

    Solution: Review the previous status messages to determine the exact reason for the failure. SMS Site Component Manager will automatically retry the reinstallation in 60 minutes. To force SMS Site Component Manager to immediately retry the reinstallation, stop and restart SMS Site Component Manager using the SMS Service Manager."

    Information in 'sitecomp.log'

        "Reinstalling component SMS_SITE_SQL_BACKUP...    SMS_SITE_COMPONENT_MANAGER    26/06/2009 15:56:08    2204 (0x089C)
    STATMSG: ID=1018 SEV=I LEV=M SOURCE="SMS Server" COMP="SMS_SITE_SQL_BACKUP_SiteName" SYS=SiteName SITE=SiteCode PID=1808 TID=2204 GMTDATE=Fri Jun 26 14:56:08.956 2009 ISTR0="" ISTR1="" ISTR2="" ISTR3="" ISTR4="" ISTR5="" ISTR6="" ISTR7="" ISTR8="" ISTR9="" NUMATTRS=0    SMS_SITE_COMPONENT_MANAGER    26/06/2009 15:56:08    2204 (0x089C)
          Starting bootstrap operations...    SMS_SITE_COMPONENT_MANAGER    26/06/2009 15:56:09    2204 (0x089C)
            Component file list item in the install map for component SMS_SITE_SQL_BACKUP does not contain srvboot.exe.    SMS_SITE_COMPONENT_MANAGER    26/06/2009 15:56:09    2204 (0x089C)
          Bootstrap operations aborted.    SMS_SITE_COMPONENT_MANAGER    26/06/2009 15:56:09    2204 (0x089C)
    LogEvent(): Successfully logged Event to NT Event Log (4, 77, 1073742842, (null)).    SMS_SITE_COMPONENT_MANAGER    26/06/2009 15:56:09    2204 (0x089C)
          The server already contains some of the required files for this component.  A disk space check will not be made.    SMS_SITE_COMPONENT_MANAGER    26/06/2009 15:56:09    2204 (0x089C)
          Installed file \\SiteName\E$\SMS_SiteName\bin\x64\smssqlbkup.exe.    SMS_SITE_COMPONENT_MANAGER    26/06/2009 15:56:09    2204 (0x089C)
          All files installed.    SMS_SITE_COMPONENT_MANAGER    26/06/2009 15:56:09    2204 (0x089C)
          Starting bootstrap operations...    SMS_SITE_COMPONENT_MANAGER    26/06/2009 15:56:09    2204 (0x089C)
            Component file list item in the install map for component SMS_SITE_SQL_BACKUP does not contain srvboot.exe.    SMS_SITE_COMPONENT_MANAGER    26/06/2009 15:56:09    2204 (0x089C)
          Bootstrap operations aborted.    SMS_SITE_COMPONENT_MANAGER    26/06/2009 15:56:09    2204 (0x089C)
        Reinstallation failed and will be retried in the next polling cycle.    SMS_SITE_COMPONENT_MANAGER    26/06/2009 15:56:09    2204 (0x089C)
    LogEvent(): Successfully logged Event to NT Event Log (1, 77, -1073740804, (null)).    SMS_SITE_COMPONENT_MANAGER    26/06/2009 15:56:09    2204 (0x089C)"

    Information in 'Application' log on SQL server:
    "14:56:08, component SMS_SITE_COMPONENT_MANAGER on computer ServerName reported:  , HRESULT=0x00000000."
    "14:56:08, component SMS_SITE_COMPONENT_MANAGER on computer ServerName reported:  , 60."

    I've rechecked all the permissions and they're OK. Site server computer account is a local admin on the sql box (SQL and main SCCM server are separate servers). All other SCCM components are working fine.
    When I tried to query this component I'm getting error: Error communicating with component I've applied patch specified here: http://support.microsoft.com/default.aspx/kb/957879 but it didn't resolve this issue.

    Is there something I'm missing ? Is there any other log to be checked ?

    Any help Appreciate
    Tuesday, June 30, 2009 12:27 PM

Answers

  • Thanks to Gorrilla who post his solution here: http://www.windows-noob.com/forums/index.php?showtopic=816&hl= I've manage to fixed this error.
    It looks like a C:\Program Files\Microsoft Configuration Manager\Install.MAP file was corrupted. I had to manually modify it and add additional line: 'FILE <srvboot.exe><0><219904>' to install.map file.


    BEGIN_COMPONENT_FILELIST
        <SMS_SITE_SQL_BACKUP>
        <1193>
        BEGIN_DIRECTORY
            <bin\i386>
            <9><X86><>
            FILE <smssqlbkup.exe><1><766496>
        FILE <srvboot.exe><0><219904>
        END_DIRECTORY
        BEGIN_DIRECTORY
            <bin\x64>
            <17><AMD64><>
            FILE <smssqlbkup.exe><1><1547296>
        END_DIRECTORY
        UNIT <SMS>
    END_COMPONENT_FILELIST


    Similar issue is described in this MS KB article: http://support.microsoft.com/kb/227010 This supposed to be issue only with SMS 2003 but it looks like it also applies to SCCM 2007 with remote SQL installation.
    • Marked as answer by santospl Thursday, July 2, 2009 12:16 PM
    Thursday, July 2, 2009 12:15 PM

All replies

  • Thanks to Gorrilla who post his solution here: http://www.windows-noob.com/forums/index.php?showtopic=816&hl= I've manage to fixed this error.
    It looks like a C:\Program Files\Microsoft Configuration Manager\Install.MAP file was corrupted. I had to manually modify it and add additional line: 'FILE <srvboot.exe><0><219904>' to install.map file.


    BEGIN_COMPONENT_FILELIST
        <SMS_SITE_SQL_BACKUP>
        <1193>
        BEGIN_DIRECTORY
            <bin\i386>
            <9><X86><>
            FILE <smssqlbkup.exe><1><766496>
        FILE <srvboot.exe><0><219904>
        END_DIRECTORY
        BEGIN_DIRECTORY
            <bin\x64>
            <17><AMD64><>
            FILE <smssqlbkup.exe><1><1547296>
        END_DIRECTORY
        UNIT <SMS>
    END_COMPONENT_FILELIST


    Similar issue is described in this MS KB article: http://support.microsoft.com/kb/227010 This supposed to be issue only with SMS 2003 but it looks like it also applies to SCCM 2007 with remote SQL installation.
    • Marked as answer by santospl Thursday, July 2, 2009 12:16 PM
    Thursday, July 2, 2009 12:15 PM
  • I had the same issue of the component failing to reinstall on SMS_SITE_SQL_BACKUP.  My setup was SCCM (mixed mode) on Win2k8 x32, and SQL2005 on Win2k8 x32.  This fix solved my issue aswell.

    Thanks!

    Friday, July 3, 2009 2:06 AM
  • Thanks, this fixed my error as well.
    Friday, July 24, 2009 12:35 PM
  • Also thanks...after I had SCCM up and running with a remote SQL box for about 4 months it just start to throw the error. By adding the one line of code it also fixed my issue...and didn't have to burn time with online tech...ahhhh...the wonderment of Google..
    Friday, August 28, 2009 1:10 PM
  • Just to add a little information to what has already been said, this will break again when you install SP2.  At least, it did for me.  I am running a configuration that is almost identical to the original poster.  Except my site server is a 2008 machine.  Thanks to the original posters.

    Cheers

    Wednesday, February 10, 2010 6:40 PM
  • Fix worked for me - thanks to original poster and "Gorilla" at http://www.windows-noob.com/forums/index.php?showtopic=816&hl=

     

    Monday, April 19, 2010 12:05 PM
  • Thank you! I had the same problem and this thread solved it.

    /Tom Erik
    Wednesday, April 28, 2010 1:33 PM
  • Hi,

    I'm seeing the same error message, but am reluctant to implement this fix, as my install.map file is showing another file version for the smssqlbkup.exe

    BEGIN_COMPONENT_FILELIST
        <SMS_SITE_SQL_BACKUP>
        <1193>
        BEGIN_DIRECTORY
            <bin\i386>
            <9><X86><>
            FILE <smssqlbkup.exe><1><765280>
        END_DIRECTORY
        BEGIN_DIRECTORY
            <bin\x64>
            <17><AMD64><>
            FILE <smssqlbkup.exe><1><1544048>
        END_DIRECTORY
        UNIT <SMS>
    END_COMPONENT_FILELIST

     

    it is 765280 instead of 766496 as in the proposed solution.

    I'm running Windows 2008 R2 and SCCM 2007 R2 SP2.

    Has anyone else implemented this fix on 2008 R2 and SCCM 2007 R2 SP2?

    Many thanks!

    Filip

    • Proposed as answer by ZakiKadoura Wednesday, May 16, 2012 2:22 PM
    Friday, June 4, 2010 1:41 PM
  • We are running Server 2008 R2 with SCCM 2007 SP2 R2 and I was also worried about the differnet numbers from the solutions I was finding. I was having the same issue since installation with the sitecomp log showing:

    "Component file list item in the install map for component SMS_SITE_SQL_BACKUP does not contain srvboot.exe"

    We worked out that numbers are not the file version but the file size in bytes (My x86 smssqlbkup.exe was like yours 765280).

    The file size of our srvboot.exe was 333,664 bytes, thus I added the line:

        FILE <srvboot.exe><0><333664>

    We restarted Component Manager and finally got a successfull install of the SMS_SITE_SQL_BACKUP component.

    For reference here is the part from our install.map

    BEGIN_COMPONENT_FILELIST
        <SMS_SITE_SQL_BACKUP>
        <1193>
        BEGIN_DIRECTORY
            <bin\i386>
            <9><X86><>
            FILE <smssqlbkup.exe><1><765280>
        FILE <srvboot.exe><0><333664>
        END_DIRECTORY
        BEGIN_DIRECTORY
            <bin\x64>
            <17><AMD64><>
            FILE <smssqlbkup.exe><1><1544048>
        END_DIRECTORY
        UNIT <SMS>
    END_COMPONENT_FILELIST

     

    Friday, August 27, 2010 12:49 AM
  • Thanks for the original post.

    It worked fine for me too in w2k8 64bit. I had this problem after I upgraded from SP1 to SCCM SP2. This solution worked. The file srvboot.exe was missing in x64 folder. I had to copy from different location.

    Sri

    Friday, September 3, 2010 6:22 PM
  • Thanks this fixed my issue as well. I am new to SCCM administration, the guy that was managing before me pointed out the error, and said he did not now how to fix it.

    Did not take me long to find this. Worked great, Thanks for sharing.

    Me still being very green to sccm, what would be the consequence of leaving the error unresolved?

    Friday, October 15, 2010 6:51 PM
  • +1 for a successful resolution of SMS_SITE_SQL_BACKUP component re-installation failure causing backups to fail, cleared up using the Install.MAP file edit. Thanks for referencing the Windows-Noob article on Technet and thanks to Gorilla for the leg work.
    Friday, January 21, 2011 4:07 PM
  • This solution works for me too.  I have SCCM 07 SP2 R2 on W2k8 std x64. My DB server is SQL2005 (9.0.4035) on W2k3 R2 x64 SP2. Thank you much for the post and to Windowds-noob.com.
    Thursday, March 31, 2011 3:46 PM
  • Agreed. This also fixed my problem on a SQL 2005 cluster node running on Windows 2003 Server x64.

     

     

    BEGIN_COMPONENT_FILELIST

        <SMS_SITE_SQL_BACKUP>

        <1193>

        BEGIN_DIRECTORY

            <bin\i386>

            <9><X86><>

            FILE <smssqlbkup.exe><1><765280>

    FILE <srvboot.exe><0><219904> 

        END_DIRECTORY

        BEGIN_DIRECTORY

            <bin\x64>

            <17><AMD64><>

            FILE <smssqlbkup.exe><1><1544048>

    END_DIRECTORY

        UNIT <SMS>

    END_COMPONENT_FILELIST

    Wednesday, May 25, 2011 12:15 AM
  • Hi,

    I'm seeing the same error message, but issue is not fixing by adding the line "FILE <srvboot.exe><0><333664> "

    BEGIN_COMPONENT_FILELIST
        <SMS_SITE_SQL_BACKUP>
        <1193>
        BEGIN_DIRECTORY
            <bin\i386>
            <9><X86><>
            FILE <smssqlbkup.exe><1><765280>
        FILE <srvboot.exe><0><333664>
        END_DIRECTORY
        BEGIN_DIRECTORY
            <bin\x64>
            <17><AMD64><>
            FILE <smssqlbkup.exe><1><1544048>
        END_DIRECTORY
        UNIT <SMS>
    END_COMPONENT_FILELIST


    I'm running Windows 2008 R2 and SCCM 2007 SP2.

    Has anyone else implemented this fix on Windows 2008 R2 and SCCM 2007 SP2?

    Regards,

    SunilC

    Sunday, July 31, 2011 12:55 PM
  • This worked for me on SCCM 2007 SP2 R3, with SQL 2008 R2.

    Add the  FILE <srvboot.exe><0><333664>           in the install.map    file.

    Aslo have admin rights on the Remote SQL sql Server. And SysAdmin right on the instance.

    BEGIN_COMPONENT_FILELIST
        <SMS_SITE_SQL_BACKUP>
        <1193>
        BEGIN_DIRECTORY
            <bin\i386>
            <9><X86><>
            FILE <smssqlbkup.exe><1><765280>
            FILE <srvboot.exe><0><333664>
        END_DIRECTORY
        BEGIN_DIRECTORY
            <bin\x64>
            <17><AMD64><>
            FILE <smssqlbkup.exe><1><1544048>
        END_DIRECTORY
        UNIT <SMS>
    END_COMPONENT_FILELIST


    Nicolai
    Monday, October 24, 2011 9:42 AM
  • Hello,

    I have two Servers with the same configuration so why should I add this srvboot.exe line on one server to fix the backup failing and why the other server backup is still working fine without this line...

    This will create discrepancies between the site?

    I added the srvboot.exe in the install.map file of the server which is failing its backup but nothing chnaged it is still failing

    Thanks,

    Dom


    System Center Operations Manager 2007 / System Center Configuration Manager 2007 R2 / Forefront Client Security / Forefront Identity Manager
    • Edited by Felyjos Thursday, November 3, 2011 6:57 PM
    Thursday, November 3, 2011 5:34 PM
  • This line is available somewhere else in the same file... search for FILE <srvboot.exe><0> in the same file and you will find it with the correct file size code...
    Wednesday, May 16, 2012 2:24 PM
  • In my situation, SMS_SITE_SQL_BACKUP_(SiteServer) service has totally disappeared from the SQL Services earlier and now it is back. 

    The backup task still not successful though.

    I tried restarting the SMS_SITE_BACKUP service from SCCM server a few times but it won't work.

    When I execute the backup service task, the following status alert are generated:

    ID 4959.... the SQL Server Principal Name (SPN) could not be validated in Active Directory....

    Is there any quick fix for this?

    Thanks!


    • Edited by Mecoy Thursday, December 4, 2014 6:08 PM
    Wednesday, December 3, 2014 11:33 PM