none
DNS record not up to date RRS feed

  • Question

  • Environment: Windows Server 2012R2 ; DHCP ; DNS ; Windows 10 Ent. clients

    Hi all,

    I have the following problem that I hope you can help me to solve it:

    The DNS records for laptop clients are not always up to date.

    The laptops have WiFi and Ethernet connections available/connected.

    I.e. when I turn on my laptop, on the logon screen I can see on the bottom right corner the WiFi first trying to connect then quickly it switch to Ethernet.

    When I'm logged on, I open my DNS console and I see my machine record with the WiFi IP instead of my actual enabled connection which is the Ethernet.

    I know that if I disable the Ethernet (to force the WiFi connection) then I enable it again, the DNS record will be updated fast with my Ethernet IP.

    So my understanding is: Windows 10 try first the WiFi connection, if available it sends a DHCP request which will update the DNS record. Then, as I have an Ethernet connection available, it switch to it but for some reason the DNS record is not updated, so why?

    I know as well that if I don't touch the Ethernet connection, the DNS record will only be updated on next DHCP lease which is set to 8 days, so after 4 days.

    What can be done to solve this behaviour?

    Thank you for your help in advance,

    Tuesday, November 21, 2017 8:10 AM

All replies

  • Hi Acetik,

    About DNS not getting Updated,you could refer to the following thread.

    https://social.technet.microsoft.com/Forums/windowsserver/en-US/a4389ac8-a13b-4ce8-9b95-7286f22eb23b/dns-not-getting-updated-using-the-dhcp-clients?forum=winserveripamdhcpdns

    There is a solution for you:

    Apply the following group policy setting to all of your computers (or just the laptops):

    1. Edit an appropriate group policy object
    2. Expand Computer Configuration, Policies, Administrative Templates, Network, DNS Client
    3. Find the “Registration refresh interval” setting and double click it
    4. Configure the refresh interval for 1800 seconds (30 minutes)
    5. Apply your settings and wait for the group policy changes to propagate

    Please note the warning in the description.

    Best Regards,

    Frank


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, November 22, 2017 6:55 AM
  • Hi Frank,

    Thank you for taking time to answer to my question. I'll test your solution.

    Thank you again,

    Josué
    Wednesday, November 22, 2017 7:09 AM
  • Hi,
    Just checking in to see if the information provided was helpful. Please let us know if you would like further assistance.

    Best Regards,

    Frank


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, November 24, 2017 10:14 AM
  • Hi,

    Was your issue resolved? 

    If you resolved it using our solution, please "mark it as answer" to help other community members find the helpful reply quickly.
    If you resolve it using your own solution, please share your experience and solution here. It will be very beneficial for other community members who have similar questions.
    If no, please reply and tell us the current situation in order to provide further help.

    Best Regards,
    Frank

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, November 27, 2017 10:12 AM
  • Hi Frank,

    This setting doesn't seems to solve the problem. But, I found other DNS settings that I changed to default and I'm monitoring the effects. Those settings are related to SOA.

    I can now see 2 DNS records for the same machine: one with LAN IP and the other with the Wifi IP which is good.

    Tuesday, December 5, 2017 3:00 PM