none
How to Append DNS suffix using Group Policy preference method.

    Question

  • Hello All,

    I do want to push out DNS suffix to user machines so that they still be able to add more manually.

    I tried normal GPO but these settings are grade out after that.

    I also try script on one machine but no help:

    reg add HKLM\system\currentcontrolset\services\tcpip\parameters /v “SearchList” /d “domain1.com,domain2.com” /f

    Anyone any other thought.

    Monday, February 08, 2016 12:53 PM

Answers

  • Hello,

    Please make sure the registry key has been added with the proper DNS suffix value. And then check the network connection properties.

    I have test on my computer, after manually add the key with proper value, I can see the DNS suffix and I can add new one also.

    Regards,

    Yan Li


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by Beadmin Tuesday, February 23, 2016 11:28 AM
    Tuesday, February 23, 2016 8:02 AM
    Moderator

All replies

  • Hello,

    You can use Group Policy Preference to add this registry item:

    Please check steps below:
    Open GPP--Registry--New--Registry Item--input registry information.
    Action: Update
    Hive: HKEY_LOCAL_MACHINE
    Key Path: System\currentcontrolset\services\tcpip\parameters
    Value name: SearchList
    Value type: REG_DWORD
    Value data: domain1.com,domain2.com

    Regards,

    Yan Li


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, February 09, 2016 3:05 AM
    Moderator
  • Thanks for you reply Yan,

    I tried to create this today but cannot add anything after dot in value data, so nothing after domain1.

    Am I missing something?

    Thursday, February 11, 2016 8:04 AM
  • Am I missing something?

    Well, it's a REG_SZ (string) value, not a dword. 

    Rolf Lidvall, Swedish Radio (Ltd)

    Thursday, February 11, 2016 8:29 AM
  • Unfortunately, this method did not work.

    After Registry was pushed to the client machine, DNS suffix was grade out again.

    Friday, February 12, 2016 8:00 AM
  • Hello,

    After registry was pushed, can you modify the registry key to add DNS suffix?

    Regards,

    Yan LI


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, February 17, 2016 1:53 AM
    Moderator
  • Hello Yan,

    Value in registry was blank. I have manually added, (removed network cable) and reboot.

    This bring no difference.

    Thursday, February 18, 2016 6:38 AM
  • This should definitely work via a computer startup script or other in computer context. You may not be seeing the immedaite change because you need to either reboot or type "IPCONFIG /REGISTERDNS" with elevated credentials to immediately apply the change.

    One BIG difference: That is REG_SZ, not REG_DWORD


    Ha®®y



    Thursday, February 18, 2016 3:34 PM
  • Hello,

    Please make sure the registry key has been added with the proper DNS suffix value. And then check the network connection properties.

    I have test on my computer, after manually add the key with proper value, I can see the DNS suffix and I can add new one also.

    Regards,

    Yan Li


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by Beadmin Tuesday, February 23, 2016 11:28 AM
    Tuesday, February 23, 2016 8:02 AM
    Moderator