none
DPM 2012 SP1 - MSDPM failure Event ID 999 RRS feed

  • Question

  • Hi all,

    I'm running DPM 2012 SP1 on Windows Server 2012, I've just started to get the DPM service crash with the following event:


    -----------------------------------------

    The description for Event ID 999 from source MSDPM cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

    If the event originated on another computer, the display information had to be saved with the event.

    The following information was included with the event: 

    An unexpected error caused a failure for process 'msdpm'.  Restart the DPM process 'msdpm'.

    Problem Details:
    <FatalServiceError><__System><ID>19</ID><Seq>2521</Seq><TimeCreated>22/11/2013 11:07:36</TimeCreated><Source>DpmThreadPool.cs</Source><Line>163</Line><HasError>True</HasError></__System><ExceptionType>FormatException</ExceptionType><ExceptionMessage>Input string was not in a correct format.</ExceptionMessage><ExceptionDetails>System.FormatException: Input string was not in a correct format.
       at System.Text.StringBuilder.AppendFormat(IFormatProvider provider, String format, Object[] args)
       at System.String.Format(IFormatProvider provider, String format, Object[] args)
       at Microsoft.Internal.EnterpriseStorage.Dls.Trace.TraceProvider.Trace(TraceFlag flag, String fileName, Int32 fileLine, Guid* taskId, Boolean taskIdSpecified, String formatString, Object[] args)
       at Microsoft.Internal.EnterpriseStorage.Dls.Trace.TraceProvider._TraceMessage(TraceFlag flag, String fileName, Int32 fileLine, String formatString, Object[] args)
       at Microsoft.Internal.EnterpriseStorage.Dls.WriterHelper.SystemStateWriterHelper.RenameBMRReplicaFolderIfNeeded(String roFileSpec)
       at Microsoft.Internal.EnterpriseStorage.Dls.WriterHelper.SystemStateWriterHelper.ValidateROListOnPreBackupSuccess(Message msg, RADataSourceStatusType raDatasourceStatus, Guid volumeBitmapId, List`1&amp; missingVolumesList, ReplicaDataset&amp; lastFullReplicaDataset, ROListType&amp; roList)
       at Microsoft.Internal.EnterpriseStorage.Dls.Prm.ReplicaPreBackupBlock.ValidateROList(Message msg, RADataSourceStatusType raDatasourceStatus, Guid datasetId)
       at Microsoft.Internal.EnterpriseStorage.Dls.Prm.ReplicaPreBackupBlock.RAPreBackupSuccess(Message msg)
       at Microsoft.Internal.EnterpriseStorage.Dls.TaskExecutor.Fsm.Transition.Execute(Message msg)
       at Microsoft.Internal.EnterpriseStorage.Dls.TaskExecutor.Fsm.Engine.ChangeState(Message msg)
       at Microsoft.Internal.EnterpriseStorage.Dls.TaskExecutor.TaskInstance.Process(Object dummy)
       at Microsoft.Internal.EnterpriseStorage.Dls.TaskExecutor.FsmThreadFunction.Function(Object taskThreadContextObj)
       at System.Threading.ExecutionContext.runTryCode(Object userData)
       at System.Runtime.CompilerServices.RuntimeHelpers.ExecuteCodeWithGuaranteedCleanup(TryCode code, CleanupCode backoutCode, Object userData)
       at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
       at System.Threading._ThreadPoolWaitCallback.PerformWaitCallbackInternal(_ThreadPoolWaitCallback tpWaitCallBack)
       at System.Threading._ThreadPoolWaitCallback.PerformWaitCallback(Object state)</ExceptionDetails></FatalServiceError>


    the message resource is present but the message is not found in the string/message table

    ----------------------------------------------------------------

    Friday, November 22, 2013 11:17 AM

Answers

  • I updated DPM to Update Rollup 3 for System Center 2012 Service Pack 1 v2 (Build 4.1.3417.0) and this seems to have resolved the problem.
    • Marked as answer by DanMc-2011 Monday, November 25, 2013 1:44 PM
    Monday, November 25, 2013 1:44 PM

All replies

  • I'm running DPM Build Version 4.1.3313.0
    Friday, November 22, 2013 12:59 PM
  • I updated DPM to Update Rollup 3 for System Center 2012 Service Pack 1 v2 (Build 4.1.3417.0) and this seems to have resolved the problem.
    • Marked as answer by DanMc-2011 Monday, November 25, 2013 1:44 PM
    Monday, November 25, 2013 1:44 PM