locked
create web app existing app pool missing RRS feed

  • Question

  • Hi,

    i created web application abc with application pool abc. now when i am creating new web application and selected existing application pool then abc pool is not being listed under existing list where this pool is available in IIS.

    kindly tell what is the issue and how to fix it.

    thanks.


    iffi
    Wednesday, September 14, 2011 11:31 AM

Answers

  • hello,

    i have restart server but same issue. if i start service on application server too then it shows custom application pool.

     

    thanks

     


    iffi
    • Marked as answer by Pengyu Zhao Friday, September 23, 2011 2:01 AM
    Friday, September 16, 2011 4:19 AM

All replies

  • There is seperate node for Application Pool above Site node in IIS. You should have farm admin to access IIS.
    w: http://www.worldofsharepoint.com | t: @sharesandip
    Wednesday, September 14, 2011 11:59 AM
  • My problem is that when you go through creating a new webapplication and choose the option labled "Use existing application pool" under the section labled "Application Pool - Choose the application pool to use for the new web application" I can only select from a list ofpools like Default,ASP.net 4.0 ASP.NET classic and some other. 

    The drop down list does not mention any of the other app pools I have created for previous web applications.

    My question is this, how do I pick an existing web application pool that I have created previously, rather than keep on creating new application pools for every new web application I create?

    My application pool are listed in IIS.

    My farm has 1 Application Server and 1 WFE Server which running / host web applications.

     

    thanks.

     

     


    iffi
    Wednesday, September 14, 2011 12:51 PM
  • Sharepoint 2010

    My problem is that when you go through creating a new webapplication and choose the option labled "Use existing application pool" under the section labled "Application Pool - Choose the application pool to use for the new web application" I can only select from a list of pools like Default,ASP.net 4.0 ASP.NET classic and some other. 

    The drop down list does not mention any of the other app pools I have created for previous web applications.

    My question is this, how do I pick an existing web application pool that I have created previously, rather than keep on creating new application pools for every new web application I create?

    My application pool are listed in IIS.

    My farm has 1 Application Server and 1 WFE Server which running / host web applications.

     

    thanks.

     

     


    iffi
    • Edited by imughal Wednesday, September 14, 2011 12:52 PM
    Wednesday, September 14, 2011 12:51 PM
  • Hello ,

     Try to stop and restart the "Windows SharePoint Services Web Application" service on all the WFE and App servers and once started on all check once again creating new web application ...i guess this time application pool would show up in the drop down.

    Thanks,

    Raj 

    Wednesday, September 14, 2011 1:22 PM
  • with reference to this post

    http://sharepoint-geek.com/category/windows-sharepoint-services-web-application/

    saying never ever stop this service. pls suggest

    i have sharepoint 2010 environment and 1 application server and 1 WFE server ans MS SharePoint Foundation web application is running only at WFE Server.

    what to do.

     


    iffi
    Thursday, September 15, 2011 4:22 AM
  • Hello Imughal,

    I agree with the post that the service shall not be stopped....but incase if all the IIS in the farm are not in a sync you can opt for this and check. Please try it if you can afford a downtime and it would not take much downtime just around 2-3 mins.

    Thanks,

    Raj 

    Thursday, September 15, 2011 1:24 PM
  • hello,

    i have restart server but same issue. if i start service on application server too then it shows custom application pool.

     

    thanks

     


    iffi
    • Marked as answer by Pengyu Zhao Friday, September 23, 2011 2:01 AM
    Friday, September 16, 2011 4:19 AM