locked
Settings for UserID will not working when starts Litetouch.wsf manually RRS feed

  • Question

  • Hi,

    i have created a new Tasksequence to Test new Scripts/Silent Installation for Software. The Tasksequence is member of Selection Profile (All Task Sequences) The Priority in my customsettings.ini:

    [Settings]
    Priority=ByIsOnBattery, UserID, ByVMType, HardwareInfo, DefaultGateway, SendMail, Default

    For my User i have a User Section that set this Selction Profil for me.

    [Admin-MHZ]
    WizardSelectionProfile=Task Sequence - All Task Sequences

    An other Selection Profil has all Tasksequences for virtual machines.

    [ByVMType]
    Subsection=VM-%IsVM%
    
    [VM-True]
    WizardSelectionProfile=Task Sequence - Virtual Machines

    When i starting fresh installation on physical or virtuell PC, the correct Selection Profil is working.

    Now i will test the new Installation without compled Deployment. On my virtuell Testmachine (W7) i mapped the Deployment Share to Drive Z: and start Z:\scripts\LiteTouch.wsf. Any time i can see only the Virtual Machines Task Sequences. When i look into the BDD.log, i can see that the UserID Section will reading, but the WizardSelectionProfile Variable will not set.

    Any Ideas?




    Thursday, October 16, 2014 1:51 PM

Answers

  • When i look into the BDD.log, i can see that the UserID Section will reading, but the WizardSelectionProfile Variable will not set.

    I'm going to disagree with you here, by default MDT does not set the UserID variable when launched from an existing OS. Instead, I would set the value manually:

    cscript \\server\deploymentshare$\scripts\LiteTouch.wsf /UserID:%USerName%

    Will allow the cs.ini to parse a UserID Section:

    [Settings]
    Priority=Default, UserID
    
    [Default]
    ...
    
    [KeithGa]
    SkipBuild = YES
    


    Keith Garner - Principal Consultant [owner] - http://DeploymentLive.com

    Friday, October 17, 2014 11:54 PM