none
MDT Windows update Defer Feature update settings no longer working RRS feed

  • Question

  • Creating new 1703 and 1709 Base images with MDT 8450. I update them with the latest updates for that version and capture them all with MDT. 

    From there I create a task sequence to deploy each base image and lay applications and settings on top. Everything has been working fine.

    With these new base images though the settings for defer feature updates are not being followed. 

    I can see the keys are applied and are in the registry. But windows is ignoring them.

    I'm also noticing that what ever windows update setting I set when creating the Base image (in the gui) holds over and does not clear with sysprep.

    These are the keys that we are setting:

    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate]
    "DeferFeatureUpdates"=dword:00000001
    "BranchReadinessLevel"=dword:00000020
    "DeferFeatureUpdatesPeriodInDays"=dword:000000b4


    If i use an older base image from October the settings in the registry are followed. Not sure if there is some update that is being applied to the base image that is screwing with these settings.

     


    • Edited by PeteBC Monday, February 5, 2018 8:52 PM
    Monday, February 5, 2018 8:50 PM

Answers

  • Ok I'm about to answer my own question. So after the base image is deployed to the computer and all apps and settings apply and then reboot, the windows update GUI still shows the original base image settings. But when I click check for windows update it magically changes the gui screen to: "Some settings are hidden or managed by your organization" and all the correct settings are set in advance options. FUN!

    • Marked as answer by PeteBC Monday, February 5, 2018 9:21 PM
    • Edited by PeteBC Monday, February 5, 2018 9:21 PM
    Monday, February 5, 2018 9:21 PM