none
Permissions for Enterprise Wiki subsite

    Question

  • Hi,

    I have created an enterprise wiki subsite, and it doesn't inherit the site permissions.

    I can see all the parent permissions, and they are set correctly. I check the user and it says they have full control of the site, but when they go to edit the page, it says they don't have permissions. 

    They are a member of two groups for the site, one that's a visitor and another that has full control (IT Services Owners). Both groups are inherited but only the visitor group is working. If I remove them from the visitor group they have no access to the site.

    Do wiki sites operate differently to other sites?
    I am a bit confused how it`s using one group and not the other.


    Monday, February 20, 2017 8:16 PM

Answers

  • I found the issue, I had to give the user edit rights to the master pages.

    Site Settings -> Master pages and page layouts -> Library Tab -> shared with

    • Marked as answer by OptimAdam Tuesday, February 21, 2017 12:22 AM
    Tuesday, February 21, 2017 12:22 AM

All replies

  • I found the issue, I had to give the user edit rights to the master pages.

    Site Settings -> Master pages and page layouts -> Library Tab -> shared with

    • Marked as answer by OptimAdam Tuesday, February 21, 2017 12:22 AM
    Tuesday, February 21, 2017 12:22 AM
  • Hi,

    Thanks for your sharing the solution here. It will help other users who meet the same issue in this forum, thanks for your support.

    Best Regards,

    Victoria


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com


    Tuesday, February 21, 2017 1:38 AM
    Moderator