none
Unable to add certain Microsoft account to a Windows 10 joined domain PC RRS feed

  • Question

  • Hello,

    After a domain migration of my PC, I am unable to add certain Microsoft accounts (Setting  > Email & app accounts > Add a Microsoft account) to my PC. In particular I have two accounts on "outlook.com", one which was not used on that machine before, and which I can add/remove at will after migration, and another, which was used on that machine, but was removed during the migration, and which I'm unable to add back: after clicking on "Add a Microsoft account" and entering the correct credentials I see "Just a moment". If, instead I select the "create one" option, no problem at all!

    As suggested in certain posts, I've deleted relevant stuff in Computer\HKEY_USERS\.DEFAULT\Software\Microsoft\IdentityCRL\StoredIdentities but no luck.

    I've tried the Microsoft Account Troubleshooter. No luck either.

    So I would appreciate any idea that could help me investigate this issue.

    Many thanks

    Wednesday, August 7, 2019 8:56 AM

All replies

  • Hi,

     

    Set up Cortana may helpful. Select the search bar in the taskbar, and follow the steps to opt-in to using Cortana.

     

    In addition, here are some posts with the similar issue with yours, just for your reference, you can try the method mentioned in them:

    https://superuser.com/questions/930681/how-to-link-windows-10-domain-user-account-to-microsoft-account

    Note: This is a third-party link and we do not have any guarantees on this website. And Microsoft does not make any guarantees about the content.

     

    Hope above information can help you.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, August 8, 2019 3:05 AM
  • Thanks. Unfortunately this does not work.
    Friday, August 9, 2019 8:58 AM
  • Hi,

     

    This issue can also be caused by GP blocking the settings for connecting the Microsoft account:

     

    Please open this group policy:

     

    Computer Configuration\Windows Settings\Security Settings\Local Policies\Security Options\Accounts: Block Microsoft Accounts

     

    Make sure that setting set to "This policy is disabled."

     

    Hope these can help you.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, August 12, 2019 6:26 AM
  • Hello,

    Thank you for the suggestion. I had tried that too, but this did not help.

    Wednesday, August 14, 2019 7:44 PM
  • Hi,

     

    I am sorry that this issue still hasn't been resolved.

     

    I think linking a Microsoft Account to a user profile has always only worked with a local user account, not an Active Directory domain user account.

     

    Microsoft removed the ablity for domain joined user to sync with their Microsoft Account.

     

    Retreat domain firstly, add certain Microsoft account then add the domain to see if it works.

     

    For more information, please refer to the following article:

    https://docs.microsoft.com/en-us/windows/security/identity-protection/access-control/microsoft-accounts#managing-the-microsoft-account-in-the-domain

     

    Best Regards,

    Farena


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, August 15, 2019 3:34 AM