none
Windows 8 Customised OS deployment pauses after first reboot RRS feed

  • Question

  • I'm trying to capture a customised Windows 8 install to use as our SOE, the capture itself completes without errors but when I try to deploy the image with a Standard Client TS the deployment process pauses after a reboot and AutoLogon.

    If I manually run C:\LTIBootStrap.vbs then the deployment process resumes and completes but with a failed Domain Join, if I manually join the domain before running LTIBootStrap.vbs then the deployment process is successful although start menu settings aren't copied. (I've also noticed that the computer name remains the same as the base image even though I've specified a computer name in the wizard)

    At first I thought my Task Sequence might be wrong but if I change the OS from the custom capture to standard Win 8 Pro then the deployment works perfectly.

    I've done alot of searching to see if people are having similar issues and that's pointed to a possible problem with the Sysprep process when I run the capture?

    The steps I've taken are as follow.

    1. Install Windows 8 Pro into a VM using the Microsoft VL ISO

    2. Customise Windows 8 by installing base applications, applying Windows Updates, Wallpaper, Screen Saver etc

    3. Launch the capture process from an elevated command prompt 'cscript \\mdt\MDTDevelopment\Scripts\LiteTouch.wsf

    4. Import the successfully captured image into MDT2012 (specifying the setup files as the clean Windows 8 OS)

    5. Create a TS and edit it's Unattend.xml to change CopyProfile to true.

    6. Deploy via WinPE specifying a computer name for the new machine.

    This is what I've been doing with MDT2010 and Windows 7 deployments for a number of years and it's worked fantastically, has something changed in MDT2012? I've tried to find guides but haven't been able to find any that describe how to deploy a custom Win 8 image, the MDT2012 documentation also didn't help me.

    Appreciate any guidance you can give.

    Thanks

    Wednesday, June 5, 2013 6:51 AM

Answers

All replies

  • Yes, the first clue about a sysprep capture problem is that the machine has the same name as your captured image.  It means it was likely not generalized properly when you captured it.  How did you perform the capture?  I'd go back and look at the sysprep logs on the machine immediately post capture attempt.  You could also try the sysprep manually and then check the logs out before running the boot to WinPE and capture steps.

    Also, CopyProfile shouldn't be used.  Period.  Ever.  (http://social.technet.microsoft.com/Forums/en-US/configmanagerosd/thread/e1a4959d-a3ec-40a7-8265-f571ee040faa for just a single example thread of where others (Jason is an MVP) say the same thing).


    David Coulter | http://DCtheGeek.blogspot.com | @DCtheGeek

    • Marked as answer by andoss Thursday, June 6, 2013 2:23 AM
    Wednesday, June 5, 2013 2:30 PM
    Answerer
  • Thanks for the reply, I've been using CopyProfile successfully for Windows 7 deployments and it's worked perfectly.

    Did something change with Windows 8 or would you recommend I look at changing the way I'm deploying Windows 7 also?

    The way I perform the capture is after customising the VM I open an elevated command prompt and run LiteTouch (full command is 'cscript \\mdt\MDTDevelopment\Scripts\LiteTouch.wsf') then I just give a name to the image file and the sysprep & capture tasks runs and completes.

    I'll remove copyprofile and see if the image deployment then completes successfully if so I'll work off the suggestions in the link you provided.

    Cheers.

    Wednesday, June 5, 2013 11:47 PM
  • David I just saw your response in this thread - http://social.technet.microsoft.com/Forums/en-US/mdt/thread/00bdcb68-9c66-435f-8765-d6f7fb8d02b8

    But thought it would more polite to ask the question here than interrupt Amit's questions.

    If I were to do the automated install & capture process that you've suggested when does the sysprep task run?

    Or would I need to add a sysprep task to my TS after all my app installs & customisations.

    Thanks.

    *EDIT - Never mind I watched the Standard Client TS and I can see it running Sysprep so all looks good, just need to see how the captured image will redeploy.

    Cheers.



    • Edited by andoss Thursday, June 6, 2013 12:32 AM
    Thursday, June 6, 2013 12:07 AM
  • Regarding CopyProfile... for many people it works fine.  I just prefer to stay clear of it and find other ways to do it.  As Jason and others have said, it's specifics are very undocumented.

    As to the other method, looks like you got it figured out!  Doing it end-to-end with a Task Sequence makes it more repeatable, it becomes automated, and reduces manual effort or guess work.  You can automate it even further with Powershell and Hyper-V (example from my blog here: http://dcthegeek.blogspot.com/2013/01/automating-image-building-with-mdt.html and a cool monitoring example from Aaron Parker here: http://stealthpuppy.com/deployment/monitoring-mdt-task-sequences-with-powershell/).  The sky is the limit. : )


    David Coulter | http://DCtheGeek.blogspot.com | @DCtheGeek

    Thursday, June 6, 2013 1:10 AM
    Answerer
  • I've managed to create a new image using the steps you suggested for an 'automated capture'.

    I've just finished redeploying it and the process completed successfully with domain join.

    I obviously have alot of tedious customisations to do but if this methods the best solution then so be it.

    Thanks for your help.

    Thursday, June 6, 2013 2:26 AM
  • They are really only tedious the first time... after you realize it's now all automated and that anyone can jump in and see how your image was built (the Task Sequence becomes a guide or document, basically), then you realize the real power and the fact that you don't have to remember to manually do each of those steps next time you build an image (or when you move to the next version of the OS). : )

    David Coulter | http://DCtheGeek.blogspot.com | @DCtheGeek

    Thursday, June 6, 2013 2:38 AM
    Answerer