locked
Auditpol and Gpedit.msc policy values are mismatching RRS feed

  • Question

  • I tested the below scenario on my machine,

    1. Opened gpedit.msc

    2. Navigated to "Computer Configuration\Policies\Windows Settings\Security Settings\Advanced Audit Policy Configuration\Audit Policies\Account Logon\Audit Credential Validation"

    3. It showed "Not Configured"

    4. Executed "auditpol /set /subcategory:"credential validation", /failure:disable /success:enable"

    5. auditpol /get /subcategory:"credential validation" and got the output below.

    C:\Users\Administrator>auditpol /get /subcategory:"credential validation"
    System audit policy
    Category/Subcategory                      Setting
    Account Logon
      Credential Validation                   Success and Failure


    6. But still the gpedit.msc shows not configured.
    7. Then when I execute gpupdate or restart my machine.
    8. I execute "auditpol /get /subcategory:"credential validation" and then got the below output.
    C:\Users\Administrator>auditpol /get /subcategory:"credential validation"
    System audit policy
    Category/Subcategory                      Setting
    Account Logon
      Credential Validation                   No Auditing

    When we restart or execute gpupdate, Whatever displayed on the gpedit.msc is set to the Audit credential validation policy.

    Is there any solution to update the gpedit.msc using command. Or is there any work around for this.
    Thursday, June 25, 2020 6:49 AM