locked
Cannot add some users in my Colleague in My Site RRS feed

  • Question

  • We have MOSS 2007 with Cumulative update June 2010. I can add most users in My Colleague list. But I cannot add some other users to My Colleague. The error is "<User name> cannot be found in the User Profile Store. Please contact an administrator." 

    I could not find anything wrong by checking user profiles in AD, and checked user profile in MOSS. User profiles are all imported, and all required fields are entered. I can grant the problem users on the Sites and Document Library, but cannot add them to My Colleague.

     

    Any help will be appreciate,

    Steven 

     


    • Edited by Steven Z. _ Monday, October 24, 2011 5:46 PM
    Monday, October 24, 2011 5:16 PM

All replies

  • Hi Steven,

    Are there some special properties for these users? For example: the duplicate users are existed in the User Profile? Or the users have been disabled in AD? Maybe you can try these solutions:

    1.      You can import all the users again within the admin site (Refer to this: http://social.technet.microsoft.com/Forums/en/sharepointadmin/thread/943967b2-9475-4469-bcca-51aa4bdd8f1f ), and check whether it works.

    2.      Try to delete one of the users, and then import from AD, check whether it works.

    3.      Check the ULS log on the server for more details.

    I look forward to your reply.

    Tuesday, October 25, 2011 7:42 AM
  • Hi,

    There are few ways to add a person as my colleague.

    The issue you have mentioned has been faced by us earlier.

    We then trying adding the person by directly clicking on the colleagues link under our mysite home page instead of going to the profile page of the user and then clicking on add colleagues. In one case when we changed the group it worked.

    Hence I suggest you to carry out these.


    Thanks, Rahul Rashu
    Tuesday, October 25, 2011 11:35 AM
  • Rahul,

    That is exactly we did. Click Colleagues link in My site, and then add new user. error cames.

    Thanks,

    Steven 

    Tuesday, October 25, 2011 2:51 PM
  • Hi Wayne,

    I cloned a new user account off the problem user in AD and change user name. It is look likke that we cannot add any user from GMDC user group. I did a full import multiple times for different changes on user group membership. I got the same error. User is not disabled, not locked, and not expired in AD. I even removed all other groups and left only "Domian users" group for the user.

    I can assign user at site permission or Document library permissions which might indicating no problem on user profile.

    We have three MOSS servers in the Farm. I wen to the server which I connected to, checked the minute log in folder 12. But could not find any  information to help me identify the problem. Which log should I check?

    Thank you very for try to help me,

    Steven

     


    • Edited by Steven Z. _ Tuesday, October 25, 2011 5:49 PM
    Tuesday, October 25, 2011 4:06 PM
  • Hi,

    Try adding the user in a new group.

    This has worked for us in our issue.


    Thanks, Rahul Rashu
    Wednesday, October 26, 2011 12:45 PM