locked
"Switch User" option missing from start menu in SteadyState RRS feed

  • Question

  • Now that I've installed SteadyState in Vista SP2, the "Switch User" option is missing from the start menu. My kids and I used to change by switching, but now each of us have to log off before someone else can access their account. Is there a way to restore this, or is this a requirement of SteadyState to not allow more than one user to be logged in at the same time? Also, if I lock the computer, they cannot change to their account from that screen anymore either.

    I only disabled hard drive changes for one child, but not the other two. I did limit them all from seeing most of the other hard drives (OK to see C, photo and media drives).

    Windows Live Family Safety is also installed, but I don't think that created the conflict.
    • Edited by ckumark Friday, June 26, 2009 7:01 PM Fixing thread title bug
    Thursday, June 18, 2009 1:09 PM

Answers

  • You can use SCTSettings.adm under Windows SteadyState\ADM folder to set group policy. However, we cannot migrate previous settings in SteadyState onto a new computer. You can do this manually.

     

    Hope this helps!


    Sean Zhu - MSFT
    • Marked as answer by Sean Zhu - Friday, June 26, 2009 7:17 AM
    Wednesday, June 24, 2009 2:30 AM

All replies

  • Hi, thanks for the post. I'd like to inform you that after installing Windows SteadyState, fast user switch is disabled. This is a by design behavior. Also, the "switch user" button is disabled on welcome screen.


    Sean Zhu - MSFT
    Friday, June 19, 2009 6:07 AM
  • Bummer. It's a key feature my kids and I use regularly, which will necessitate uninstalling steadystate now after less than a week. I had heard such good things and was excited to try it.

    Is there a comparison chart somewhere which would allow me to replicate similar steadystate features with group policy edit?
    Tuesday, June 23, 2009 8:16 PM
  • You can use SCTSettings.adm under Windows SteadyState\ADM folder to set group policy. However, we cannot migrate previous settings in SteadyState onto a new computer. You can do this manually.

     

    Hope this helps!


    Sean Zhu - MSFT
    • Marked as answer by Sean Zhu - Friday, June 26, 2009 7:17 AM
    Wednesday, June 24, 2009 2:30 AM
  • Sean,

    Can you give me a little more information on this procedure? I've gone into the file that you suggest, but I'm not sure what I'm supposed to do with the file.  I opened it with a text editor, but wasn't sure if that is what you're suggesting be done.  Further, exactly what values need to be set in order to effect the change you're talking about.  Can this also be done through registry edits?

    Thanks,

    jayef
    Wednesday, September 23, 2009 8:10 PM
  • I have Vista Business 32bit. This is how I got Fast User Switching Back.

    (WARNING: Any changes you make in GPEdit.msc/Local Group Policy Editor will effect ALL users, including the Administrator.)

    Open Run Command, type in the Open box: gpedit.msc

    Click "OK"

    The Local Group Policy Editor will open.

    Double-Click on "Administrative Templates" under "Computer Configuration"

    Double-Click on "System"

    Double-Click on "Logon"

    Now, on the right, in the details pane you will see some listed options. Double-Click on "Hide entry points for Fast User Switching"

    Click on "Disable"

    Click "OK"

    Now check to see if you have "Switch User" back where it should be on your Shutdown options menu in the Start Menu.

    If it's there, close the Local Group Policy Editor and never open it again unless you know what you're doing. :)

    If it's not, still close the Local Group Policy Editor. I'm afraid this solution will not work for you. I'm sorry. Keep Searching! :)
    • Edited by PammyLZ Friday, October 30, 2009 8:18 PM Super Extra Clarification
    • Proposed as answer by PammyLZ Friday, October 30, 2009 10:23 PM
    Friday, October 30, 2009 8:10 PM
  • I had the same issue on a Windows XP Home computer.  I just went into control panel, selected user accounts, then selected the option for 'change the way a user logs on' and then selected 'Use Fast User Switching'.  Worked like a champ.
    james . Curtis
    Saturday, November 14, 2009 6:24 PM