Issue with Sharepoint 2010 and opening Office documents


  • I've spent hours searching everywhere I can find, but I have yet to find an answer that has solved this issue, so any help that could be provided is appreciated.

    Here's what I have:

    I have built a document library on my SharePoint 2010 server site. When I select the 'Edit in Word' option for uploaded files, I am prompted 3 times for credentials, and then it loads the document as read only. I supply my proper credentials, I supply random characters, I hit cancel and it all yields the same result: Document opens as read-only.

    I have reason to suspect it has something to do with authentication, that it's not accepting my credentials. The 'Open With Explorer' option also comes up the same way. Three requests for credentials, than an error that it cannot be opened with this client.

    I've tried IE10, Chrome, and Firefox, and they all exhibit the same behavior. I have managed to get it to work on various computers, but after a restart, it always reverts back to the read-only issue. Office 2010 and 2013 both have this problem. Client OS is Windows 7. Sharepoint server is 2k8r2 with webdav uninstalled.

    Any input would be appreciated.

    Tuesday, September 10, 2013 10:25 PM

All replies

  • Is your SharePoint url a FQDN? Theres a known complexity with Office Documents and windows 7 and FQDNs, you can see if you are experiencing it by adding an AAM that is servername:port and try browsing that and seeing if your behavior is any different. 

    See Aseems asnwer here

    What about the client OSs webdav, is that working?

    Also check if the url you are browsing is in your local intranet zone or trusted sites zone.

    Also, is your URL kerberos or NTLM enabled?

    Please mark my response as an answer if appropriate.

    Tuesday, September 10, 2013 10:35 PM
  • Thanks for the quick reply!

    Yes, we are using FQDN. I am browsing through an AAM, and it seems to have accepted the credentials once, then opened as it should. I'll continue to explore this on other machines to verify and ensure this would fix the issue.

    The local box's WebDAV works fine otherwise, just this case causing an issue.

    We have a GPO pushing the site as trusted for both local, external, and trusted zones.

    Site has NTLM enabled, and we use it to provide SSO connection to the site.


    I'll report back after I've verified the AAM address corrects this issue.

    Tuesday, September 10, 2013 10:48 PM
  • So I have this working internally by supplying the port number in the address, however, I cannot get this to work externally (and I really need it to work externally).

    Recommendations or suggestions?

    Wednesday, September 11, 2013 4:24 PM
  • So you've confirmed this only happens with FQDN and not with server:port, so its the classic windows 7 problem that can be resolved by following the instructions from AseemN in the link

    Did you try this and it didn't work? Normally this is added to GPO so the change spreads to everyone

    Please mark my response as an answer if appropriate.

    Wednesday, September 11, 2013 6:48 PM
  • I had attempted that before I tried using the server:port, however it has not had an effect. I went through and made sure, but I still get the files in read-only.

    I can feed the server:port locally, but is there a way to do that externally? Extending the site with the port and using AAM has not worked so far.

    Thanks again for your help.

    Wednesday, September 11, 2013 6:57 PM