locked
DNS not working RRS feed

  • Question

  • Hi,

    I'm having DNS problems with my trial install of Server 2012 R2 Essentials Preview. My apologies if a) I'm doing something really stupid or b) this is already documented - I have spent some time looking around and can't find the answer online.

    Basically, the server does not seem to be resolving DNS addresses (i.e. if I try to ping (e.g.) www.Microsoft.com I get a 'request could not find host...' error message. The DNS service is running and neither Server Manager nor the Dashboard are showing any errors.

    I have the DNS server set to be local loopback (127.0.0.1) - see ipconfig /all output below. If I add the Google public DNS server (8.8.8.8) then all is well. I'm pretty sure I have got something wrong, but I am stumped. Any help would be much appreciated.

    ipconfig output is as follows:

    Windows IP Configuration
    
       Host Name . . . . . . . . . . . . : Sol
       Primary Dns Suffix  . . . . . . . : XXXXXX.local
       Node Type . . . . . . . . . . . . : Hybrid
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No
       DNS Suffix Search List. . . . . . : XXXXXX.local
    
    Ethernet adapter Ethernet:
    
       Connection-specific DNS Suffix  . : 
       Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
       Physical Address. . . . . . . . . : 6C-F0-49-B2-9E-BC
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       Link-local IPv6 Address . . . . . : fe80::b590:7b0:66d1:368a%12(Preferred) 
       IPv4 Address. . . . . . . . . . . : 192.168.0.11(Preferred) 
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Default Gateway . . . . . . . . . : 192.168.0.1
       DHCPv6 IAID . . . . . . . . . . . : 309129289
       DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-19-7F-46-22-6C-F0-49-B2-9E-BC
       DNS Servers . . . . . . . . . . . : ::1
                                           127.0.0.1
       NetBIOS over Tcpip. . . . . . . . : Enabled
    
    Tunnel adapter isatap.{1EDDE6C8-A20B-4DF9-ADA1-F45894B14786}:
    
       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . : 
       Description . . . . . . . . . . . : Microsoft ISATAP Adapter
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    Thanks for your help

    Dave


    • Edited by DaveH Monday, August 5, 2013 6:17 AM
    Monday, August 5, 2013 6:16 AM

Answers

  • Hi, Dave

    Please see my reply inline.

    regards,

    Guang

    Hi Guang

    Thanks for this - that makes sense. Am I right in thinking that this (setting up the DNS Forwarder) is normally done in setup and configured automatically? (used to be done by DC Promo??). (Or is it because I wasn't connected to the Internet when I set the server up?)

    [guang] This setting should be done automatically during configuration, and you need to make sure the server connected to the Internet before setup the server.

    Is this a setup step that I have missed out or is it a bug that it wasn't created automatically (or at least prompted for). Running DNS Manager, I can see that a Forward Lookup Zone for my domain has been created but no DNS Forwarder with a valid IP v4 address.

    Do I now just go and edit the DNS Forwarder tab (or do I run the configuration wizard?)

    [guang] The missing step is that before the server setup, make sure it connects to the Internet.  For now you can just edit the DNS forwarder with correct info.

    • Marked as answer by DaveH Tuesday, August 13, 2013 7:31 AM
    Tuesday, August 13, 2013 4:03 AM
    Moderator

All replies

  • Hi,

    Thanks for posting in the forum.

    Regarding the current issue, we’d better refer to the following similar thread. It may be useful to us.

    2K8 - Best practice for setting the DNS server list on a DC/DNS server for an interface

    http://social.technet.microsoft.com/Forums/windowsserver/en-US/b7bf37a2-6e1a-40a8-8d4b-1c15ee9bc0fa/2k8-best-practice-for-setting-the-dns-server-list-on-a-dcdns-server-for-an-interface

    Hope this helps.

    Best Regards,

    Andy Qi


    Andy Qi
    TechNet Community Support

    Thursday, August 8, 2013 3:19 AM
    Moderator
  • How is your router set up?  Normally Essentials handles the DNS, the router is the DHCP/


    Don't Retire TechNet

    Thursday, August 8, 2013 4:22 PM
  • Thanks Andy,

    Interesting thread - though I'm not sure I fully understood it.

    Just replacing the loopback address with the local IP address of the server made no difference. However, adding my router as the Secondary DNS server did work. (as I don't have a second DC - I know this is not best practice, but I'm a very small business and I can't justify two boxes).

    It does beg the question though - why does set up end with the DNS setup on the server as 127.0.0.1 if that doesn't (always) work? I'm pretty sure that was fine on previous test instance of Server 2012 Essentials.

    Thanks again,

    Dave 

    Friday, August 9, 2013 8:10 AM
  • Thanks Susan

    I have switched DHCP off on the router and added the role on the server - wanted to have DHCP and DNS on the same box (I think that is a good practice recommendation).

    Dave

    Friday, August 9, 2013 8:11 AM
  • Hi, Dave

    Essentials Server is by default the DNS server in the networks, the DNS settings on NIC is expected to point to itself (127.0.0.1).  Instead DNS forwarder is leveraged to point to actual DNS resolver to the internet(which is usually the router address or the one provided by ISP).

    In typical Essentials network settings, DHCP is on the Router side. Manually switch DHCP from router to Essentials is an advanced usage for Essentials, you should manually setup the DHCP with correct DNS server info. More info about DHCP: http://technet.microsoft.com/en-us/library/hh831825.aspx. To troubleshoot your current issue, instead of changing the DNS on NIC, you should add the expected DNS address to the DNS forwarder. You can run the PowerShell cmdlet: Get-DnsServerForwarder to see whether the expected one is set.

    Switching DHCP to Essentials should not impact the internet access as long as you set it correctly. If it's the WSEE enabling breaks the internet connections, please let us know more details and we can follow up with you.

    Thanks,

    Guang

     


    Monday, August 12, 2013 8:33 AM
    Moderator
  • Hi Guang

    Thanks for this - that makes sense. Am I right in thinking that this (setting up the DNS Forwarder) is normally done in setup and configured automatically? (used to be done by DC Promo??). (Or is it because I wasn't connected to the Internet when I set the server up?)

    Is this a setup step that I have missed out or is it a bug that it wasn't created automatically (or at least prompted for). Running DNS Manager, I can see that a Forward Lookup Zone for my domain has been created but no DNS Forwarder with a valid IP v4 address.

    Do I now just go and edit the DNS Forwarder tab (or do I run the configuration wizard?)

    Thanks

    Dave

    Monday, August 12, 2013 3:25 PM
  • Hi, Dave

    Please see my reply inline.

    regards,

    Guang

    Hi Guang

    Thanks for this - that makes sense. Am I right in thinking that this (setting up the DNS Forwarder) is normally done in setup and configured automatically? (used to be done by DC Promo??). (Or is it because I wasn't connected to the Internet when I set the server up?)

    [guang] This setting should be done automatically during configuration, and you need to make sure the server connected to the Internet before setup the server.

    Is this a setup step that I have missed out or is it a bug that it wasn't created automatically (or at least prompted for). Running DNS Manager, I can see that a Forward Lookup Zone for my domain has been created but no DNS Forwarder with a valid IP v4 address.

    Do I now just go and edit the DNS Forwarder tab (or do I run the configuration wizard?)

    [guang] The missing step is that before the server setup, make sure it connects to the Internet.  For now you can just edit the DNS forwarder with correct info.

    • Marked as answer by DaveH Tuesday, August 13, 2013 7:31 AM
    Tuesday, August 13, 2013 4:03 AM
    Moderator
  • All sorted. Thank you.
    Tuesday, August 13, 2013 7:31 AM