none
IE11 Ignoring Home_Page (MDT 2013) RRS feed

  • Question

  • Hey Everyone,

    We have added IE11 to an image for one of our sections, and are encountering an issue with the Home_Page value from MDT not being processed.

    Background:

    MDT 2013

    Windows 7 x64 SP1 image, customized and then deployed with CopyProfile = True

    IE11 was installed as Windows Update on reference PC, rather than with IEAK or through TS

    We deployed our image to a PC for testing and noticed that the home page was not being set to the assigned value for the computer (done through departmental/location role in MDT DB).

    I checked the MDT log, and it indicated that the DB lookup was successful and the correct value was returned.

    Next, I checked the sysprep action log for the test client, and found that the correct home_page value was in there too.

    Then, I checked c:\program files (x86)\internet explorer\signup\Install.iss and found the correct value was in there.

    Lastly, I reviewed c:\users\username\appdata\local\microsoft\internet explorer\brndlog.txt and determined that while it was calling the branding process with the right path to Install.ins, it wasn't picking up the value.

    In the section where it logs the application of the general settings, where I confirmed it writes the home page value on another test client with IE8, I do not see it applying the home page.

    Restoring the advanced settings in IE, which retriggers the process produces the same result, the value is not read, or seems to be skipped in brndlog.txt.

    This is using the exact same process as we do for images with IE8 installed, which works without issue. Are there changes in IE11 that need to be accounted for in the imaging process? 

    Thanks,

    Garrett

    Thursday, October 30, 2014 2:45 PM

All replies

  • There are so many ways to set an IE homepage... Like you, I install IE 11 as part of my reference image.

    I set the IE hompage via unattend.xml file and/or customsettings.ini. Have you tried the two below?

    Customsettings.ini-->Home_Page=http://microsoft.com

    Unattend.xml-->

     <component name="Microsoft-Windows-IE-InternetExplorer" processorArchitecture="amd64" >
                <Home_Page>https://microsoft.com</Home_Page>

    Thursday, October 30, 2014 3:24 PM
  • Yeah, agreed, so many ways to do the same thing...

    The customsettings.ini is the same as what I am doing with the MDT DB, as its values are returned and injected into the TS. I can confirm with the bdd logs that the value is getting set properly.

    I can't set the value directly inside of the unattend, as we use one image and task sequence for the majority of places and customize it during application. In theory tho setting the value in customsettings or the DB should have the same effect, as the unattend is updated according to those values.

    I checked the unattend.xml that was left on testing client in the panther folder, and it did have the home_page section you pasted injected into it.

    Thursday, October 30, 2014 3:35 PM
  • Can you upload your unattend.xml file? And maybe your smsts and bdd logs?
    Thursday, October 30, 2014 3:45 PM
  • As an update to this, here's what I've found/done.

    While I can see that the values are being written into the unattend.xml, I wanted to test if the issue was injection or something else. I edited the unattend.xml for the sequence in WISM and added/recreated some of our customizations, none of which were applied. So the issue appears to be that IE11 is ignoring unattend.xml.

    I did some digging and determined that the values are written out to HKLM\SOFTWARE\Microsoft\Internet Explorer\UnattendBackup\ when sysprep is processed. I checked and all the values I configured were there.

    I'm guessing that this question is now better suited to the IE forums, as it has nothing to do with MDT, as the unattend file is getting created properly.

    Friday, October 31, 2014 2:10 PM
  • I found another way!

    Go to the[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]</b> key, right-click on the blank area to create a new String value with the name "Default_Page_URL".

    Yet another way! 

    Have you tried installing IE 11 as a post application? 

    Friday, October 31, 2014 3:28 PM
  • This sounds like an answer file issue rather than IE per say. I don't think you'll get much help there.

    I think you should use WSIM to generate a new catalog file. From then update the Internet explorer section in your answer file.

    Although I haven't tried this, I suspect that the IE section may have changed somewhat.

    Let me know if you get a chance to test this.

    /Andrew


    Blog: http://scriptimus.wordpress.com

    Sunday, November 2, 2014 11:06 PM
  • Hey Andrew,

    I did give that a try previously, there was no change. And you are right tho, there are structure changes for the section with IE11.

    I had started a new thread in the IE forums regarding this, hasn't really gone anywhere. Not sure if deployment is really the focus for that one.

    Anyway, what I have found is that the issue appears to be in using CopyProfile. When CopyProfile is "true", the settings in the unattend are ignored. When "false" they are applied. Problem is that with our image we need CopyProfile to apply other standard settings.

    With our other images, and IE8, the behavior was reversed. We could set general options and then override them if required via the unattend. With this one and IE11 it is working in reverse. I tried delving into the ActiveSetup keys to retrigger the branding process, but it doesn't seem to do anything in our instance, even though the values are there in the unattendbackup key.

    Thanks,

    Garrett

    Wednesday, November 12, 2014 6:02 PM
  • Went back to searching for other similar documented issues. Found mention of IE11 + Sysprep + CopyProfile and the search providers not transferring. This is one of the customizations that we had performed that was not transferring to the newly imaged PCs.

    This link makes mention that the update KB2988414 was the cause of that specific issue, and that it was resolved in KB3003057. I applied that to our base VM and recaptured the image, and the search provider configuration is now working. However our other customizations still aren't. It's interesting, however, that the issue was partly due to an update. I guess I'll have to dig further into that.


    • Edited by gjezekiel Thursday, November 13, 2014 12:55 PM
    Thursday, November 13, 2014 12:55 PM