none
Kerberos authentication: _ PowerShell RRS feed

  • Question

  • When i am running this command  --> New-PSSession -ComputerName ABC

    I am getting below ERROR:

    New-PSSession : [ABC] Connecting to remote server ABC failed with the following error message : WinRM cannot process the request. The following error occurred while using Kerberos authentication: Cannot find the computer ABC. Verify that the computer exists on the network and that the name provided is spelled correctly. For more information, see the about_Remote_Troubleshooting Help topic.

    I can RDP to the Computer. 

    i have already ran PS remoting command on ABC server.

    Already tried KLIST PURGE COMMAND.



    Manvendra Bele

    Thursday, February 7, 2019 2:40 PM

Answers

  • Yes.  It can cause all kinds of issues.  The domains must have a trust and your account must be an admin in the target domain or on the target server.

    \_(ツ)_/


    • Edited by jrv Friday, February 8, 2019 10:14 AM
    • Marked as answer by Powershell Learner Friday, February 8, 2019 1:55 PM
    Friday, February 8, 2019 10:14 AM

All replies

  • What do you get when running Test-WSMan? 
    Thursday, February 7, 2019 2:53 PM
  • wsmid           : http://schemas.dmtf.org/wbem/wsman/identity/
    ProtocolVersion : http://schemas.dmtf.org/wbem/wsman/
    ProductVendor   : Microsoft Corporation
    ProductVersion  : OS: 0.0.0 SP: 0.0 Stack: 3.0

    Manvendra Bele

    Thursday, February 7, 2019 3:05 PM
  • Found this thread which might be useful: https://social.technet.microsoft.com/Forums/en-US/11b1c36b-1f0f-41a3-983a-240840437214/winrm-cannot-process-the-request?forum=exchange2010

    Looks like this solved it:

    Hi,

    I understand you are sad. However, please check if the following steps can solve your issue.

    1. Close all MMC/EMC instances before proceeding.
    2. Open Registry Editor (regedit) as the user you run the EMC.
    3. Go to
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\ExchangeServer\v14\AdminTools
    4. Look for value NodeStructureSetting.
    5. If it is there, back it up and then remove it.
    6. Re-open EMC and check the result.

    Besides, "The PowerShell virtual directory 'PowerShell-Proxy (Default Web Site)' has been configured to require SSL. This can cause the Exchange Management Tools to fail to connect.", I have seen several people get the same warning in ExBPA and it seems pretty safe to ignore.

    Hope it helps.

    Best regards


    Amy  Wang
    TechNet Community Support








    Thursday, February 7, 2019 4:02 PM
  • SORRY FOR THE FORMATTING ERRORS BELOW. It won't let me amend them.





    Disable Grammarly for this site or update Grammarly to the newest fixed version.


    \_(ツ)_/

    Thursday, February 7, 2019 5:07 PM
  • My account is in XYZ domain and server ABC is in PQR domain.

    So there is domain difference. 

    Please advice if difference in domain can cause this issue ?


    Manvendra Bele

    Friday, February 8, 2019 10:11 AM
  • Yes.  It can cause all kinds of issues.  The domains must have a trust and your account must be an admin in the target domain or on the target server.

    \_(ツ)_/


    • Edited by jrv Friday, February 8, 2019 10:14 AM
    • Marked as answer by Powershell Learner Friday, February 8, 2019 1:55 PM
    Friday, February 8, 2019 10:14 AM