locked
I wanted a SteadyState but got Steady Screwed. Help Please Help! RRS feed

  • Question

  •  

     

    Issue: VISTA SP1

     

    Steadystate.


    Help! I don't mean to vent, but this isthe 1st time I have ever had to seek help.

     

     

    Basically. I istalled. configured (correctly), rebooted, and either Vista or the SteadyState decided to null my Adminand UAC User Account. I can only sign in with the account I created.

     

     

    Excerpt of the settings I exported to another drive

     

     

    Code Snippet

    <!-- Windows SteadyState                                                                               -->
    <!-- Copyright 2005 Microsoft                                                                          -->
    <!--                                                                                                   -->
    <!-- Restrict.xml                                                                                      -->
    <!--                                                                                                   -->
    <!-- This file is used to restrict specific user profiles... Do Not Delete!                            -->
    <!--                                                                                                   -->
    <restrictions>
     <allrestrictions>
      <_locDefinition>
       <_locDefault _loc="locNone"/>
       <_locDefaultAttr _loc="locNone"/>
       <_locTag _loc="locNone" _locAttrData="name">section</_locTag>
       <_locTag _loc="locNone" _locAttrData="name">subsection</_locTag>
       <_locTag _loc="locNone" _locAttrData="name">restriction</_locTag>
      </_locDefinition>
      <section id="General" name="General Settings" type="general" _locID="General">
       <restriction id="chkSharedAccount" name="Shared Account Lock" _locID="chkSharedAccount">
        <poke resid="chkSharedAccount" internal="1" on="1" off="0" delete="">0</poke>
       </restriction>
       <restriction id="txtHomePage" name="Set Home Page:" _locID="txtHomePage">
        <poke resid="txtHomePage" regkey="Software\Microsoft\Internet Explorer\Main\Start Page" type="REG_SZ" on="" off="" delete="" unicode="1">http://www.msn.com</poke>
       </restriction>
       <!--                        
                <restriction id="txtProxy" name="Specify Proxy Server:" _locID="txtProxy">
                    <poke resid="txtProxy" regkey="Software\Microsoft\Windows\CurrentVersion\Internet Settings\ProxyServer" type="REG_EXPAND_SZ" on="" off="" delete="" unicode="1"></poke>
                    <poke resid="txtProxy" regkey="Software\Microsoft\Windows\CurrentVersion\Internet Settings\ProxyEnable" type="REG_DWORD" on="1" off="0" delete=""></poke>
                </restriction>
    -->
       <restriction id="txtProxyOverride" name="Specify Proxy Exceptions:" _locID="txtProxyOverride">
        <poke resid="txtProxyOverride" regkey="Software\Microsoft\Windows\CurrentVersion\Internet Settings\ProxyOverride" type="REG_SZ" on="" off="" delete="" unicode="1"></poke>
       </restriction>
       <restriction id="txtIESearchPage" name="Specify the IE Search Page:" _locID="txtIESearchPage">
        <poke resid="txtIESearchPage" regkey="Software\Microsoft\Internet Explorer\Main\Search Bar\SearchPage" type="REG_SZ" on="" off="" delete="" unicode="1"></poke>
       </restriction>
       <!--            
                <restriction id="txtAutoRestart" name="Run and automatically restart application:" _locID="txtAutoRestart">
                    <poke resid="txtAutoRestart" regkey="" type="REG_SZ" on="" off="" delete="" unicode="1"></poke>
                </restriction>
    -->
       <restriction id="lstBlockPrograms" name="Blocked Programs List" _locID="lstBlockPrograms">
        <blockedprog>C:\Program Files\Microsoft Network Monitor 3\netmon.exe</blockedprog><blockedprog>C:\Program Files\Windows Defender\MSASCui.exe</blockedprog><blockedprog>C:\Program Files\Windows Mail\wab.exe</blockedprog><blockedprog>C:\Users\System Aministrator\Documents\DMUSProducer\Tutorial8\FarmGameApp\Farm.exe</blockedprog><blockedprog>C:\Program Files\Windows Collaboration\WinCollab.exe</blockedprog><blockedprog>C:\Program Files\Realtek\RTNICDiag\RTNICDiag.exe</blockedprog></restriction>
       <restriction id="lstAutoRunOnce" name="Run-Once Programs List" _locID="lstAutoRunOnce">
       </restriction>
       <restriction id="txtAccessDisks" name="Prevent Access to Disks" _locID="txtAccessDisks" high="???" medium="???" low="???">
        <poke resid="txtAccessDisks" regkey="Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\NoViewOnDrive" type="REG_DWORD" on="" off="0" delete="off">8388640</poke>
        <poke resid="txtAccessDisks" regkey="Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\NoDrives" type="REG_DWORD" on="" off="0" delete="off">8388640</poke>
       </restriction>
       <restriction id="txtLogoffMinsUse" name="Force Logoff after mins of use" _locID="txtLogoffMinsUse">
        <poke resid="txtLogoffMinsUse" regkey="Software\Microsoft\Shared Computer Toolkit\LogoffAfter" type="REG_SZ" on="" off="" delete="off" initialvalue="60">0</poke>
       </restriction>
       <restriction id="txtLogoffInactive" name="Force Logoff if inactive after" _locID="txtLogoffInactive">
        <poke resid="txtLogoffInactive" regkey="Software\Microsoft\Shared Computer Toolkit\IdleLogoff" type="REG_SZ" on="" off="0" delete="off" initialvalue="10">0</poke>
       </restriction>
       <restriction id="chkForceRestart" name="Restart computer when user logs Off" _locID="chkForceRestart" high="???" medium="???" low="???">
        <poke resid="chkForceRestart" regkey="Software\Microsoft\Shared Computer Toolkit\ForceRestart" type="REG_DWORD" on="1" off="" delete="off">1</poke>
       </restriction>
       <restriction id="chkPersistTimerNotify" name="Persist Timer Notify" _locID="chkPersistTimerNotify" high="on" medium="on" low="off">
        <poke resid="chkPersistTimerNotify" regkey="Software\Microsoft\Shared Computer Toolkit\PersistTimerNotify" type="REG_DWORD" on="1" off="0" delete="off">0</poke>
       </restriction>
      </section>
      <section id="StartMenu" name="Start Menu Restrictions" type="windowsrestrictionsstartmenu" _locID="StartMenu">
       <restriction id="chkNoRightClickStart" name="Prevent right-click in the Start menu" _locID="chkNoRightClickStart" high="on" medium="on" low="off">
        <poke resid="chkNoRightClickStart" regkey="Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\NoChangeStartMenu" type="REG_DWORD" on="1" off="0" delete="off">1</poke>
       </restriction>
       <restriction id="chkForceClassicMenu" name="Allow only the Classic Start menu" _locID="chkForceClassicMenu" high="on" medium="on" low="on">
        <poke resid="chkForceClassicMenu" regkey="Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\NoSimpleStartMenu" type="REG_DWORD" on="1" off="0" delete="off">1</poke>
        <poke resid="chkForceClassicMenu" regkey="Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\NoWindowsUpdate" type="REG_DWORD" on="1" off="0" delete="off">1</poke>
        <poke resid="chkForceClassicMenu" regkey="Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\ForceStartMenuLogoff" type="REG_DWORD" on="1" off="2" delete="">1</poke>
       </restriction>
       <restriction id="chkRestrictClassicMenu" name="Remove the Control Panel, Printer and Network Settings from the Classic Start menu" _locID="chkRestrictClassicMenu" high="on" medium="on" low="off">
        <poke resid="chkRestrictClassicMenu" regkey="Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\NoSetFolders" type="REG_DWORD" on="1" off="0" delete="off">1</poke>
       </restriction>
       <restriction id="chkNoMyDocuments" name="Remove the My Documents icon" _locID="chkNoMyDocuments" high="on" medium="on" low="on">
        <poke resid="chkNoMyDocuments" regkey="Software\Microsoft\Windows\CurrentVersion\Policies\NonEnum\{450D8FBA-AD25-11D0-98A8-0800361B1103}" type="REG_DWORD" on="1" off="0" delete="off">1</poke>
        <poke resid="chkNoMyDocuments" regkey="Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\NoSMMyDocs" type="REG_DWORD" on="1" off="0" delete="off">1</poke>
        <poke resid="chkNoMyDocuments" regkey="Software\Microsoft\Office\12.0\Common\Open Find\Places\StandardPlaces\MyDocuments\Show" type="REG_DWORD" on="0" off="1" delete="off">0</poke>
        <poke resid="chkNoMyDocuments" regkey="Software\Microsoft\Office\11.0\Common\Open Find\Places\StandardPlaces\MyDocuments\Show" type="REG_DWORD" on="0" off="1" delete="off">0</poke>
        <poke resid="chkNoMyDocuments" regkey="Software\Microsoft\Office\10.0\Common\Open Find\Places\StandardPlaces\MyDocuments\Show" type="REG_DWORD" on="0" off="1" delete="off">0</poke>
        <poke resid="chkNoMyDocuments" regkey="Software\Microsoft\Office\9.0\Common\Open Find\Places\StandardPlaces\MyDocuments\Show" type="REG_DWORD" on="0" off="1" delete="off">0</poke>
       </restriction>
       <restriction id="chkNoRecentDocs" name="Remove the My Recent Documents icon" _locID="chkNoRecentDocs" high="on" medium="on" low="on">
        <poke resid="chkNoRecentDocs" regkey="Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\NoRecentDocsMenu" type="REG_DWORD" on="1" off="0" delete="off">1</poke>
        <poke resid="chkNoRecentDocs" regkey="Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\NoRecentDocsHistory" type="REG_DWORD" on="1" off="0" delete="off">1</poke>
       </restriction>
       <restriction id="chkNoMyPictures" name="Remove the My Pictures icon" _locID="chkNoMyPictures" high="on" medium="on" low="on">
        <poke resid="chkNoMyPictures" regkey="Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\NoSMMyPictures" type="REG_DWORD" on="1" off="0" delete="off">1</poke>
       </restriction>
       <restriction id="chkNoMyMusic" name="Remove the My Music icon" _locID="chkNoMyMusic" high="on" medium="on" low="on">
        <poke resid="chkNoMyMusic" regkey="Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\NoStartMenuMyMusic" type="REG_DWORD" on="1" off="0" delete="off">1</poke>
       </restriction>
       <restriction id="chkNoFavorites" name="Remove the Favorites icon" _locID="chkNoFavorites" high="on" medium="on" low="on">
        <poke resid="chkNoFavorites" regkey="Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\NoFavoritesMenu" type="REG_DWORD" on="1" off="0" delete="off">1</poke>
       </restriction>
       <restriction id="chkNoNetworkPlaces" name="Remove the My Network Places icon" _locID="chkNoNetworkPlaces" high="on" medium="on" low="on">
        <poke resid="chkNoNetworkPlaces" regkey="Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\NoStartMenuNetworkPlaces" type="REG_DWORD" on="1" off="0" delete="off">1</poke>
        <poke resid="chkNoNetworkPlaces" regkey="Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\NoNetHood" type="REG_DWORD" on="1" off="0" delete="off">1</poke>
        <poke resid="chkNoNetworkPlaces" regkey="Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\NoNetConnectDisconnect" type="REG_DWORD" on="1" off="0" delete="off">1</poke>
        <poke resid="chkNoNetworkPlaces" regkey="Software\Microsoft\Windows\CurrentVersion\Explorer\CLSID\{208D2C60-3AEA-1069-A2D7-08002B30309D}\ShellFolder\Attributes" type="REG_DWORD" on="538443776" off="0" delete="off" ignore="">538443776</poke>
        <poke resid="chkNoNetworkPlaces" regkey="Software\Microsoft\Office\10.0\Common\Open Find\Places\StandardPlaces\Publishing\Show" type="REG_DWORD" on="0" off="1" delete="off">0</poke>
        <poke resid="chkNoNetworkPlaces" regkey="Software\Microsoft\Office\11.0\Common\Open Find\Places\StandardPlaces\Publishing\Show" type="REG_DWORD" on="0" off="1" delete="off">0</poke>
        <poke resid="chkNoNetworkPlaces" regkey="Software\Microsoft\Office\12.0\Common\Open Find\Places\StandardPlaces\Publishing\Show" type="REG_DWORD" on="0" off="1" delete="off">0</poke>
       </restriction>
       <restriction id="chkNoFrequentList" name="Remove the Frequently Used Programs list" _locID="chkNoFrequentList" high="on" medium="on" low="on">
        <poke resid="chkNoFrequentList" regkey="Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\NoStartMenuMFUprogramsList" type="REG_DWORD" on="1" off="0" delete="off">1</poke>
       </restriction>
       <restriction id="chkDisableAllUsers" name="Prevent programs in the All Users folder from appearing" _locID="chkDisableAllUsers" high="on" medium="on" low="on">
        <poke resid="chkDisableAllUsers" regkey="Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\NoCommonGroups" type="REG_DWORD" on="1" off="0" delete="off">1</poke>
       </restriction>
       <restriction id="chkNoSharedDocuments" name="Remove the Shared documents folder from My Computer" _locID="chkNoSharedDocuments" high="on" medium="on" low="on" os="xp">
        <poke resid="chkNoSharedDocuments" regkey="Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\NoSharedDocuments" type="REG_DWORD" on="1" off="0" delete="off">1</poke>
       </restriction>
       <restriction id="chkNoControlPanel" name="Remove the Control Panel icon" _locID="chkNoControlPanel" high="on" medium="on" low="off">
        <poke resid="chkNoControlPanel" regkey="Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\NoControlPanel" type="REG_DWORD" on="1" off="0" delete="off">1</poke>
       </restriction>
       <restriction id="chkNoSetProgramAccess" name="Remove the Set Program Access and Defaults icon" _locID="chkNoSetProgramAccess" high="on" medium="on" low="on">
        <poke resid="chkNoSetProgramAccess" regkey="Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\NoSMConfigurePrograms" type="REG_DWORD" on="1" off="0" delete="off">1</poke>
       </restriction>
       <restriction id="chkNoNetworkConnections" name="Remove the Network Connections (Connect To) icon" _locID="chkNoNetworkConnections" high="on" medium="on" low="off">
        <poke resid="chkNoNetworkConnections" regkey="Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\NoNetworkConnections" type="REG_DWORD" on="1" off="0" delete="off">1</poke>
       </restriction>
       <restriction id="chkNoPrinterFaxes" name="Remove the Printers and Faxes icon" _locID="chkNoPrinterFaxes" high="on" medium="off" low="off">
        <poke resid="chkNoPrinterFaxes" regkey="Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Start_ShowPrinters" type="REG_DWORD" on="0" off="1" delete="">1</poke>
       </restriction>
       <restriction id="chkNoSearchCommand" name="Remove the Search icon (Windows XP only)" _locID="chkNoSearchCommand" high="on" medium="off" low="off">
        <poke resid="chkNoSearchCommand" regkey="Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\NoFind" type="REG_DWORD" on="1" off="" delete="off">0</poke>
       </restriction>
       <restriction id="chkNoRunCommand" name="Remove the Run icon" _locID="chkNoRunCommand" high="on" medium="on" low="off">
        <poke resid="chkNoRunCommand" regkey="Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\NoRun" type="REG_DWORD" on="1" off="0" delete="off">1</poke>
       </restriction>
       <restriction id="chkNoShutdown" name="Remove the Shut Down button" _locID="chkNoShutdown" high="on" medium="off" low="off">
        <poke resid="chkNoShutdown" regkey="Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\NoClose" type="REG_DWORD" on="1" off="0" delete="off">0</poke>
       </restriction>
       <restriction id="chkNoHelp" name="Remove the Help and Support icon" _locID="chkNoHelp" high="on" medium="off" low="off">
        <poke resid="chkNoHelp" regkey="Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\NoSMHelp" type="REG_DWORD" on="1" off="0" delete="off">0</poke>
        <poke resid="chkNoHelp" regkey="Software\Policies\Microsoft\Windows\Safer\CodeIdentifiers\0\Paths\{00000000-0000-0000-0000-000000000070}\ItemData" type="REG_SZ" on="HelpCtr.exe" off="" delete="off"></poke>
        <poke resid="chkNoHelp" regkey="Software\Policies\Microsoft\Windows\Safer\CodeIdentifiers\0\Paths\{00000000-0000-0000-0000-000000000071}\ItemData" type="REG_SZ" on="HelpPane.exe" off="" delete="off"></poke>
       </restriction>

     

     

     

     

    I have a "Vista Premium Ready"

     

    I followed the Manual, the Tech Help. I am a "power user" & a geek. I know DOS, I've been on windows since 3.1, I can manage Unix/Solaris, but this error has me SCREWED!

     

    I can't revert, nothing. I need a fix!


    I did what I thought was a fairly routine install only to discover upon reboot, that the only acount that I am able to access Vista is with the limited account I created.

     

    I swear! I am freakin' pissed. My Administror account is is blocked, my "privilaged" user account will not log on.

    I can not do anything on my PC. Please tell me you have "failsafe" soultion.


    I guess you know what I'm asking next... Please help me get this off my machine, or get me On it with elevated privlages so I preform an uninstall routine. I even went as far to preform a full OS recovery and just wipe the damn disc, but it did'nt work.


    Luckily I had systeminternals suit on a usb drive but no tools have worked so far.

     

    Question? Will I be forced to re-gain access to my PC via trojan like back orfice. Or go the route that this and and a few other Vista anoyancfes are pushing me to... use a Linux LiveCD to salvage me dat and repartition the drive. I i have to do that Ubuntu and Linux have just gained 50 seats from me and my staff.

     

    I think YOU NEED TO WARN USERS OF THE VISTA bug or vice versa before they use Steady State. The amount of support outside of the two redundant documentsis pathetic. I know I CAN NOT be the 1st and only one this has happened to. I am also aware that its not good to promptly display what harm this software can potentially do to your machine, on your spash page of the site, but I've been digging around for 2 hours to find a viable soulution.


    I also think you need to post in the manual clear fail safes... and detail instructions on what to do in a worst case senario


    I would appreciate any helpful advice.


    This SteadyState has been a real Luser Attitude Re-adjustment Tool!


    HELP!

     

    Andre S. Bexxxxxxxxxx

    onegod360@hotmail.com
    onegod360@gmail.com

    Sunday, September 7, 2008 2:42 AM

Answers

  •  

    Hi Andre, since you can use the account to log on under Safe Mode, you can disable all restrictions in Windows SteadyState and temporarily remove it via Programs and features. You can check if that resolves the issue.

    Monday, September 15, 2008 5:50 AM

All replies

  •  

    I fully understand the inconvenience you have encountered.

     

    Andre, do you mean you cannot use the account "Administrator" to log on the computer? If so, could you let me know the detail error message? Also, can you enter Safe Mode and use administrator account to log on? If you can enter Safe Mode, we can temporarily disable Windows SteadyState and then enter Normal Mode.

    Wednesday, September 10, 2008 7:20 AM
  • This is wrote I wrote to

    Judy Jiang

    v-30judj@mssupport.microsoft.com

    Microsoft Windows Vista Support Professional



    Thanks...


    Please do NOT take anything I am writing personal. I appreciate any and all help you can offer.

    1st. My telephone Number is (XXX) XXX-XXXX

    Andre X. XXXXXXXX

    I had to wait a day or two to calm down. You have no ideal. Right now I am using a live-cd Ubuntu. And I was able to get online, check email, find info as well asa few System Rescue CD/DVD's, and get the latest Ubuntu distro and some specialized tools like Nubuntu.

    So many of my peers choose to pay extra for PC's with XP. I am begining to see why.

    I was able to find decent help via Wikipedia... The Steady-State site like to support is a joke... After at least 3 hours searching it, tech-net and systeminternals I found nothing. I understand that it is a "security" issue... and I'm not likly to find ANY info as to how-to bypass it, but there should be some fail-safe for issues like mine. I can NOT be the only one this has happeded to.

    PROBLEM:

    I know ALL the basic Windows stuff. Logon on safe mode > Administrator was the very 1st thing I tried. (Suggesting such made me wonder if you even READ my support ticket!).

    So to re-iterate:

    Now... I installed "Steady-State". It &%@# my OS (Vista). When I rebooted I could only use the 'limited' account I created; and whats strange is when I did boot into safe mode the only account that worked was my normal/elevated user account. I am able to login to that under safemode and access the revovery options and CMD but get an error is I try to do a recovery. When I boot windows normally and type the same normal/elevated user account it says error/disabled.

    The main "Administrator" account does not work period.

    [ UPDATE ] Now Fri, Sept 12 I can not login using the "limited" Steady-State account...and can only login under safe-mode with my elevated user account. This is the account I installed steady state under.

    Is there anything you can do to help?

    I swear I don't think I'm ever installing anything from windows/Microsoft again.

    My primary concern is to salvage my data which at this very moment I'm looking into and gathering resources to do so using

    I don't plan to do anything that will render  C: drive unreadable, or blank until I get my data from off it to a redundant/USB drive. Then maybe (maybe), I'll think about using Vista or Microsoft again.

    Sad thing is I was a real Vista fan. I liked the new Windows Explorer Featues. and put up with the "annoyances" and installed Vista SP1, but this is the 2nd Major issue in  less than 1 year.
    Saturday, September 13, 2008 1:03 AM
  •  

    Hi Andre, since you can use the account to log on under Safe Mode, you can disable all restrictions in Windows SteadyState and temporarily remove it via Programs and features. You can check if that resolves the issue.

    Monday, September 15, 2008 5:50 AM
  • Andre,

    When you try to log in to your user profile (not admin.) are you getting the following message:

    ______________________________________________________________________________________

    Your user profile was not loaded correctly!
    You have been logged on with a temporary profile. Changes you make to this profile will be lost when you log off. Please see the event log for details or contact your administrator.

    Microsoft Product: Windows Operating System

    Version: 6.0.6000.16386

    Event

    ID: 1515

    _______________________________________________________________

    If this is your problem I have the fix for you. It happened to me for a different reason, but following the same procedures will do it, unless you have something else involved as well. Let me know if this is your problem. I know how you feel about Vista. I’ve had trouble logging into my “user profile” from day one—even did a reinstall, no difference. It got to the point where approx. 80% of the time I could not log into my "user profile". After 9 months of this I finally fixed it. So many people are having this same problem and MSN offers no support for their own product unless you want to pony up some $$. They should support what they sell.

    Tom


    Thank you! Tom

    Event Source: Microsoft-Windows-User Profiles Service

    • Edited by Bond, James Saturday, May 16, 2009 10:42 PM Part of it got deleted
    Saturday, May 16, 2009 10:37 PM