I think I have some sort of DNS issue.


  • I get this error on the working DC 

    The attempt to establish a replication link for the following writable directory partition failed. 

    I ran the PortQry Command Line Port Scanner to check if communication is ok and got this.

    Starting portqry.exe -n -e 135 -p TCP ...

    Querying target system called:

    Attempting to resolve IP address to a name...

    IP address resolved to c0001.tom

    IP address should resolve to DC2 not c0001.tom. I think I scanned the network for available IP address and found that was available then a laptop use called me a day later and said his laptop had a ip conflict. I gave him a new address but for what ever reason the above is happening, any suggestions? Everything in DNS looks right?   

    Wednesday, February 05, 2014 5:44 PM


All replies

  • When I run the same query with the fqdn instead of the ip I get.


     Starting portqry.exe -n dc2.tom -e 42 -p TCP ...

    Querying target system called:


    Attempting to resolve name to IP address...

    Failed to resolve name to IP address

    portqry.exe -n dc2.tom -e 42 -p TCP exits with return code 0x00000063.

    Wednesday, February 05, 2014 5:57 PM
  • The easiest way to check DNS is nslookup.

    try it from the server locally and from a remote machine

    Wednesday, February 05, 2014 6:14 PM
  • nslookup is resolving properly.

    Default Server:  serv1.tom

    > dc2.tom
    Server:  serv1.tom

    Name:    dc2.tom


    Wednesday, February 05, 2014 6:27 PM
  • Fixed by adding PTR in the revers look up for and
    Wednesday, February 05, 2014 6:50 PM