locked
Why is Sharepiont appending port number to public URL? RRS feed

  • Question

  • I have created an extended web application, so there are two SharePoint applications running on the same server, one on port 80 and the other on port 8081.  Internally everything is fine.

    In the extended application I installed the "Help Desk" template.

    When I try to access the extended application using the public URL, everything is fine initially, I can browse from site to site, I can browse service requests and other lists, but as soon as I try to access folders that I have created in the "Knowledge Base" SharePoint begins to append port 8081 to the public URL.  For example, let's say that my public URL is www.knowledgebase.com, SharePoint begins to reference www.knowledgebase.com:8081.  Obviously this is not going to work, NAT will not allow it.

    I can view documents in the root of the Knowledge Base, and I can upload documents to the root of the Knowledge Base, but as soon as I try to access a sub folder, the URL is wrong because SharePoint is appending the port number and the URL can not be resolved.

    I can not find anywhere in the configuration where I have asked SharePoint to do this for me.  What is going on?  This has to be something simple, but I can't seem to track it down, any suggestions would be greatly appreciated.

    Also, I am not having this trouble in the application running on port 80, but I am also not running "Help Desk" in that application.  Could this be a bug in "Help Desk"?

    • Moved by Mike Walsh FIN Monday, December 6, 2010 3:38 AM Not accessibility for the physically challenged (From:SharePoint - Accessibility (pre-SharePoint 2010))
    Wednesday, November 3, 2010 4:32 PM

All replies

  • Could you please post your AAM setting here? Please refer to http://sharepoint.microsoft.com/Blogs/fromthefield/Lists/Posts/Post.aspx?ID=8 for knowledge about AAM.

     

    And are you publishing your site through ISA http://www.isaserver.org/tutorials/How-to-Publish-Microsoft-Sharepoint-Service-ISA-Server-2006.html ?

     

     

     

    Gu Yuming

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com

    • Marked as answer by GuYuming Tuesday, November 23, 2010 3:05 AM
    • Unmarked as answer by Mike Walsh FIN Wednesday, December 8, 2010 2:18 PM
    Thursday, November 4, 2010 3:33 AM
  • I'm sorry for the late response, I did not have my email alerts confirmed.

    I have read the articles you referred me to, thank you.

    I am publishing through ISA 2004 Standard Edition, the article you refer to is related to ISA 2006.

    I am able to browse to both Sharepoint applications just fine, so NAT and ISA are configured to direct traffic properly.  Any idea why the internal port number is being appended to the URL of the additional application?

    I have also read this article:

    http://technet.microsoft.com/en-us/library/cc302627.aspx

    When I edit the rule and go to the Traffic tab nothing is editable, I can't click on "Filter" and the list of protocols is locked (i.e. greyed out), when I go to the properties of the HTTP protocol there is no option to disable "Verify normalization", is this the problem?

    Saturday, November 6, 2010 11:27 PM
  • Sorry for the delay. What about current situation?

     

    I had checked our internal support incident database and had found several similar incidents "external URL redirect to internal URL when click on folders" are caused by incorrect AAM setting:

     

    You can find you AAM setting in Central Administration->Operation->Alternate Access Mapping.

     

     

     

    Gu Yuming

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com

    Thursday, November 11, 2010 6:51 AM
  • There are five definitions in my AAM.

    The first definition is for the admin site:

    Internal URL = http://spserver:34987

    Zone = Default

    Public URL for Zone = http://spserver:34987

     

    Two AAM definitions for the application that is working just fine:

    **First address:**

    Internal URL = http://spserver

    Zone= Default

    Public URL for Zone = http://spserver

     

    **Second address:**

    Internal URL = http://www.myurl.com

    Zone = Internet

    Public URL for Zone = http://www.myurl.com

     

    Two AAM definitions for the application that is appending the port number to the public URL:

    **The first address:**

    Internal URL = http://spserver:8081

    Zone = Default

    Public URL for Zone = http://spserver:8081

     

    **The second address:**

    Internal URL = http://sharepoint.myurl.com

    Zone = Internet

    Public URL for Zone = http://sharepoint.myurl.com

     

    Please let me know if you see anything wrong with these definitions, or if you don't see anything wrong.

     

    Thanks :)

    Thursday, November 11, 2010 6:22 PM
  • So, you enter  http://sharepoint.myurl.com in browser, and  http://sharepoint.myurl.com:8081 is returned?

     

    Could you please check when the request  http://sharepoint.myurl.com goes to ISA, what address ISA use for SharePoint? The server NetBIOS name? or some IP address? You may include this address in AAM too. For example, if ISA use load balanced IP address http://192.168.1.1 to visit SharePoint, you may add

     

    Internal URL = http://192.168.1.1

    Zone = Internet

    Public URL = http://sharepoint.myurl.com/

     

     

     

    Gu Yuming

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com

    • Marked as answer by GuYuming Monday, November 22, 2010 3:49 AM
    • Unmarked as answer by plclogic Tuesday, November 23, 2010 4:02 PM
    Friday, November 12, 2010 12:10 PM
  • I'm very sorry for the late response, I was notified of your response only yesterday.

     

    Here is the problem, when I move my mouse over a link to a folder in the knowledge base portion of the template, the url that is shown is as follows:

    http://sharepoint.myurl.com:8081


    This tells me that Sharepoint is not building the links properly. 

    If I click on this link, the request never makes it to my server because my firewall does not accept traffic on port 8081.

     

    So here's the million dollar question:

    Why is Sharepoint building the URL, only for specific sub-links mind you, and including the port number? 


    Tuesday, November 23, 2010 4:02 PM
  • *ping*

     

    Any ideas?

    Wednesday, December 8, 2010 2:04 PM
  • Sorry for the delay. I may have not made it clear enough.

     

    SharePoint build URLs in the returned page (the URL you see when you move your mouse over the link) based the on the host header SharePoint received in the HTTP request and the matching Internal URL in the AAM setting.

     

    And in ISA, there is an option called forward the original host header instead of the actual one (see http://technet.microsoft.com/en-us/library/cc713327.aspx ). If you type in the address http://sharepoint.myurl.com in client browser, the host header SharePoint received maybe sharepoint.myurl.com or some other internal computer name or IP address (that you configured in ISA Web Publishing Wizard above the forward the original host header instead of the actual one check box).

     

    Most probably, you have the forward the original host header instead of the actual one unchecked. So, the host header SharePoint received from ISA is the internal computer name or IP address (for example 192.168.1.1 as in my reply before) ISA used to visit the SharePoint server on behalf of the client browser. Then, SharePoint will get the wrong matching internal URL in AAM setting and hence the URLs on the resulting page (based on the Public URL in the AAM setting) is not the one you expected.

     

    The solution is to change the forward the original host header instead of the actual one setting on ISA or add new internal address (the address ISA used to visit SharePoint) in the AAM setting as I replied before.

     

     

    Gu Yuming

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com

    Thursday, December 9, 2010 3:32 AM
  • I do actually have the "forward the original host header instead of the actual one" check box checked.

    I'm sorry if I'm missing something, but again, the URL for the link on the client clearly shows the port number, as in:

    http://sharepoint.myurl.com:8081

     

    Why is Sharepoint appending the port number to the address?

    Also, please remember, this is only happening in one specific area of the "Help Desk" template, specifically in the "Knowlege Base" portion.  The rest of the template is behaving properly.

    If the problem was in my configuration, wouldn't the entire site be having issues?  Why is this happening ONLY in the "Knowledge Base"??

    Thursday, December 9, 2010 4:02 AM
  • Thursday, December 9, 2010 5:03 AM
  • We have this same issue without having publishing thru ISA or TMG.  If an internal user's browser is set to use a proxy server, the sharepoint rendered pages show the links with addional incorrect port number appended (e.g. http://site.ky.gov:8081, https://secure.ky.gov:4433 these should be 80 and 443).  These links point to a new web server running IIS 7.5.  Public users not using proxy see the correct link.  If they users behind a web proxy these inappropriate links are displayed and they cannot reach the pages.

    So you can take publishing via ISA or TMG out of the problem.

    • Proposed as answer by Mterry_56 Friday, August 3, 2012 5:51 PM
    Friday, August 3, 2012 3:30 PM
  • Resolution to ports being added to hyperlinks in SharePoint pages.

    This was what I found and how I got to resolved it.  The SP site was published by threat management gateway (TMG) along with 40-50 other sites.  There was an additional site, one that we hoped to publish but never could get it to work properly as the same URL had both a port 80 site and a port 443 SSL site.

    The SP site where the links would show up with port numbers behind them was the water.ky.gov site.  I went thru the published rule and on the link translation tab found “Apply link translation to this rule” checked. 

    After clicking the Mappings button, I got a long table of all of the link mappings

    The bottom few rows had the problematic site with a translated URL with: 4433 appended and it said that rule dep.gateway.ky.gov under mapping details.

    When I found the rule it was from an attempt to publish the gateway site thru TMG that had been abandoned, however the rule was still active.  At some point a listener for port 4433 had been created for the rule.  I first tried disabling the rule.  However it took removing the rule and the listener and waiting approximately ½ an hour for the issue to go away.

    It is strange that the page only reflected the appended ports when viewed thru a browser that used a proxy server.  I have no explanation for that.

    hope some of this helps

    • Proposed as answer by Mterry_56 Friday, August 3, 2012 5:52 PM
    Friday, August 3, 2012 5:52 PM