locked
DFS Replication only working one-way RRS feed

  • Question

  • I've got two servers in a replication group where replication is only occurring one-way.  I get daily backlog status reports and weekly health reports and there has been no error indicating this.  There are still is no errors in either of these reports.  Replication from Server1 to Server2 happens instantly.  Nothing has replicated form Server2 to Server1 withing the past 24hrs.  I've restarted both servers.  What is really concerning is that the reports show everything is fine... What gives?  

       

    • Server1 = Server 2008R2 SP1 with all DFSR updates installed
    • Server2 = Server 2012
    • Server1 -> Server2 = Replicates OK
    • Server2 -> Server1 = No Replication
    • Replication Health Reports produce fine and don't show any backlog
    • Backlog status reports show that there is no backlog
    • I've reviewed the DFSR logs on both servers and can't find anything out of the ordinary.  

       

    Backlog Status Report (run from server2.  I get the same results when I run it from Server1):




    • Edited by Caleb44 Friday, April 12, 2013 7:15 PM
    Friday, April 12, 2013 7:12 PM

Answers

  • Opened a support case with Microsoft.  It ended up being something with TCP Chimney or other TCP features.  They had me run this on the Server2012 box, restart it and everything worked fine after about 5-10 min after the reboot:

    netsh interface tcp set global chimney=disabled

    netsh interface tcp set global rss=disabled

    netsh int tcp set global autotuning=disabled

    netsh int tcp set global congestion=none

    netsh int tcp set global netdma=Disabled

    • Marked as answer by Caleb44 Monday, April 22, 2013 9:58 PM
    Monday, April 22, 2013 9:57 PM

All replies

  • Hi,

    First you could refer to this article for some common issues of DFSR. See if it could provide some clues of current situation.

    http://blogs.technet.com/b/askds/archive/2007/10/05/top-10-common-causes-of-slow-replication-with-dfsr.aspx

    Meanwhile here is a thread with similar issue, which is finally resolved by re-config the DFS settings:

    http://social.technet.microsoft.com/Forums/en-US/winserverfiles/thread/644840ea-c6b3-463e-b972-2638a017e4a6


    TechNet Subscriber Support in forum |If you have any feedback on our support, please contact tnmff@microsoft.com.

    Tuesday, April 16, 2013 1:18 AM
  • Thanks Shaon.

    I took a look at both of those links.  I'm open to rebuilding this replication group as a last resort, but I don't see this as the first option.  Also, the one thing that differs from the scenario in your second link is that DFS was actually reporting a backlog, which it is not in our scenario.  I also looked through the 10 common causes of slow replication.  I found that a propagation test reports accurately that files are not being replicated.  I then performed a  backlog status check and it says both members are in sync and have no backlog.  It's flat out wrong!  I'd like to find out what the backlog status check actually checks to determine why it's producing a false positive.  The same goes for a health report, as the health report produces a false positive as well.  Can you tell me what these reports are checking and what may be causing them to produce false positives?


    All that said, after roughly two days, I noticed a test file I had created finally replicated.  I'm doing another test to confirm those results.  These servers are also on a Gigabit Lan.  


    • Edited by Caleb44 Tuesday, April 16, 2013 4:56 PM
    Tuesday, April 16, 2013 4:52 PM
  • I did a Propagation test and here are the results:

    4Days 14hr. 50min to replication a file.  Any ideas? 


    • Edited by Caleb44 Monday, April 22, 2013 6:55 PM
    Monday, April 22, 2013 4:27 PM
  • Opened a support case with Microsoft.  It ended up being something with TCP Chimney or other TCP features.  They had me run this on the Server2012 box, restart it and everything worked fine after about 5-10 min after the reboot:

    netsh interface tcp set global chimney=disabled

    netsh interface tcp set global rss=disabled

    netsh int tcp set global autotuning=disabled

    netsh int tcp set global congestion=none

    netsh int tcp set global netdma=Disabled

    • Marked as answer by Caleb44 Monday, April 22, 2013 9:58 PM
    Monday, April 22, 2013 9:57 PM
  • We had exactly the same problem. This solution works.



    MCTS: Messaging | MCSE: S+M

    Friday, December 4, 2015 10:14 AM
  • Glad I could be of help.  :)
    Monday, December 7, 2015 5:12 PM
  • Yes , this worked like charm.

    Best Regards, Dinesh Patil. MCP-Windows Server 2003 Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights. If you satisfied with answer,please click on Proposed as answer key.

    Thursday, June 2, 2016 7:38 AM
  • Same problem, worked a treat - and didn't have to reboot in my case.  Thanks!
    Friday, May 19, 2017 6:55 PM